Skip to content

Commit

Permalink
dev-python/executing: add patch for new slow tests
Browse files Browse the repository at this point in the history
The original skips are technically for tests that take a long time to
run, which these aren't really - they just fail if run under a
sufficiently slow CPU since they are measuring a hard real-time
benchmark.  Already accepted upstream.

See: alexmojaki/executing#78
Bug: https://bugs.gentoo.org/909738
Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk>
  • Loading branch information
matoro committed Nov 7, 2023
1 parent 21377ec commit cedac59
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/executing/executing-2.0.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -32,6 +32,8 @@ BDEPEND="
)
"

PATCHES=( "${FILESDIR}/${PN}-2.0.1-additional-slow-tests.patch" )

distutils_enable_tests pytest

export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
https://bugs.gentoo.org/show_bug.cgi?id=909738
https://github.com/alexmojaki/executing/pull/78

From 9990d20a28d46e8a911c370a019f9231cad977f0 Mon Sep 17 00:00:00 2001
From: matoro <matoro@users.noreply.github.com>
Date: Sun, 5 Nov 2023 19:54:34 -0500
Subject: [PATCH] Add many_calls tests to EXECUTING_SLOW_TESTS

---
tests/test_main.py | 8 ++++++++
1 file changed, 8 insertions(+)

diff --git a/tests/test_main.py b/tests/test_main.py
index 7e33247..bc015cd 100644
--- a/tests/test_main.py
+++ b/tests/test_main.py
@@ -279,6 +279,10 @@ def test_future_import(self):
print(1 / 2)
tester(4)

+ @pytest.mark.skipif(
+ not os.getenv("EXECUTING_SLOW_TESTS"),
+ reason="These tests are very slow, enable them explicitly",
+ )
def test_many_calls(self):
node = None
start = time.time()
@@ -290,6 +294,10 @@ def test_many_calls(self):
self.assertIs(node, new_node)
self.assertLess(time.time() - start, 1)

+ @pytest.mark.skipif(
+ not os.getenv("EXECUTING_SLOW_TESTS"),
+ reason="These tests are very slow, enable them explicitly",
+ )
def test_many_source_for_filename_calls(self):
source = None
start = time.time()

0 comments on commit cedac59

Please sign in to comment.