Skip to content

Commit

Permalink
php: Build minilua for build host
Browse files Browse the repository at this point in the history
see https://bugs.php.net/bug.php?id=80717&edit=1

Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Nov 13, 2021
1 parent 7175f8b commit ce3a46e
Show file tree
Hide file tree
Showing 3 changed files with 22 additions and 35 deletions.

This file was deleted.

Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
From 73ea1d44c1e6b063bfa02e12919ec8a9de3709d8 Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Wed, 3 Feb 2021 22:51:34 +0100
Subject: [PATCH] Fix opcache jit minilua compiling

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
---
ext/opcache/jit/Makefile.frag | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--- a/ext/opcache/jit/Makefile.frag
+++ b/ext/opcache/jit/Makefile.frag
@@ -1,6 +1,6 @@

$(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
- $(CC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@
+ $(HOSTCC) $(srcdir)/jit/dynasm/minilua.c -lm -o $@

$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
$(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
8 changes: 2 additions & 6 deletions meta-oe/recipes-devtools/php/php_8.0.12.bb
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ SRC_URI:append:class-target = " \
file://0006-ext-phar-Makefile.frag-Fix-phar-packaging.patch \
file://0007-sapi-cli-config.m4-fix-build-directory.patch \
file://0008-ext-imap-config.m4-fix-include-paths.patch \
file://0011-opcache-jit-use-minilua-in-sysroot.patch \
file://1010-Fix-opcache-jit-minilua-compiling.patch \
file://php-fpm.conf \
file://php-fpm-apache.conf \
file://70_mod_php${PHP_MAJOR_VERSION}.conf \
Expand Down Expand Up @@ -108,6 +108,7 @@ PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valg
PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma"
PACKAGECONFIG[mbstring] = "--enable-mbstring,,"

export HOSTCC = "${BUILD_CC}"
export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN = "${STAGING_BINDIR_NATIVE}/php"
CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2"
Expand Down Expand Up @@ -258,13 +259,8 @@ RCONFLICTS:${PN}-modphp = "${MODPHP_OLDPACKAGE}"
do_install:append:class-native() {
create_wrapper ${D}${bindir}/php \
PHP_PEAR_SYSCONF_DIR=${sysconfdir}/

if [ "$MACHINE_ARCH" == "x86" || "$MACHINE_ARCH" == "x86-64" ]; then
install -m 0755 ${WORKDIR}/build/ext/opcache/minilua ${D}${bindir}/
fi
}


# Fails to build with thumb-1 (qemuarm)
# | {standard input}: Assembler messages:
# | {standard input}:3719: Error: selected processor does not support Thumb mode `smull r0,r2,r9,r3'
Expand Down

0 comments on commit ce3a46e

Please sign in to comment.