Skip to content

Commit

Permalink
mraa: Fix build on x86 32bit
Browse files Browse the repository at this point in the history
Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Mar 8, 2020
1 parent d62b225 commit 7e6305d
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 5de183dc436bb647361ab641d891c113e6a7dadd Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 8 Mar 2020 16:30:48 -0700
Subject: [PATCH] cmake: Use a regular expression to match x86 architectures

in OE we use i686 for qemux86 and this results in

-- INFO - Target arch is i686
CMake Error at CMakeLists.txt:191 (message):
Only x86, arm, mips, PERIPHERALMAN and mock platforms currently supported

So using a wildcard helps in using any x86 arch

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
CMakeLists.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 250d9106..fb642722 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -176,8 +176,7 @@ else ()
message (STATUS "INFO - Override arch is ${DETECTED_ARCH}")
endif()

-if (DETECTED_ARCH STREQUAL "i586" OR DETECTED_ARCH STREQUAL "x86_64"
- OR DETECTED_ARCH STREQUAL "i386")
+if (DETECTED_ARCH MATCHES "i?86" OR DETECTED_ARCH STREQUAL "x86_64")
set (X86PLAT ON)
elseif (DETECTED_ARCH MATCHES "arm.*" OR DETECTED_ARCH MATCHES "aarch64")
set (ARMPLAT ON)
--
2.25.1

3 changes: 3 additions & 0 deletions meta-oe/recipes-extended/mraa/mraa_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -9,6 +9,7 @@ SRCREV = "e15ce6fbc76148ba8835adc92196b0d0a3f245e7"
PV = "2.1.0+git${SRCPV}"

SRC_URI = "git://github.com/eclipse/${BPN}.git;protocol=http \
file://0001-cmake-Use-a-regular-expression-to-match-x86-architec.patch \
"

S = "${WORKDIR}/git"
Expand Down Expand Up @@ -60,3 +61,5 @@ RDEPENDS_node-${PN} += "nodejs"
### Include desired language bindings ###
PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'nodejs', 'node-${PN}', '', d)}"
PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'python', '${PYTHON_PN}-${PN}', '', d)}"

TOOLCHAIN = "gcc"

0 comments on commit 7e6305d

Please sign in to comment.