Skip to content

Commit

Permalink
lockdev: Switch to use archive tarballs for SRC_URI
Browse files Browse the repository at this point in the history
anonscm.debian.org has been replaced with https://salsa.debian.org
however, lockdev has been dropped from debian packages, so its not
maintained at salsa.debian.org, therefore resort to archives and add few
more fixes to get it building from archive.

bump PE since version still remains 1.0.3 but we drop +git${...} from PV

Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Jan 14, 2019
1 parent 6fc561c commit 1ed152e
Show file tree
Hide file tree
Showing 5 changed files with 82 additions and 54 deletions.

This file was deleted.

28 changes: 28 additions & 0 deletions meta-oe/recipes-support/lockdev/lockdev/build.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
commit 0dd47123655c52d68185f06b9da8fb0e1b925400
Author: Ludwig Nussel <ludwig.nussel@suse.de>
Date: Tue Feb 9 14:56:23 2010 +0100

RedHat patch 2

- change library file name
- install devel symlink

--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ VER = $(shell expr `pwd` : '.*-\([0-9.]*
MVER = ${shell expr `pwd` : '.*-\([0-9]*\).[0-9]*'}

static = ${libname}.a
-shared = ${libname}.${VER}.so
+shared = ${libname}.so.${VER}
soname = ${libname}.so.${MVER}

# overwritten by caller (e.g.: debian/rules)
@@ -72,6 +72,7 @@ install_doc: docs/lockdev.3
install_run: ${shared}
install -m755 -d ${libdir}
install -m644 ${shared} ${libdir}
+ ln -s ${shared} ${libdir}/liblockdev.so

.PHONY: clean distclean perl-clean mostyclean
perl-clean: clean
25 changes: 25 additions & 0 deletions meta-oe/recipes-support/lockdev/lockdev/cross_compile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
--- a/Makefile
+++ b/Makefile
@@ -15,17 +15,17 @@ shared = ${libname}.${VER}.so
soname = ${libname}.so.${MVER}

# overwritten by caller (e.g.: debian/rules)
-basedir = /usr/local
+basedir ?= /usr/local
srcdir=.

libdir = ${basedir}/lib
incdir = ${basedir}/include
mandir = ${basedir}/share/man

-CC = gcc
-LCFLAGS = -g -O2 -fPIC -Wall -pipe -D_REENTRANT
-CFLAGS = -g
-LDLIBS = -llockdev
+CC ?= gcc
+LCFLAGS ?= -g -O2 -fPIC -Wall -pipe -D_REENTRANT
+CFLAGS ?= -g
+LDLIBS ?= -llockdev

.PHONY: shared static perl-lib
ALL: shared static perl-lib
29 changes: 29 additions & 0 deletions meta-oe/recipes-support/lockdev/lockdev_1.0.3.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
SUMMARY = "Locking devices library"
SECTION = "libs"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM="file://LICENSE;md5=d8045f3b8f929c1cb29a1e3fd737b499"

PE = "1"
SRC_URI = "http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/l/lockdev/lockdev_${PV}.orig.tar.gz \
http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/l/lockdev/lockdev_${PV}-1.6.diff.gz;name=debianpatch \
file://cross_compile.patch \
file://build.patch \
"
SRC_URI[md5sum] = "64b9c1b87b125fc348e892e24625524a"
SRC_URI[sha256sum] = "ccae635d7ac3fdd50897eceb250872b3d9a191d298f213e7f0c836910d869f82"
SRC_URI[debianpatch.md5sum] = "5ef6267c42fca9145e0af006ccb6aff7"
SRC_URI[debianpatch.sha256sum] = "a5405c6ee5e97e45eeb1c81330a7e9f444a58bda5e6771fa30007516c115007e"

inherit lib_package perlnative
export basedir="${D}${prefix}"

CFLAGS += " -D__GNU_LIBRARY__"

TARGET_CC_ARCH += "${LDFLAGS}"

do_compile() {
oe_runmake basedir=${D}${prefix} LD="${CC}" LD="${CC}" shared static
}
do_install() {
oe_runmake DESTDIR=${D} basedir=${D}${prefix} install
}
24 changes: 0 additions & 24 deletions meta-oe/recipes-support/lockdev/lockdev_git.bb

This file was deleted.

0 comments on commit 1ed152e

Please sign in to comment.