Skip to content

Commit

Permalink
salt: Autospec creation for update from version 3003 to version 3003.1
Browse files Browse the repository at this point in the history
Bryce Larson (5):
      add ubuntu-2004-amd64 m2crypto pycryptodome and tcp tests
      add distro_arch
      changing the cloud platforms file missed in 1a9b7be0e2f300d87924731dc5816fd1000cd22b
      fix github actions jobs on branch until bullseye comes out
      add changelog for saltstack/salt#59982

Daniel A. Wozniak (17):
      Use contextvars from site-packages for thin
      Add regression test for #59942
      Add changelog for #59942
      Update filemap to include test_py_versions
      Fix broken thin tests
      Fix thin tests on windows
      No need to use warn log level here
      Fix getsitepackages for old virtualenv versions
      Fix issue #59975
      Fix pillar serialization for jinja #60083
      Fix test
      Add changelog for #60083
      Add connect to IPCMessageSubscriber's async_methods
      Add changelog for #60049
      Regression test for #56273
      Fix race condition in batch. #56273
      Add changelog for #56273

Daniel Wozniak (1):
      Update salt/client/__init__.py

Frode Gundersen (5):
      update releasenotes 3003
      Update docs
      Update docs
      Update CHANGELOG.md
      Update 3003.1.rst

Gareth J. Greenaway (1):
      Update 60049.fixed

Megan Wilhite (5):
      Update __utils__ calls to import utils in azure
      Add changelog for 59744
      Fix azure unit tests and move to pytest
      Fix coroutine spelling error
      Update doc for salt/client

Pedro Algarvio (9):
      Always install the `contextvars` backport, even on Py3.7+
      Use salt-factories to handle the container. Don't override default roster
      Bump requirements to address a few security issues
      Address traceback on macOS
      Replace `saltstack.com` with `saltproject.io` on URLs being tested
      Add back support to load old entrypoints by iterating instead of type checking
      IPC on windows cannot use socket paths
      Update Jinja2 and lxml due to security related bugfix releases
      Upgrade to `six==1.16.0` to avoid problems on CI runs

ScriptAutomate (5):
      Bugfix release docs
      Bugfix release docs
      Removing pip-compile log files
      Update changelog and release for 3003.1
      Remove the changelog source refs

Wayne Werner (1):
      Update changelog/56273.fixed

twangboy (3):
      Add explicit pyobjc reqs
      Add back the passthrough stuff
      Remove a line so pre-commit will run
  • Loading branch information
phmccarty committed Jun 24, 2021
1 parent 2f9ce86 commit 3ca5d7a
Show file tree
Hide file tree
Showing 11 changed files with 43 additions and 14 deletions.
21 changes: 21 additions & 0 deletions 0001-Remove-dep-on-contextvars.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Patrick McCarty <patrick.mccarty@intel.com>
Date: Thu, 24 Jun 2021 14:17:42 -0700
Subject: [PATCH] Remove dep on contextvars

This package has been part of the stdlib since 3.7...

Signed-off-by: Patrick McCarty <patrick.mccarty@intel.com>
---
requirements/base.txt | 1 -
1 file changed, 1 deletion(-)

diff --git a/requirements/base.txt b/requirements/base.txt
index 96037cc..712dcca 100644
--- a/requirements/base.txt
+++ b/requirements/base.txt
@@ -4,4 +4,3 @@ PyYAML
MarkupSafe
requests>=1.0.0
distro>=1.0.1
-contextvars
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := salt
URL = https://github.com/saltstack/salt/releases/download/v3003/salt-3003.tar.gz
URL = https://github.com/saltstack/salt/releases/download/v3003.1/salt-3003.1.tar.gz
ARCHIVES =

include ../common/Makefile.common
1 change: 1 addition & 0 deletions buildreq_ban
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
# This file contains build requirements that get picked up but are
# undesirable. One entry per line, no whitespace.
contextvars
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = salt
url = https://github.com/saltstack/salt/releases/download/v3003/salt-3003.tar.gz
url = https://github.com/saltstack/salt/releases/download/v3003.1/salt-3003.1.tar.gz
archives =
giturl = https://github.com/saltstack/salt.git
domain =
Expand Down
1 change: 1 addition & 0 deletions python3_requires_ban
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
pypi(contextvars)
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
15
16
1 change: 1 addition & 0 deletions requires_ban
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
# This file contains runtime requirements that get picked up but are
# undesirable. One entry per line, no whitespace.
contextvars
22 changes: 13 additions & 9 deletions salt.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : salt
Version : 3003
Release : 15
URL : https://github.com/saltstack/salt/releases/download/v3003/salt-3003.tar.gz
Source0 : https://github.com/saltstack/salt/releases/download/v3003/salt-3003.tar.gz
Version : 3003.1
Release : 16
URL : https://github.com/saltstack/salt/releases/download/v3003.1/salt-3003.1.tar.gz
Source0 : https://github.com/saltstack/salt/releases/download/v3003.1/salt-3003.1.tar.gz
Summary : Portable, distributed, remote execution and configuration management system
Group : Development/Tools
License : Apache-2.0
Expand All @@ -32,6 +32,7 @@ BuildRequires : msgpack
BuildRequires : pycryptodomex
BuildRequires : pyzmq
BuildRequires : requests
Patch1: 0001-Remove-dep-on-contextvars.patch

%description
Salt is a distributed remote execution system used to execute commands and
Expand Down Expand Up @@ -94,15 +95,16 @@ python3 components for the salt package.


%prep
%setup -q -n salt-3003
cd %{_builddir}/salt-3003
%setup -q -n salt-3003.1
cd %{_builddir}/salt-3003.1
%patch1 -p1

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1617648680
export SOURCE_DATE_EPOCH=1624569670
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -118,8 +120,9 @@ python3 setup.py build
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/salt
cp %{_builddir}/salt-3003/LICENSE %{buildroot}/usr/share/package-licenses/salt/c0f0fb1c856a87d9fc4a59bd2ec0d6b19907a94f
cp %{_builddir}/salt-3003/pkg/windows/installer/LICENSE.txt %{buildroot}/usr/share/package-licenses/salt/712d25aaeea79cb25612195315109efc884cc5d6
cp %{_builddir}/salt-3003.1/LICENSE %{buildroot}/usr/share/package-licenses/salt/c0f0fb1c856a87d9fc4a59bd2ec0d6b19907a94f
cp %{_builddir}/salt-3003.1/pkg/osx/pkg-resources/license.rtf %{buildroot}/usr/share/package-licenses/salt/906ed1fd66d444e951c0f5f38131d1dd61dfcf7c
cp %{_builddir}/salt-3003.1/pkg/windows/installer/LICENSE.txt %{buildroot}/usr/share/package-licenses/salt/712d25aaeea79cb25612195315109efc884cc5d6
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand Down Expand Up @@ -148,6 +151,7 @@ echo ----[ mark ]----
%files license
%defattr(0644,root,root,0755)
/usr/share/package-licenses/salt/712d25aaeea79cb25612195315109efc884cc5d6
/usr/share/package-licenses/salt/906ed1fd66d444e951c0f5f38131d1dd61dfcf7c
/usr/share/package-licenses/salt/c0f0fb1c856a87d9fc4a59bd2ec0d6b19907a94f

%files man
Expand Down
1 change: 1 addition & 0 deletions series
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
0001-Remove-dep-on-contextvars.patch
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
c65f660de100f8af9f318ff19dbb9bf632955701/salt-3003.tar.gz
931e1cc51c4d75f3ad60ca17f05152c4ca3c1426/salt-3003.1.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3003
3003.1

0 comments on commit 3ca5d7a

Please sign in to comment.