Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 72.1.0 to …
Browse files Browse the repository at this point in the history
…version 72.2.0

Christoph Reiter (6):
      find_library_file: port from doctest to normal test and fix for cygwin
      test_customize_compiler_with_msvc_python: skip for cygwin
      CI: add a job for running tests under MSVC CPython with GCC as the default compiler
      mingw: make get_msvcr() a noop
      venv_install_options: add missing clear_argv fixture
      Remove unused RangeMap

Jason R. Coombs (42):
      👹 Feed the hobgoblins (delint).
      👹 Feed the hobgoblins (delint).
      Adjust expectation to match behavior.
      For consistency, ensure Extension.sources is always a pathlib.Path object and adjust expectations in tests.
      When computing input_opt, ensure src is a string (when it could be a pathlib Path).
      In filelist, allow for self.files to be pathlib objects.
      Revert "Disable cygwin tests for now. Ref pypa/setuptools#3921"
      Simply accept pathlib objects and convert them early for compatibilty with upstream.
      Reword docs on 'Build system requirement' to use imperative voice.
      Add guidance on pinning the upper bound in build-system.requires.
      Pin towncrier in docs build.
      Prefer f-strings
      Need to include 'three' in the input.
      Consolidate str and Path handling.
      Remove r string now that docstring is gone.
      Expand convert_path to also accept pathlib.Path objects.
      👹 Feed the hobgoblins (delint).
      Prefer simply 'pathlib' for import.
      👹 Feed the hobgoblins (delint).
      Extract a singledispatchmethod _copy for handling the copy of each data file.
      Use explicit registration for compatibility with older Pythons.
      Prefer os.PathLike in convert_path
      Convert needs to accept None for Setuptools' sake.
      In test_convert_path, utilize posixpath.join and ntpath.join for maximum compatibility with other libraries.
      Wrap paths in PurePosixPath to ensure that any WindowsPaths don't get backslashes.
      convert_path no longer fails if passed a path with a trailing slash. Instead, trailing slashes are stripped just as they are with pathlib.Path.
      convert_path now converts to a platform-native path.Path, but then calls `.as_posix()` on it.
      Separate test_convert_path into two tests to avoid interactions in monkeypatching os.path.
      Remove expectation that a ValueError is raised for data_files being drive-relative absolute on Windows.
      Simplify convert_path by simply relying on the logic in PurePath.
      Harmonize convert_path tests across Unix and Windows.
      Consolidate convert_path tests and just generate the expected value in a platform-sensitive way. Should fix failures on mingw.
      Harmonize '-shared' parameter for C and C++ in Mingw32CCompiler
      In sysconfig.customize_compiler, initialize ldcxxshared from config vars.
      Refactored customize_compiler to reduce logical branches and extract _add_flags logic.
      Use simple import
      Don't add flags when the value is None, such as when on PyPy, LDCXXSHARED is unset.
      Rely on monkeysession to monkeypatch.
      Apply isort. Ref pypa/distutils#240
      Add news fragment.
      Correct reference in news fragment. Ref #4539
      Bump version: 72.1.0 → 72.2.0

Michael Carlstrom (1):
      Allow path objects

Mridul Seth (1):
      ENH: Extension should be able to accept PathLike sources objects

Samuel Cormier-Iijima (3):
      Distutils C++ support
      Adjust tests further to accommodate C++ support.
      Ignore sysconfig variables for LDCXXSHARED as it appears not to exist on PyPy.

connortann (1):
      [Docs] Minor grammar fix in dependency_management.rst
  • Loading branch information
fenrus75 committed Aug 13, 2024
1 parent bc4e20d commit d5a0806
Show file tree
Hide file tree
Showing 5 changed files with 13 additions and 13 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/5e/11/487b18cc768e2ae25a919f230417983c8d5afa1b6ee0abd8b6db0b89fa1d/setuptools-72.1.0.tar.gz
URL = https://files.pythonhosted.org/packages/ce/ef/013ded5b0d259f3fa636bf35de186f0061c09fbe124020ce6b8db68c83af/setuptools-72.2.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/5e/11/487b18cc768e2ae25a919f230417983c8d5afa1b6ee0abd8b6db0b89fa1d/setuptools-72.1.0.tar.gz
url = https://files.pythonhosted.org/packages/ce/ef/013ded5b0d259f3fa636bf35de186f0061c09fbe124020ce6b8db68c83af/setuptools-72.2.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
18 changes: 9 additions & 9 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,13 @@
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v18
# autospec commit: 356da62
# autospec commit: f35655a
#
Name : pypi-setuptools
Version : 72.1.0
Release : 332
URL : https://files.pythonhosted.org/packages/5e/11/487b18cc768e2ae25a919f230417983c8d5afa1b6ee0abd8b6db0b89fa1d/setuptools-72.1.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/5e/11/487b18cc768e2ae25a919f230417983c8d5afa1b6ee0abd8b6db0b89fa1d/setuptools-72.1.0.tar.gz
Version : 72.2.0
Release : 333
URL : https://files.pythonhosted.org/packages/ce/ef/013ded5b0d259f3fa636bf35de186f0061c09fbe124020ce6b8db68c83af/setuptools-72.2.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/ce/ef/013ded5b0d259f3fa636bf35de186f0061c09fbe124020ce6b8db68c83af/setuptools-72.2.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : Apache-2.0 BSD-2-Clause MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -63,18 +63,18 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-72.1.0
cd %{_builddir}/setuptools-72.1.0
%setup -q -n setuptools-72.2.0
cd %{_builddir}/setuptools-72.2.0
pushd ..
cp -a setuptools-72.1.0 buildavx2
cp -a setuptools-72.2.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1722275994
export SOURCE_DATE_EPOCH=1723569697
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
332
333
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
c971c6c465274b717f15f02e99088f95ed11afbd/setuptools-72.1.0.tar.gz
7f891dbb3eeb76f6a3e1664b543e5b268733bcb8/setuptools-72.2.0.tar.gz

0 comments on commit d5a0806

Please sign in to comment.