Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 67.8.0 to …
Browse files Browse the repository at this point in the history
…version 68.0.0

Anderson Bravalheri (25):
      Temporarily disable deprecation enforcements
      Fix test_pip_upgrade_from_source
      Avoid _distutils_hack.remove_shim on Python >= 3.12
      Add news fragment
      Simplify exporting of remove_shim for Python < 3.12
      Speed-up comparison for spect_for_pip
      Mention PEP 632 in comment
      Remove py34compat
      Remove py36compat
      Implement workaround for missing '-requiresAny' (only available on VS 2017 > 15.6)
      Add news fragment
      Mention 'packaging' on pkg_resources deprecation notes
      Add news fragment
      Add '.txt' extension to examples of tool.setuptools.dynamic.readme.file
      Remove deprecated setuptools.dist._get_unpatched
      Remove deprecated autofixing of broken egg-info folder (using '-')
      Remove deprecated APIs in easy_install
      Remove deprecated egg_info.get_pkg_info_revision
      Remove reminiscent depends.txt chech (depends.txt is deprecated)
      Stop ignoring invalid pyproject.toml
      Remove deprecated SVN support for package_index
      Add news fragment
      Re-enable SETUPTOOLS_ENFORCE_DEPRECATION
      Leave an empty 'egg_info.warn_depends_obsolete' to avoid erros when updating from source
      Bump version: 67.8.0 → 68.0.0

Chris Pryer (1):
      Fix dependency_management.rst typo

Christian Clauss (1):
      Avoid duplication in warning text

Dave Brondsema (2):
      Show source location and link to more info, from pkg_resources deprecation
      Use issue_warning helper to get best stacklevel (sometimes it could point to ResourceManager.resource_filename not user code)

Diego Ramirez (1):
      Remove a typo

Jason R. Coombs (22):
      ⚫ Fade to black.
      Fix EncodingWarning in finalize.
      Refresh vendored dependencies
      ⚫ Fade to black.
      Return discovered msbuild_path value.
      Rewrite get_msbuild to unconditionally use vswhere. Resolve values naturally to avoid reliance on shell.
      Locate CMake deterministically using registry.
      Move attribute docstring to after the attribute.
      Update the module docstring.
      Re-use global get_* functions.
      Convert subprocess calls to use explicit parameters.
      Extract function for resolve_platform.
      Extract function for doing the build.
      Generate a temporary directory for the build arena.
      Use itertools.product instead of nested loops.
      Rebuilt the executables.
      Make substitution fields more prominent and distinct from true 'skeleton' references. (#71)
      Suppress EncodingWarning in build.env. Ref pypa/build#615.
      Remove reference to EncodingWarning as it doesn't exist on some Pythons.
      Update RTD boilerplate to new issue. Ref readthedocs/readthedocs.org#10401.
      Add badge for Ruff.
      Remove inclusion of python version for docs

Marvin Gravert (1):
      fixes spelling mod->module

Ronnie Dutta (2):
      Update vendored `packaging` to 23.1
      Changelog

Steve Kowalik (1):
      tests: Add extraction_filter for tarfile

Yevhenii Sevostianov (7):
      enable symlink for win
      add changelog info
      introduce proper build script on python
      nits
      nits
      fix issues
      update the way we pass definitions to cmake
  • Loading branch information
fenrus75 committed Jun 20, 2023
1 parent 765c101 commit 334af13
Show file tree
Hide file tree
Showing 5 changed files with 12 additions and 12 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
URL = https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
url = https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
16 changes: 8 additions & 8 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -4,10 +4,10 @@
# Using build pattern: distutils3
#
Name : pypi-setuptools
Version : 67.8.0
Release : 302
URL : https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/03/20/630783571e76e5fa5f3e9f29398ca3ace377207b8196b54e0ffdf09f12c1/setuptools-67.8.0.tar.gz
Version : 68.0.0
Release : 303
URL : https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/dc/98/5f896af066c128669229ff1aa81553ac14cfb3e5e74b6b44594132b8540e/setuptools-68.0.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : MIT Python-2.0 ZPL-2.0
Expand Down Expand Up @@ -61,18 +61,18 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-67.8.0
cd %{_builddir}/setuptools-67.8.0
%setup -q -n setuptools-68.0.0
cd %{_builddir}/setuptools-68.0.0
pushd ..
cp -a setuptools-67.8.0 buildavx2
cp -a setuptools-68.0.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1684611878
export SOURCE_DATE_EPOCH=1687274276
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
302
303
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
04950ca6fa24599bd996fdbfb8d0a869d74cc8da/setuptools-67.8.0.tar.gz
11a0ee6ae1f2dcb1bdc673dc66ee3f62db59c840/setuptools-68.0.0.tar.gz

0 comments on commit 334af13

Please sign in to comment.