Skip to content

Commit

Permalink
pypi-jaraco.functools: Autospec creation for update from version 3.6.…
Browse files Browse the repository at this point in the history
…0 to version 3.7.0

Jason R. Coombs (9):
      Remove unnecessary and incorrect copyright notice. Fixes jaraco/skeleton#78.
      Replace flake8 with ruff. Fixes jaraco/skeleton#79 and sheds debt.
      Make substitution fields more prominent and distinct from true 'skeleton' references. (#71)
      Suppress EncodingWarning in build.env. Ref pypa/build#615.
      Remove reference to EncodingWarning as it doesn't exist on some Pythons.
      Add pass_through_when.
      Rely on boolean value of check. Use mutability for dynamic behavior.
      Invert the logic and rename the function to 'bypass_unless'
      Refactor as 'bypass_when' and 'bypass_unless' because one is likely much more useful to the caller than the other.

Joyce (1):
      Feat: initial permissions to main.yml (jaraco/skeleton#76)
  • Loading branch information
fenrus75 committed May 29, 2023
1 parent a55671a commit aa81729
Show file tree
Hide file tree
Showing 5 changed files with 22 additions and 20 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-jaraco.functools
URL = https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
URL = https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
6 changes: 4 additions & 2 deletions options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-jaraco.functools
url = https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
url = https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
archives =
giturl = https://github.com/jaraco/jaraco.functools/
domain =
Expand All @@ -19,6 +19,8 @@ autoupdate = true
broken_c++ = false
# disable parallelization during build
broken_parallel_build = false
# create vendor archive with cargo
cargo_vendor = false
# this package is a library compatibility package and only ships versioned library files
compat = false
# set conservative build flags
Expand Down Expand Up @@ -58,7 +60,7 @@ skip_tests = false
# add .so files to the lib package instead of dev
so_to_lib = false
# configure build for avx2
use_avx2 = false
use_avx2 = true
# configure build for avx512
use_avx512 = false
# add clang flags
Expand Down
30 changes: 15 additions & 15 deletions pypi-jaraco.functools.spec
Original file line number Diff line number Diff line change
@@ -1,20 +1,20 @@
#
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: pyproject
#
Name : pypi-jaraco.functools
Version : 3.6.0
Release : 51
URL : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/6d/82/e94ee23a7924ab1c3b617e42ddee24a60add7d988497d5cde8ae524b1525/jaraco.functools-3.6.0.tar.gz
Version : 3.7.0
Release : 52
URL : https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/a9/9b/5da438f6734ad7bc13ae1ab5d14329526f2c93b122d89482cb24bad97714/jaraco.functools-3.7.0.tar.gz
Summary : Functools like those found in stdlib
Group : Development/Tools
License : MIT
Requires: pypi-jaraco.functools-license = %{version}-%{release}
Requires: pypi-jaraco.functools-python = %{version}-%{release}
Requires: pypi-jaraco.functools-python3 = %{version}-%{release}
BuildRequires : buildreq-distutils3
BuildRequires : pypi(more_itertools)
BuildRequires : pypi(py)
BuildRequires : pypi(setuptools)
BuildRequires : pypi(setuptools_scm)
Expand Down Expand Up @@ -59,23 +59,23 @@ python3 components for the pypi-jaraco.functools package.


%prep
%setup -q -n jaraco.functools-3.6.0
cd %{_builddir}/jaraco.functools-3.6.0
%setup -q -n jaraco.functools-3.7.0
cd %{_builddir}/jaraco.functools-3.7.0
pushd ..
cp -a jaraco.functools-3.6.0 buildavx2
cp -a jaraco.functools-3.7.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1676920033
export SOURCE_DATE_EPOCH=1685402200
export GCC_IGNORE_WERROR=1
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz "
export CFLAGS="$CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
export FCFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
export FFLAGS="$FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
export CXXFLAGS="$CXXFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
export MAKEFLAGS=%{?_smp_mflags}
python3 -m build --wheel --skip-dependency-check --no-isolation
pushd ../buildavx2/
Expand All @@ -92,7 +92,7 @@ popd
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools
cp %{_builddir}/jaraco.functools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
cp %{_builddir}/jaraco.functools-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/0445ed0f69910eeaee036f09a39a13c6e1f37e12 || :
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand All @@ -112,7 +112,7 @@ popd

%files license
%defattr(0644,root,root,0755)
/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1
/usr/share/package-licenses/pypi-jaraco.functools/0445ed0f69910eeaee036f09a39a13c6e1f37e12

%files python
%defattr(-,root,root,-)
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
51
52
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
c37c641d5b39a3b383e69191601a942ee7161e19/jaraco.functools-3.6.0.tar.gz
a53423547d6fc7e3b16f3c58782afd5da141f6d7/jaraco.functools-3.7.0.tar.gz

0 comments on commit aa81729

Please sign in to comment.