Skip to content

Commit

Permalink
dlt-daemon: superseed upstream pr openembedded#238 patch with pr open…
Browse files Browse the repository at this point in the history
…embedded#245 due to unexpected behaviour

Upstream commented to use the second one

Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
Gianfranco Costamagna authored and kraj committed Aug 29, 2020
1 parent c732465 commit fef1089
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 8 deletions.
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
From 214f8c71552fc096077f0b916dad75b31eefea3d Mon Sep 17 00:00:00 2001
From 57fd61ea5c58a4f9fcd7140b53ac6cd6e971ef47 Mon Sep 17 00:00:00 2001
From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
Date: Fri, 31 Jul 2020 15:26:35 +0200
Date: Fri, 31 Jul 2020 15:16:02 +0200
Subject: [PATCH] dlt_offline: fix build failures with gcc-10

see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957140
Expand All @@ -14,22 +14,61 @@ see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=957140
/usr/bin/ld: CMakeFiles/dlt-daemon.dir/dlt_daemon_event_handler.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: multiple definition of `g_logstorage_cache_max'; CMakeFiles/dlt-daemon.dir/dlt-daemon.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: first defined here
/usr/bin/ld: CMakeFiles/dlt-daemon.dir/dlt_daemon_offline_logstorage.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: multiple definition of `g_logstorage_cache_max'; CMakeFiles/dlt-daemon.dir/dlt-daemon.c.o:./obj-x86_64-linux-gnu/src/daemon/./src/offlinelogstorage/dlt_offline_logstorage.h:116: first defined here
---
src/offlinelogstorage/dlt_offline_logstorage.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
src/daemon/dlt_daemon_offline_logstorage.c | 1 +
src/offlinelogstorage/dlt_offline_logstorage.h | 4 ++--
src/offlinelogstorage/dlt_offline_logstorage_behavior.c | 1 +
tests/gtest_dlt_daemon_offline_log.cpp | 1 +
4 files changed, 5 insertions(+), 2 deletions(-)

diff --git a/src/daemon/dlt_daemon_offline_logstorage.c b/src/daemon/dlt_daemon_offline_logstorage.c
index 0b3c14f..db9637e 100644
--- a/src/daemon/dlt_daemon_offline_logstorage.c
+++ b/src/daemon/dlt_daemon_offline_logstorage.c
@@ -56,6 +56,7 @@ DLT_STATIC DltReturnValue dlt_logstorage_split_ecuid(char *key,
return DLT_RETURN_OK;
}

+unsigned int g_logstorage_cache_max;
/**
* dlt_logstorage_split_ctid
*
diff --git a/src/offlinelogstorage/dlt_offline_logstorage.h b/src/offlinelogstorage/dlt_offline_logstorage.h
index b58da70..8ad84b8 100644
index b58da70..c9bc93b 100644
--- a/src/offlinelogstorage/dlt_offline_logstorage.h
+++ b/src/offlinelogstorage/dlt_offline_logstorage.h
@@ -114,9 +114,9 @@
#define DLT_OFFLINE_LOGSTORAGE_IS_STRATEGY_SET(S, s) ((S)&(s))

/* logstorage max cache */
-unsigned int g_logstorage_cache_max;
+static unsigned int g_logstorage_cache_max;
+extern unsigned int g_logstorage_cache_max;
/* current logstorage cache size */
-unsigned int g_logstorage_cache_size;
+static unsigned int g_logstorage_cache_size;
+extern unsigned int g_logstorage_cache_size;

typedef struct
{
diff --git a/src/offlinelogstorage/dlt_offline_logstorage_behavior.c b/src/offlinelogstorage/dlt_offline_logstorage_behavior.c
index afbf8c4..edef482 100644
--- a/src/offlinelogstorage/dlt_offline_logstorage_behavior.c
+++ b/src/offlinelogstorage/dlt_offline_logstorage_behavior.c
@@ -32,6 +32,7 @@
#include "dlt_offline_logstorage_behavior.h"
#include "dlt_offline_logstorage_behavior_internal.h"

+unsigned int g_logstorage_cache_size;
/**
* dlt_logstorage_log_file_name
*
diff --git a/tests/gtest_dlt_daemon_offline_log.cpp b/tests/gtest_dlt_daemon_offline_log.cpp
index b8965de..0bd4d5e 100644
--- a/tests/gtest_dlt_daemon_offline_log.cpp
+++ b/tests/gtest_dlt_daemon_offline_log.cpp
@@ -29,6 +29,7 @@ extern "C"
#include <fcntl.h>
}

+unsigned int g_logstorage_cache_max;
/* Begin Method: dlt_logstorage::t_dlt_logstorage_list_add*/
TEST(t_dlt_logstorage_list_add, normal)
{
2 changes: 1 addition & 1 deletion meta-oe/recipes-extended/dlt-daemon/dlt-daemon_2.18.5.bb
Original file line number Diff line number Diff line change
Expand Up @@ -17,8 +17,8 @@ DEPENDS = "zlib gzip-native"
SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=https \
file://0002-Don-t-execute-processes-as-a-specific-user.patch \
file://0004-Modify-systemd-config-directory.patch \
file://238.patch \
file://241.patch \
file://245.patch \
"
SRCREV = "f1ac087c766827b1d0ed9c3a814b3cc052e948f2"

Expand Down

0 comments on commit fef1089

Please sign in to comment.