Skip to content

Commit

Permalink
linpack: Build both sp and dp binaries
Browse files Browse the repository at this point in the history
This eases out running single-precision and double-precision benchmarks.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
  • Loading branch information
kraj committed Nov 11, 2021
1 parent ef4f5c1 commit c1968ea
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From f092d4be22acd09e791187b8e9bff6d312721ce4 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 10 Nov 2021 11:36:31 -0800
Subject: [PATCH] linpack: Define DP only when SP is not defined

This helps compiling two versions ( SP/FP ) of the benchmark just by
passing -DSP on compile cmdline

Upstream-Status: Pending

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
linpacknew.c | 2 ++
1 file changed, 2 insertions(+)

diff --git a/linpacknew.c b/linpacknew.c
index 17b2824..c656082 100644
--- a/linpacknew.c
+++ b/linpacknew.c
@@ -28,7 +28,9 @@
#include <time.h>
#include <float.h>

+#ifndef SP
#define DP
+#endif

#ifdef SP
#define ZERO 0.0
--
2.33.1

10 changes: 7 additions & 3 deletions meta-oe/recipes-benchmark/linpack/linpack_1.0.bb
Original file line number Diff line number Diff line change
Expand Up @@ -4,17 +4,21 @@ SUMMARY = "LINPACK is a software library for performing numerical linear algebra
LICENSE = "PD"
LIC_FILES_CHKSUM ="file://${WORKDIR}/linpacknew.c;beginline=1;endline=23;md5=aa025e3bc44190c71e4c5e3b084fed87"

SRC_URI = "http://www.netlib.org/benchmark/linpackc.new;downloadfilename=linpacknew.c"
SRC_URI = "http://www.netlib.org/benchmark/linpackc.new;downloadfilename=linpacknew.c \
file://0001-linpack-Define-DP-only-when-SP-is-not-defined.patch \
"
SRC_URI[md5sum] = "1c5d0b6a31264685d2e651c920e3cdf4"
SRC_URI[sha256sum] = "a63f2ec86512959f1fd926bfafb85905b2d7b7402942ffae3af374d48745e97e"

S = "${WORKDIR}"

do_compile () {
${CC} ${CFLAGS} ${LDFLAGS} -o linpack linpacknew.c -lm
${CC} ${CFLAGS} ${LDFLAGS} -DDP -o linpack_dp linpacknew.c -lm
${CC} ${CFLAGS} ${LDFLAGS} -DSP -o linpack_sp linpacknew.c -lm
}

do_install () {
install -Dm 0755 linpack ${D}${bindir}/linpack
install -Dm 0755 linpack_dp ${D}${bindir}/linpack_dp
install -Dm 0755 linpack_sp ${D}${bindir}/linpack_sp
}

0 comments on commit c1968ea

Please sign in to comment.