Skip to content

Commit

Permalink
Update devel/matrix-synapse to 1.114.0
Browse files Browse the repository at this point in the history
# Synapse 1.114.0 (2024-09-02)

This release enables support for
[MSC4186](matrix-org/matrix-spec-proposals#4186) —
Simplified Sliding Sync. This allows using the upcoming releases of the Element
X mobile apps without having to run a Sliding Sync Proxy.


### Features

- Enable native sliding sync support ([MSC3575](matrix-org/matrix-spec-proposals#3575) and [MSC4186](matrix-org/matrix-spec-proposals#4186)) by default. ([\#17648](element-hq/synapse#17648))




# Synapse 1.114.0rc3 (2024-08-30)

### Bugfixes

- Fix regression in v1.114.0rc2 that caused workers to fail to start. ([\#17626](element-hq/synapse#17626))




# Synapse 1.114.0rc2 (2024-08-30)

### Features

- Improve cross-signing upload when using [MSC3861](matrix-org/matrix-spec-proposals#3861) to use a custom UIA flow stage, with web fallback support. ([\#17509](element-hq/synapse#17509))
- Make `hash_password` script accept password input from stdin. ([\#17608](element-hq/synapse#17608))

### Bugfixes

- Fix hierarchy returning 403 when room is accessible through federation. Contributed by Krishan (@kfiven). ([\#17194](element-hq/synapse#17194))
- Fix content-length on federation `/thumbnail` responses. ([\#17532](element-hq/synapse#17532))
- Fix authenticated media responses using a wrong limit when following redirects over federation. ([\#17543](element-hq/synapse#17543))

### Internal Changes

- MSC3861: load the issuer and account management URLs from OIDC discovery. ([\#17407](element-hq/synapse#17407))
- Refactor sliding sync class into multiple files. ([\#17595](element-hq/synapse#17595))
- Store sliding sync per-connection state in the database. ([\#17599](element-hq/synapse#17599))
- Make the sliding sync `PerConnectionState` class immutable. ([\#17600](element-hq/synapse#17600))
- Add support to `@tag_args` for standalone functions. ([\#17604](element-hq/synapse#17604))
- Speed up incremental syncs in sliding sync by adding some more caching. ([\#17606](element-hq/synapse#17606))
- Always return the user's own read receipts in sliding sync. ([\#17617](element-hq/synapse#17617))
- Replace `isort` and `black` with `ruff`. ([\#17620](element-hq/synapse#17620))
- Refactor sliding sync code to move room list logic out into a separate class. ([\#17622](element-hq/synapse#17622))



### Updates to locked dependencies

* Bump attrs from 23.2.0 to 24.2.0. ([\#17609](element-hq/synapse#17609))
* Bump cryptography from 42.0.8 to 43.0.0. ([\#17584](element-hq/synapse#17584))
* Bump phonenumbers from 8.13.43 to 8.13.44. ([\#17610](element-hq/synapse#17610))
* Bump pygithub from 2.3.0 to 2.4.0. ([\#17612](element-hq/synapse#17612))
* Bump pyyaml from 6.0.1 to 6.0.2. ([\#17611](element-hq/synapse#17611))
* Bump sentry-sdk from 2.12.0 to 2.13.0. ([\#17585](element-hq/synapse#17585))
* Bump serde from 1.0.206 to 1.0.208. ([\#17581](element-hq/synapse#17581))
* Bump serde from 1.0.208 to 1.0.209. ([\#17613](element-hq/synapse#17613))
* Bump serde_json from 1.0.124 to 1.0.125. ([\#17582](element-hq/synapse#17582))
* Bump serde_json from 1.0.125 to 1.0.127. ([\#17614](element-hq/synapse#17614))
* Bump types-jsonschema from 4.23.0.20240712 to 4.23.0.20240813. ([\#17583](element-hq/synapse#17583))
* Bump types-setuptools from 71.1.0.20240726 to 71.1.0.20240818. ([\#17586](element-hq/synapse#17586))

# Synapse 1.114.0rc1 (2024-08-20)

### Features

- Add a flag to `/versions`, `org.matrix.simplified_msc3575`, to indicate whether experimental sliding sync support has been enabled. ([\#17571](element-hq/synapse#17571))
- Handle changes in `timeline_limit` in experimental sliding sync. ([\#17579](element-hq/synapse#17579))
- Correctly track read receipts that should be sent down in experimental sliding sync. ([\#17575](element-hq/synapse#17575), [\#17589](element-hq/synapse#17589), [\#17592](element-hq/synapse#17592))

### Bugfixes

- Start handlers for new media endpoints when media resource configured. ([\#17483](element-hq/synapse#17483))
- Fix timeline ordering (using `stream_ordering` instead of topological ordering) in experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17510](element-hq/synapse#17510))
- Fix experimental sliding sync implementation to remember any updates in rooms that were not sent down immediately. ([\#17535](element-hq/synapse#17535))
- Better exclude partially stated rooms if we must await full state in experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17538](element-hq/synapse#17538))
- Handle lower-case http headers in `_Mulitpart_Parser_Protocol`. ([\#17545](element-hq/synapse#17545))
- Fix fetching federation signing keys from servers that omit `old_verify_keys`. Contributed by @tulir @ Beeper. ([\#17568](element-hq/synapse#17568))
- Fix bug where we would respond with an error when a remote server asked for media that had a length of 0, using the new multipart federation media endpoint. ([\#17570](element-hq/synapse#17570))

### Improved Documentation

- Clarify default behaviour of the
  [`auto_accept_invites.worker_to_run_on`](https://element-hq.github.io/synapse/develop/usage/configuration/config_documentation.html#auto-accept-invites)
  option. ([\#17515](element-hq/synapse#17515))
- Improve docstrings for profile methods. ([\#17559](element-hq/synapse#17559))

### Internal Changes

- Add more tracing to experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17514](element-hq/synapse#17514))
- Fixup comment in sliding sync implementation. ([\#17531](element-hq/synapse#17531))
- Replace override of deprecated method `HTTPAdapter.get_connection` with `get_connection_with_tls_context`. ([\#17536](element-hq/synapse#17536))
- Fix performance of device lists in `/key/changes` and sliding sync. ([\#17537](element-hq/synapse#17537), [\#17548](element-hq/synapse#17548))
- Bump setuptools from 67.6.0 to 72.1.0. ([\#17542](element-hq/synapse#17542))
- Add a utility function for generating random event IDs. ([\#17557](element-hq/synapse#17557))
- Speed up responding to media requests. ([\#17558](element-hq/synapse#17558), [\#17561](element-hq/synapse#17561), [\#17564](element-hq/synapse#17564), [\#17566](element-hq/synapse#17566), [\#17567](element-hq/synapse#17567), [\#17569](element-hq/synapse#17569))
- Test github token before running release script steps. ([\#17562](element-hq/synapse#17562))
- Reduce log spam of multipart files. ([\#17563](element-hq/synapse#17563))
- Refactor per-connection state in experimental sliding sync handler. ([\#17574](element-hq/synapse#17574))
- Add histogram metrics for sliding sync processing time. ([\#17593](element-hq/synapse#17593))



### Updates to locked dependencies

* Bump bytes from 1.6.1 to 1.7.1. ([\#17526](element-hq/synapse#17526))
* Bump lxml from 5.2.2 to 5.3.0. ([\#17550](element-hq/synapse#17550))
* Bump phonenumbers from 8.13.42 to 8.13.43. ([\#17551](element-hq/synapse#17551))
* Bump regex from 1.10.5 to 1.10.6. ([\#17527](element-hq/synapse#17527))
* Bump sentry-sdk from 2.10.0 to 2.12.0. ([\#17553](element-hq/synapse#17553))
* Bump serde from 1.0.204 to 1.0.206. ([\#17556](element-hq/synapse#17556))
* Bump serde_json from 1.0.122 to 1.0.124. ([\#17555](element-hq/synapse#17555))
* Bump sigstore/cosign-installer from 3.5.0 to 3.6.0. ([\#17549](element-hq/synapse#17549))
* Bump types-pyyaml from 6.0.12.20240311 to 6.0.12.20240808. ([\#17552](element-hq/synapse#17552))
* Bump types-requests from 2.31.0.20240406 to 2.32.0.20240712. ([\#17524](element-hq/synapse#17524))

# Synapse 1.113.0 (2024-08-13)

No significant changes since 1.113.0rc1.




# Synapse 1.113.0rc1 (2024-08-06)

### Features

- Track which rooms have been sent to clients in the experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17447](element-hq/synapse#17447))
- Add Account Data extension support to experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17477](element-hq/synapse#17477))
- Add receipts extension support to experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17489](element-hq/synapse#17489))
- Add typing notification extension support to experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint. ([\#17505](element-hq/synapse#17505))

### Bugfixes

- Update experimental [MSC3575](matrix-org/matrix-spec-proposals#3575) Sliding Sync `/sync` endpoint to handle invite/knock rooms when filtering. ([\#17450](element-hq/synapse#17450))
- Fix a bug introduced in v1.110.0 which caused `/keys/query` to return incomplete results, leading to high network activity and CPU usage on Matrix clients. ([\#17499](element-hq/synapse#17499))

### Improved Documentation

- Update the [`allowed_local_3pids`](https://element-hq.github.io/synapse/v1.112/usage/configuration/config_documentation.html#allowed_local_3pids) config option's msisdn address to a working example. ([\#17476](element-hq/synapse#17476))

### Internal Changes

- Change sliding sync to use their own token format in preparation for storing per-connection state. ([\#17452](element-hq/synapse#17452))
- Ensure we don't send down negative `bump_stamp` in experimental sliding sync endpoint. ([\#17478](element-hq/synapse#17478))
- Do not send down empty room entries down experimental sliding sync endpoint. ([\#17479](element-hq/synapse#17479))
- Refactor Sliding Sync tests to better utilize the `SlidingSyncBase`. ([\#17481](element-hq/synapse#17481), [\#17482](element-hq/synapse#17482))
- Add some opentracing tags and logging to the experimental sliding sync implementation. ([\#17501](element-hq/synapse#17501))
- Split and move Sliding Sync tests so we have some more sane test file sizes. ([\#17504](element-hq/synapse#17504))
- Update the `limited` field description in the Sliding Sync response to accurately describe what it actually represents. ([\#17507](element-hq/synapse#17507))
- Easier to understand `timeline` assertions in Sliding Sync tests. ([\#17511](element-hq/synapse#17511))
- Reset the sliding sync connection if we don't recognize the per-connection state position. ([\#17529](element-hq/synapse#17529))



### Updates to locked dependencies

* Bump bcrypt from 4.1.3 to 4.2.0. ([\#17495](element-hq/synapse#17495))
* Bump black from 24.4.2 to 24.8.0. ([\#17522](element-hq/synapse#17522))
* Bump phonenumbers from 8.13.39 to 8.13.42. ([\#17521](element-hq/synapse#17521))
* Bump ruff from 0.5.4 to 0.5.5. ([\#17494](element-hq/synapse#17494))
* Bump serde_json from 1.0.120 to 1.0.121. ([\#17493](element-hq/synapse#17493))
* Bump serde_json from 1.0.121 to 1.0.122. ([\#17525](element-hq/synapse#17525))
* Bump towncrier from 23.11.0 to 24.7.1. ([\#17523](element-hq/synapse#17523))
* Bump types-pyopenssl from 24.1.0.20240425 to 24.1.0.20240722. ([\#17496](element-hq/synapse#17496))
* Bump types-setuptools from 70.1.0.20240627 to 71.1.0.20240726. ([\#17497](element-hq/synapse#17497))
  • Loading branch information
Midar committed Sep 14, 2024
1 parent fdd915a commit d95af47
Show file tree
Hide file tree
Showing 4 changed files with 51 additions and 31 deletions.
4 changes: 2 additions & 2 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.100 2024/08/11 15:01:32 js Exp $
# $NetBSD: Makefile,v 1.101 2024/09/14 20:28:31 js Exp $

DISTNAME= matrix-synapse-1.112.0
DISTNAME= matrix-synapse-1.114.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=element-hq/}
GITHUB_PROJECT= synapse
Expand Down
28 changes: 24 additions & 4 deletions chat/matrix-synapse/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.54 2024/08/11 15:01:32 js Exp $
@comment $NetBSD: PLIST,v 1.55 2024/09/14 20:28:31 js Exp $
bin/export_signing_key
bin/generate_config
bin/generate_log_config
Expand Down Expand Up @@ -507,9 +507,18 @@ ${PYSITELIB}/synapse/handlers/send_email.pyo
${PYSITELIB}/synapse/handlers/set_password.py
${PYSITELIB}/synapse/handlers/set_password.pyc
${PYSITELIB}/synapse/handlers/set_password.pyo
${PYSITELIB}/synapse/handlers/sliding_sync.py
${PYSITELIB}/synapse/handlers/sliding_sync.pyc
${PYSITELIB}/synapse/handlers/sliding_sync.pyo
${PYSITELIB}/synapse/handlers/sliding_sync/__init__.py
${PYSITELIB}/synapse/handlers/sliding_sync/__init__.pyc
${PYSITELIB}/synapse/handlers/sliding_sync/__init__.pyo
${PYSITELIB}/synapse/handlers/sliding_sync/extensions.py
${PYSITELIB}/synapse/handlers/sliding_sync/extensions.pyc
${PYSITELIB}/synapse/handlers/sliding_sync/extensions.pyo
${PYSITELIB}/synapse/handlers/sliding_sync/room_lists.py
${PYSITELIB}/synapse/handlers/sliding_sync/room_lists.pyc
${PYSITELIB}/synapse/handlers/sliding_sync/room_lists.pyo
${PYSITELIB}/synapse/handlers/sliding_sync/store.py
${PYSITELIB}/synapse/handlers/sliding_sync/store.pyc
${PYSITELIB}/synapse/handlers/sliding_sync/store.pyo
${PYSITELIB}/synapse/handlers/sso.py
${PYSITELIB}/synapse/handlers/sso.pyc
${PYSITELIB}/synapse/handlers/sso.pyo
Expand Down Expand Up @@ -1341,6 +1350,9 @@ ${PYSITELIB}/synapse/storage/databases/main/session.pyo
${PYSITELIB}/synapse/storage/databases/main/signatures.py
${PYSITELIB}/synapse/storage/databases/main/signatures.pyc
${PYSITELIB}/synapse/storage/databases/main/signatures.pyo
${PYSITELIB}/synapse/storage/databases/main/sliding_sync.py
${PYSITELIB}/synapse/storage/databases/main/sliding_sync.pyc
${PYSITELIB}/synapse/storage/databases/main/sliding_sync.pyo
${PYSITELIB}/synapse/storage/databases/main/state.py
${PYSITELIB}/synapse/storage/databases/main/state.pyc
${PYSITELIB}/synapse/storage/databases/main/state.pyo
Expand Down Expand Up @@ -1870,6 +1882,8 @@ ${PYSITELIB}/synapse/storage/schema/main/delta/85/04_cleanup_device_federation_o
${PYSITELIB}/synapse/storage/schema/main/delta/85/05_add_instance_names_converted_pos.sql
${PYSITELIB}/synapse/storage/schema/main/delta/85/06_add_room_reports.sql
${PYSITELIB}/synapse/storage/schema/main/delta/86/01_authenticate_media.sql
${PYSITELIB}/synapse/storage/schema/main/delta/86/02_receipts_event_id_index.sql
${PYSITELIB}/synapse/storage/schema/main/delta/87/02_per_connection_state.sql
${PYSITELIB}/synapse/storage/schema/main/full_schemas/72/full.sql.postgres
${PYSITELIB}/synapse/storage/schema/main/full_schemas/72/full.sql.sqlite
${PYSITELIB}/synapse/storage/schema/state/delta/23/drop_state_index.sql
Expand Down Expand Up @@ -1921,6 +1935,9 @@ ${PYSITELIB}/synapse/types/__init__.pyo
${PYSITELIB}/synapse/types/handlers/__init__.py
${PYSITELIB}/synapse/types/handlers/__init__.pyc
${PYSITELIB}/synapse/types/handlers/__init__.pyo
${PYSITELIB}/synapse/types/handlers/sliding_sync.py
${PYSITELIB}/synapse/types/handlers/sliding_sync.pyc
${PYSITELIB}/synapse/types/handlers/sliding_sync.pyo
${PYSITELIB}/synapse/types/rest/__init__.py
${PYSITELIB}/synapse/types/rest/__init__.pyc
${PYSITELIB}/synapse/types/rest/__init__.pyo
Expand Down Expand Up @@ -1984,6 +2001,9 @@ ${PYSITELIB}/synapse/util/daemonize.pyo
${PYSITELIB}/synapse/util/distributor.py
${PYSITELIB}/synapse/util/distributor.pyc
${PYSITELIB}/synapse/util/distributor.pyo
${PYSITELIB}/synapse/util/events.py
${PYSITELIB}/synapse/util/events.pyc
${PYSITELIB}/synapse/util/events.pyo
${PYSITELIB}/synapse/util/file_consumer.py
${PYSITELIB}/synapse/util/file_consumer.pyc
${PYSITELIB}/synapse/util/file_consumer.pyo
Expand Down
12 changes: 6 additions & 6 deletions chat/matrix-synapse/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: cargo-depends.mk,v 1.20 2024/08/11 15:01:32 js Exp $
# $NetBSD: cargo-depends.mk,v 1.21 2024/09/14 20:28:31 js Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-1.1.3
CARGO_CRATE_DEPENDS+= anyhow-1.0.86
Expand All @@ -9,7 +9,7 @@ CARGO_CRATE_DEPENDS+= bitflags-2.5.0
CARGO_CRATE_DEPENDS+= blake2-0.10.6
CARGO_CRATE_DEPENDS+= block-buffer-0.10.4
CARGO_CRATE_DEPENDS+= bumpalo-3.16.0
CARGO_CRATE_DEPENDS+= bytes-1.6.1
CARGO_CRATE_DEPENDS+= bytes-1.7.1
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= cpufeatures-0.2.12
CARGO_CRATE_DEPENDS+= crypto-common-0.1.6
Expand Down Expand Up @@ -51,14 +51,14 @@ CARGO_CRATE_DEPENDS+= rand-0.8.5
CARGO_CRATE_DEPENDS+= rand_chacha-0.3.1
CARGO_CRATE_DEPENDS+= rand_core-0.6.4
CARGO_CRATE_DEPENDS+= redox_syscall-0.5.1
CARGO_CRATE_DEPENDS+= regex-1.10.5
CARGO_CRATE_DEPENDS+= regex-1.10.6
CARGO_CRATE_DEPENDS+= regex-automata-0.4.6
CARGO_CRATE_DEPENDS+= regex-syntax-0.8.3
CARGO_CRATE_DEPENDS+= ryu-1.0.18
CARGO_CRATE_DEPENDS+= scopeguard-1.2.0
CARGO_CRATE_DEPENDS+= serde-1.0.204
CARGO_CRATE_DEPENDS+= serde_derive-1.0.204
CARGO_CRATE_DEPENDS+= serde_json-1.0.120
CARGO_CRATE_DEPENDS+= serde-1.0.209
CARGO_CRATE_DEPENDS+= serde_derive-1.0.209
CARGO_CRATE_DEPENDS+= serde_json-1.0.127
CARGO_CRATE_DEPENDS+= sha1-0.10.6
CARGO_CRATE_DEPENDS+= sha2-0.10.8
CARGO_CRATE_DEPENDS+= smallvec-1.13.2
Expand Down
38 changes: 19 additions & 19 deletions chat/matrix-synapse/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.70 2024/08/11 15:01:32 js Exp $
$NetBSD: distinfo,v 1.71 2024/09/14 20:28:31 js Exp $

BLAKE2s (aho-corasick-1.1.3.crate) = 36150b5dacb72fa7cd0d33aee15e14857914224878f0af76eabcb9daa68e3ae0
SHA512 (aho-corasick-1.1.3.crate) = ba422a54688c4678fcf16e34fdf3ed06c333e6e3fc8b75af9272a215add494d43ebaef319021134b61327fd5d3572aec0dc655b714ffb3bc71ba3c265c9ebb69
Expand Down Expand Up @@ -27,9 +27,9 @@ Size (block-buffer-0.10.4.crate) = 10538 bytes
BLAKE2s (bumpalo-3.16.0.crate) = 718bb7ba9add434df2b5e3f8ea1ac354f2e51c0f0a6d8d77296504d6c1ca87b2
SHA512 (bumpalo-3.16.0.crate) = a51b75c36f6794db444cab20eeb24f42a319080ecb486a56d254d6f873f3d188b5ccba11db30c068bd0c52c4322d4a3f5f5195c81c94b0bc04387030418835b1
Size (bumpalo-3.16.0.crate) = 85677 bytes
BLAKE2s (bytes-1.6.1.crate) = 668865d606eac6bf1769f71a3a93a2f667588a0d1b47511f727e57449b55e278
SHA512 (bytes-1.6.1.crate) = 4826cdba7a772b68f7352a3160a4c8ff93002110644c2e99537274cbb9776ba2f40ed8be9cde564f58b884c1985bdbce07cd7f5a46d34b48146ff51f317b5ab7
Size (bytes-1.6.1.crate) = 60723 bytes
BLAKE2s (bytes-1.7.1.crate) = d4e7267c7fa230caaf53404ad0585977ddac101ea505f3fcf807d16febf87973
SHA512 (bytes-1.7.1.crate) = 04cb5bb1718ee378be1d9d56aef2d117ed561935ddadd78139ef2839f998e92c88369c79560bce9d23246a3ebda1dc888af373f9ad4827a0b9a249379bc71e81
Size (bytes-1.7.1.crate) = 63623 bytes
BLAKE2s (cfg-if-1.0.0.crate) = fbb02f63b24cc224b045ff2aac3aefd0a77cf7b578df4d5f9da9517a59aaf9bb
SHA512 (cfg-if-1.0.0.crate) = 0fb16a8882fd30e86b62c5143b1cb18ab564e84e75bd1f28fd12f24ffdc4a42e0d2e012a99abb606c12efe3c11061ff5bf8e24ab053e550ae083f7d90f6576ff
Size (cfg-if-1.0.0.crate) = 7934 bytes
Expand Down Expand Up @@ -90,9 +90,9 @@ Size (lock_api-0.4.12.crate) = 27591 bytes
BLAKE2s (log-0.4.22.crate) = 9c270d3af5640c9eeb36754e6fd6cf50521e9fd1efad955e0d777716b3d6839a
SHA512 (log-0.4.22.crate) = bd7baa9c8a5523fd0864a53bcde955d484cacd782412b5b02c890b89dbf62137624da3a27337a310dd8f62bcc6606925a42bbd4ca161a3b7936ea4ff96bc0d71
Size (log-0.4.22.crate) = 44027 bytes
BLAKE2s (matrix-synapse-1.112.0.tar.gz) = bc8a45f5227c783af4adbb0e04baa4d997daffba069b88983d42ecacad9ae7f8
SHA512 (matrix-synapse-1.112.0.tar.gz) = dc09e37f6581dd2b25c2aaae53294df997e450bfc4c3496929f56d342d354a48f0bfaac2aee154f7e1f53e86f7d078844495290c0fbc6c91efea966f8f6d68ff
Size (matrix-synapse-1.112.0.tar.gz) = 8644732 bytes
BLAKE2s (matrix-synapse-1.114.0.tar.gz) = fb68ee7c37f615d189942b3b72c6accc0e4c69c7d370dd488089e8a6067d0556
SHA512 (matrix-synapse-1.114.0.tar.gz) = 14e9abd441d1f67411d7087ca489a52343d7804ba8b575326ec52e128c0a3a0ba533b08ddaf3d31b49ac80d7b79a18e9ccdde581510c69c883d4284ddd4aed4b
Size (matrix-synapse-1.114.0.tar.gz) = 8697736 bytes
BLAKE2s (memchr-2.7.2.crate) = 58bad593cd29bb59ae79239f6f69364c2c512fa365107c1c46c37878bf53126f
SHA512 (memchr-2.7.2.crate) = cadcb4239c7f3aaab042592c5186770a225621e32f8583052fd3dbebb4a6d9b99be28f589b39b5ca36cb2d56fb3709e7d4ba91838ebb882e28e51280c02bbc40
Size (memchr-2.7.2.crate) = 96220 bytes
Expand Down Expand Up @@ -156,9 +156,9 @@ Size (rand_core-0.6.4.crate) = 22666 bytes
BLAKE2s (redox_syscall-0.5.1.crate) = f8d509b643ffa477ad2b979f4e1195de551a74d2804f834cc88b9aeca8a47ec8
SHA512 (redox_syscall-0.5.1.crate) = 0952b5f4f79f2cff04b4c21d964df7b56bc0cbff8d8a2a9a7d38ba66fd69cbd0fb004cd3d8ac6feadde8d9590858cd7e1763da7e4a5de840cdef42b1b6f1e460
Size (redox_syscall-0.5.1.crate) = 22536 bytes
BLAKE2s (regex-1.10.5.crate) = 3df1c365e07bb083bdb0fe36e6f0fc6d80f13d1b1959d3d56b2dd3d88152e13c
SHA512 (regex-1.10.5.crate) = 177fddb001e14281510e34070f88f8e5167278a46f1d93d9286d9606b7673346f504e4064d7ad53558e6988a400c728e33b663ab398fee12ae23fba7158da5fb
Size (regex-1.10.5.crate) = 253805 bytes
BLAKE2s (regex-1.10.6.crate) = 56ff08dbd1148a48f0f37248a7fa0ae1e657f0236415e92d288c83633a431754
SHA512 (regex-1.10.6.crate) = ec28961d226c944321d9953c42e43cf2d23b8ca0d72d6412e7b0f572c407aceb079bb82502d124af94d71d67c9e5e0c9f66ab9f31edf6023ff045ec37b770964
Size (regex-1.10.6.crate) = 253894 bytes
BLAKE2s (regex-automata-0.4.6.crate) = 1ed0f1b2621a3903870a4ef6f0a265ee88d15525b0e2245bc6b4155df1ea6065
SHA512 (regex-automata-0.4.6.crate) = b288e1facae2612f73d3de3fe9fd1af13d337107004f990263abe6277b31b948478ad9c2b807dcafa73fa565e48bdf2113139f5ca67eb73165b7d29e2ee5c9f1
Size (regex-automata-0.4.6.crate) = 617565 bytes
Expand All @@ -171,15 +171,15 @@ Size (ryu-1.0.18.crate) = 47713 bytes
BLAKE2s (scopeguard-1.2.0.crate) = 4daf97de7fabaf7fe5ba6000f7132a46cc0bab2a297127580d9ac127d0a8fcec
SHA512 (scopeguard-1.2.0.crate) = 6247719a15fe1e4e2d179127b9a934bd2f99367724f41175ed9522f58824b6bc69b35002eae66b35880375ff61d77ac43ddaa78cbde7160a35183a1da32d3fbb
Size (scopeguard-1.2.0.crate) = 11619 bytes
BLAKE2s (serde-1.0.204.crate) = f43fea3418fcdb7f89db4f10bdc05fbaac51fed7ed2317844740d348da864612
SHA512 (serde-1.0.204.crate) = 2fefbeed0117bd791fd25dd5ad0c99ed4f60aac5919605b6f642050f748dd472bf9d4d121b78b0cfe8719db30a675559d097bcc7542cb57451d1779dfd8d294f
Size (serde-1.0.204.crate) = 78253 bytes
BLAKE2s (serde_derive-1.0.204.crate) = 948dbe273ee87fbab81296654d8e24e0b3b9ce0acc6a9a64cac9d9a49dc85df1
SHA512 (serde_derive-1.0.204.crate) = bbb2b5e60e2af5bc7528b937ffaf0d3ffd433dbd9cb2592c1e07090620309057e4f11cbd6112fc1d2c5557e1bb3c0f4d59eb06ff06fa021ec683ab880997140e
Size (serde_derive-1.0.204.crate) = 55871 bytes
BLAKE2s (serde_json-1.0.120.crate) = 3f1a5a0eeb0980ee486808fbd112bde9c92252ffe42941cfb614fb079a56abf5
SHA512 (serde_json-1.0.120.crate) = dab44850326f9020d6f6dd3fc8147e22eed693527fe9cac2c6bc8f6a030f461061e8e54d2780382ce32cced63b5a016372a4f9938effdd1631d8f3dc96014e3e
Size (serde_json-1.0.120.crate) = 147062 bytes
BLAKE2s (serde-1.0.209.crate) = dc8747abd6e8fb4d8900322484aa816ac7c174f0af4d16c0d5d69c83ab1b3562
SHA512 (serde-1.0.209.crate) = 25d2236eedc08fa3b9d078a1971df705c4f428b7a4e6a2d28d9f0f9893c19de745bffffe3fa9f3c08074bf4359aaf09cc28770e4b14c21c66d6a0b9411738f7b
Size (serde-1.0.209.crate) = 78364 bytes
BLAKE2s (serde_derive-1.0.209.crate) = 50dbb2e608490b9c879ee3da2fe56e996596e6671bb4edceb084bfd5015a67e9
SHA512 (serde_derive-1.0.209.crate) = 22c4eb76412bd73814d0b86209b110b9e59626f64b41cbc250755144e545ff30fa69972ac93d74f988a3a6a239d9138f4e8a23b283c746a0aa5fcddfbe077cd6
Size (serde_derive-1.0.209.crate) = 56023 bytes
BLAKE2s (serde_json-1.0.127.crate) = 7bb9608f567004a74792736080156031e4c40f5594fddd444b2f7bdd6aa51fab
SHA512 (serde_json-1.0.127.crate) = f14f5eeebe07261daded47c3cbb6d511da4633bfcc46ea1b0600063730dd4211a0c310959e4f8731a688d18d60a46f6dc1c1a1f052f170b6207877b93742a88b
Size (serde_json-1.0.127.crate) = 149465 bytes
BLAKE2s (sha1-0.10.6.crate) = de97b70d4fb6a4dc4e3db64696720ea96e7b38eec57b2e8fa01ecd5102d96eab
SHA512 (sha1-0.10.6.crate) = fd37be7e3f1d4b6addd313a36b55215fb70abd21be7831b71de28bd3eb03b7352817d8a7b1a166df002c3a23eadc8224e49edd4a37556c0e5357565305d4128f
Size (sha1-0.10.6.crate) = 13517 bytes
Expand Down

0 comments on commit d95af47

Please sign in to comment.