Skip to content

Commit

Permalink
Update to 0.24.3
Browse files Browse the repository at this point in the history
Upstream changes:
#-#-#-#-#-#-#-#-#-#    Changes in TTR version 0.24.2    #-#-#-#-#-#-#-#-#-#


BUG FIXES

  - Check for 'ratio > 0' before calculating 'n' in zlema() C code. The prior
    code could result in division by 0, which was flagged by clang-UBSAN.
    Thanks to Prof Brian Ripley for the report. (#100)


#-#-#-#-#-#-#-#-#-#    Changes in TTR version 0.24.1    #-#-#-#-#-#-#-#-#-#


BUG FIXES

  - Fix leading NA accounting in wma() C code. The prior code caused invalid
    reads under valgrind. Thanks to Prof Brian Ripley for the report. (#99)

  - Check for 'ratio > 0' before calculating 'n' in ema() C code. The prior
    code could result in division by 0, which was flagged by UBSAN. Thanks to
    Prof Brian Ripley for the report. (#100)

  - Make ALMA() output length equal input length when the input can not be
    converted to xts. This was caused by the difference between
    rollapply.default() and rollapply.xts(). Thanks to GitHub user
    marksimmonds for the report. (#29)

  - Fix stoch() in very rare cases where fastK is Inf. I could only reproduce
    this if the Close is > High and High and Low are equal, but that is a data
    error. I fixed anyway because there may be other cases I don't anticipate.
    Thanks to GitHub user cjuncosa for the report. (#52)

  - Fix MFI() when money flow is always zero or positive. The denominator of
    the money ratio will be zero if there is no negative money flow for 'n'
    consecutive observations (e.g. during a strong up-trend), which causes the
    money flow index to be Inf. Set the money flow index to 100 in this case.

    And the money ratio will be NaN if there's no money flow for 'n'
    consecutive observations (e.g. if there are no trades), which causes the
    money flow index to be NaN. Set the money flow index to 50 in this case.

    Thanks to GitHub user jgehw for the report, reproducible example, and
    suggested patch. (#81)


#-#-#-#-#-#-#-#-#-#    Changes in TTR version 0.24.0    #-#-#-#-#-#-#-#-#-#


SIGNIFICANT USER-VISIBLE CHANGES

  - Updated stockSymbols() to use the NASDAQ FTP site instead of downloading
    the CSV from the NASDAQ stock screener page. Some columns are no longer
    populated because they are not provided in the FTP file:
      LastSale ,MarketCap, IPOyear, Sector, Industry
    These columns will be removed in a future version. (#98, #5, #97)

  - runPercentRank(x, n, cumulative = TRUE) now sets observations in the
    initialization period to NA. This is consistent with the other
    running/rolling functions in TTR. If you want the previous behavior,
    you should use runPercentRank(x, n = 1, cumulative = TRUE). Thanks to
    GitHub user httassadar for the report. (#73)


NEW FEATURES

  - Add Ehler's Correlation Trend Indicator. Thanks to Evelyn Mitchell for
    the suggestion, and for Ethan Smith for the initial implementation. (#92)


BUG FIXES

  - runMAD() returned incorrect values when 'cumulative = TRUE' and the input
    contained leading NA. Thanks to GitHub user stellathecat for the report.
    This also affected runMedian() also. (#93)

  - ZLEMA() would crash when 'ratio = 0.0' and 'n' was not specified. Thanks
    to GitHub user yogat3ch for the report! (#95)

  - WMA() did not return an xts object when passed an xts object for 'x' that
    had leading NA, with the default 'wts = 1:n'. Thanks to Cory Fletcher for
    reporting this issue via email. (#96)

  - stoch() was wrong when 'bounded = FALSE'. Thanks to GitHub user rfinfun
    for the report and patch. (#74)

  - HMA() threw an error when 'n' was an odd number. This was because the
    first call to WMA() used 'n = n / 2' which caused 'n' to not be an
    integer. Thanks to GitHub user dragie for the report. (#76)
  • Loading branch information
wen committed May 29, 2022
1 parent 9246619 commit cf36975
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions finance/R-TTR/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.4 2019/08/08 19:53:41 brook Exp $
# $NetBSD: Makefile,v 1.5 2022/05/29 00:46:45 wen Exp $

R_PKGNAME= TTR
R_PKGVER= 0.23-4
R_PKGVER= 0.24.3
CATEGORIES= finance

MAINTAINER= minskim@NetBSD.org
Expand Down
8 changes: 4 additions & 4 deletions finance/R-TTR/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:26:00 nia Exp $
$NetBSD: distinfo,v 1.5 2022/05/29 00:46:45 wen Exp $

BLAKE2s (R/TTR_0.23-4.tar.gz) = 5ab81163c2cac783df245608c99c361c98a2692a9f5b20f8aa1bd68be6154113
SHA512 (R/TTR_0.23-4.tar.gz) = e0c3049c8ee8d58fbb5ccdd8e426e9e6d5a30f2476e6fc9302216273153a0ddf5eff22b0a00c84cdd0e8d214d1dc180e3c7e2052010bedfe904ef400aa91fcc0
Size (R/TTR_0.23-4.tar.gz) = 310105 bytes
BLAKE2s (R/TTR_0.24.3.tar.gz) = 37f09ddd28b2d8d3094fe9ad7ece26ec3d07a89abe6f922f83fff16273094fd4
SHA512 (R/TTR_0.24.3.tar.gz) = 0911fa13164ed7883606ec7ca56e4cda43e2f1eb5c6ae6cb418606df6f9e55b78dcca1ba4717fdbce1006e313e25694935735029ed69e9cdfc060cf441fc207f
Size (R/TTR_0.24.3.tar.gz) = 317338 bytes

0 comments on commit cf36975

Please sign in to comment.