Skip to content

Commit

Permalink
devel/ormolu: Update to 0.7.3.0
Browse files Browse the repository at this point in the history
Ormolu 0.7.3.0
* Switched to ghc-lib-parser-9.8, with the following new syntactic features:
  - ExtendedLiterals: 123#Int8 is a literal of type Int8#. (disabled by
    default)
  - TypeAbstractions: @k-binders in data type declarations (enabled by
    default)
  - GHC proposal #134: deprecating/warning about exports
  - GHC proposal #541: warning categories

Ormolu 0.7.2.0
* Preserve necessary braces for final function arguments. Issue 1044.
* Put "this" PackageImports at the end. Issue 1048.
* Format parenthesized operators starting with a # correctly in the
  presence of UnboxedSums. Issue 1062.
* Fix false positives in AST diffing related to empty Haddock comments in
  data declarations. Issue 1065.

Ormolu 0.7.1.0
* Include base fixity information when formatting a Haskell file that's not
  mentioned in an existing cabal file. Issue 1032
* Update displayException for OrmoluException to pretty print the
  exception. PR 1031.
* Ormolu is now aware of more common module re-exports by default.
* Support explicit mention of target package name in module
  re-exports. Even if the exported package is not specified as a direct
  dependency of the component being formatted it will still be taken into
  account correctly. Issue 1037.
* Ormolu no longer fails when CPP directly follows the import section (a
  regression introduced in 0.7.0.0). Issue 1040.

Ormolu 0.7.0.0
* Inference of operator fixity information is now more precise and takes
  into account the import section of the module being formatted. Issue 892
  and issue 929.
* Ormolu can now be made aware of module re-exports through either special
  declarations in .ormolu files (see the readme for a description of the
  syntax), or on the command line with the --reexport/-r option. Issue
  1017.
* Ormolu now looks for .ormolu files independently of .cabal files. This
  means that it is now possible to have one .ormolu file for multiple Cabal
  packages. Issue 1019.
* Consistently format do blocks/cases/MultiWayIfs with 4 spaces if and only
  if they occur as the applicand. Issue 1002 and issue 730.
* Support the (deprecated) DatatypeContexts extension to avoid
  surprises. Issue 1012.
* Don't let comments escape from empty export lists. Issue 906.
* Format \cases with multiple patterns across multiple lines
  correctly. Issue 1025.

Ormolu 0.6.0.1
* Fix false positives in AST diffing related to UnicodeSyntax. PR 1009.

Ormolu 0.6.0.0
* Haddocks attached to arguments of a data constructor are now formatted in
  the pipe style (rather than the caret style), consistent with everything
  else. As a consequence, now Ormolu's output will be deemed invalid by the
  Haddock shipped with GHC <9.0. Issue 844 and issue 828.
* Insert space before char literals in ticked promoted constructs when
  necessary. Issue 1000.
* Switched to ghc-lib-parser-9.6:
  - Extended OverloadedLabels: #Foo, #3, #"Hello there".
  - Also, it is now disabled by default, as it causes e.g. a#b to be parsed
    differently.
  - New extension: TypeData, enabled by default.
  - Parse errors now include error codes, cf. https://errors.haskell.org.
* Updated to Cabal-syntax-3.10.
* Now whenever Ormolu fails to parse a .cabal file it also explains why. PR
  999.

Ormolu 0.5.3.0
* Stop making empty lets move comments. Issue 917.
* Now .ormolu fixity override files can use both LF and CRLF line
  endings. PR 969.
* Normalize parentheses around constraints. Issue 264.
* The ormolu function now consumes Text instead of String due to an
  internal refactoring.
* Exposed a more complete public API in the Ormolu module. The API is
  supposed to be stable and change according to PVP.
* Now warnings regarding Ormolu not being able to find .cabal files or
  finding such files but them not mentioning the source file in question
  are only displayed when --debug is used. Printing the warnings by default
  seems to have been confusing, see e.g. Issue 971 and issue 924.
  • Loading branch information
depressed-pho committed Oct 30, 2023
1 parent f46e164 commit c1bdcc7
Show file tree
Hide file tree
Showing 4 changed files with 24 additions and 21 deletions.
13 changes: 4 additions & 9 deletions devel/ormolu/Makefile
Original file line number Diff line number Diff line change
@@ -1,30 +1,25 @@
# $NetBSD: Makefile,v 1.7 2023/10/09 04:54:36 pho Exp $
# $NetBSD: Makefile,v 1.8 2023/10/30 06:28:51 pho Exp $

DISTNAME= ormolu-0.5.2.0
DISTNAME= ormolu-0.7.3.0
PKGNAME= ${DISTNAME}
PKGREVISION= 2
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Formatter for Haskell source code
LICENSE= modified-bsd

# ormolu is built with optparse-applicative, and can generate shell
# completion scripts automatically.
.include "../../devel/hs-optparse-applicative/application.mk"

# lib:ormolu
.include "../../devel/hs-ansi-terminal/buildlink3.mk"
.include "../../textproc/hs-Diff/buildlink3.mk"
.include "../../devel/hs-dlist/buildlink3.mk"
.include "../../devel/hs-file-embed/buildlink3.mk"
.include "../../devel/hs-ghc-lib-parser/buildlink3.mk"
.include "../../textproc/hs-megaparsec/buildlink3.mk"
.include "../../devel/hs-memotrie/buildlink3.mk"
.include "../../devel/hs-syb/buildlink3.mk"

# exe:ormolu
.include "../../devel/hs-gitrev/buildlink3.mk"
.include "../../devel/hs-optparse-applicative/application.mk"
.include "../../devel/hs-th-env/buildlink3.mk"

.include "../../mk/haskell.mk"
.include "../../mk/bsd.pkg.mk"
15 changes: 13 additions & 2 deletions devel/ormolu/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2023/01/26 10:58:24 pho Exp $
@comment $NetBSD: PLIST,v 1.3 2023/10/30 06:28:51 pho Exp $
bin/ormolu
lib/${PKGNAME}/${HS_VERSION}/package-description
lib/${PKGNAME}/${HS_VERSION}/package-id
Expand All @@ -24,6 +24,9 @@ ${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Exception.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity/Imports.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity/Imports.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity/Imports.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity/Internal.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity/Internal.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Fixity/Internal.p_hi
Expand Down Expand Up @@ -141,6 +144,9 @@ ${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Processing/Preprocess.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Terminal.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Terminal.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Terminal.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Terminal/QualifiedDo.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Terminal/QualifiedDo.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Terminal/QualifiedDo.p_hi
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Utils.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Utils.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Utils.p_hi
Expand All @@ -155,14 +161,15 @@ lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Utils/IO.hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Ormolu/Utils/IO.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}.a
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}_p.a
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/LICENSE.md
share/doc/${HS_PLATFORM}/${PKGNAME}/LICENSE.md
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/CHANGELOG.md
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/CONTRIBUTING.md
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/DESIGN.md
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Config.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Diff-ParseResult.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Diff-Text.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Exception.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Fixity-Imports.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Fixity-Internal.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Fixity-Parser.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Fixity-Printer.html
Expand Down Expand Up @@ -202,13 +209,15 @@ ${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Printer.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Processing-Common.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Processing-Cpp.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Processing-Preprocess.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Terminal-QualifiedDo.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Terminal.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Utils-Cabal.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Utils-Fixity.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Utils-IO.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu-Utils.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/Ormolu.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/README.md
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-62.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-A.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-All.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-B.html
Expand All @@ -231,10 +240,12 @@ ${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-U.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-V.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index-W.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/doc-index.json
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/haddock-bundle.min.js
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/index.html
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/linuwial.css
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/meta.json
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/ormolu.haddock
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/quick-jump.css
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/quick-jump.min.js
${PLIST.doc}share/doc/${HS_PLATFORM}/${PKGNAME}/html/synopsis.png
9 changes: 3 additions & 6 deletions devel/ormolu/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,24 +1,21 @@
# $NetBSD: buildlink3.mk,v 1.6 2023/10/09 04:54:36 pho Exp $
# $NetBSD: buildlink3.mk,v 1.7 2023/10/30 06:28:51 pho Exp $

BUILDLINK_TREE+= ormolu

.if !defined(ORMOLU_BUILDLINK3_MK)
ORMOLU_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.ormolu+= ormolu>=0.5.2
BUILDLINK_ABI_DEPENDS.ormolu+= ormolu>=0.5.2.0nb2
BUILDLINK_API_DEPENDS.ormolu+= ormolu>=0.7.3
BUILDLINK_ABI_DEPENDS.ormolu+= ormolu>=0.7.3.0
BUILDLINK_PKGSRCDIR.ormolu?= ../../devel/ormolu

.include "../../devel/hs-ansi-terminal/buildlink3.mk"
.include "../../textproc/hs-Diff/buildlink3.mk"
.include "../../devel/hs-dlist/buildlink3.mk"
.include "../../devel/hs-file-embed/buildlink3.mk"
.include "../../devel/hs-ghc-lib-parser/buildlink3.mk"
.include "../../textproc/hs-megaparsec/buildlink3.mk"
.include "../../devel/hs-memotrie/buildlink3.mk"
.include "../../devel/hs-syb/buildlink3.mk"
.include "../../devel/hs-gitrev/buildlink3.mk"
.include "../../devel/hs-optparse-applicative/buildlink3.mk"
.endif # ORMOLU_BUILDLINK3_MK

BUILDLINK_TREE+= -ormolu
8 changes: 4 additions & 4 deletions devel/ormolu/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2023/01/26 10:58:24 pho Exp $
$NetBSD: distinfo,v 1.3 2023/10/30 06:28:51 pho Exp $

BLAKE2s (ormolu-0.5.2.0.tar.gz) = 1c4f9d541b1c15035ef0b7da839e36af29549e921cdf2b6244c180031462d28e
SHA512 (ormolu-0.5.2.0.tar.gz) = 8a83b0b6ae8a7ea351ece7d1c7236d1930c03ede3d227682789a717d7883f0e1560795e1f9df320f614b6dd0fe7caf710161a0ad48b8fd4a71b6540013ad1dcd
Size (ormolu-0.5.2.0.tar.gz) = 398402 bytes
BLAKE2s (ormolu-0.7.3.0.tar.gz) = ec8bd9fb1a0877883c35e69cc9d0fbb232bf8142ac92cff0b199ba6a3171a4ee
SHA512 (ormolu-0.7.3.0.tar.gz) = 850c36fddfa93ec8166b943cf0de6b12cf0e1ebcd6d1902e6ccd3e6a8bf9baa29e7ffe2956b9b8bc06b9925e8357d6174ae67935fe52ca1bef837e8c4ce6bbed
Size (ormolu-0.7.3.0.tar.gz) = 348324 bytes

0 comments on commit c1bdcc7

Please sign in to comment.