Skip to content

Commit

Permalink
dnsperf: update to 2.3.2. Changed upstream to DNS-OARC.
Browse files Browse the repository at this point in the history
2019-08-23 Jerry Lundström

    Release 2.3.2

    This release fixes a buffer overflow when using TSIG and algorithms
    with digests larger then SHA256, reported by Mukund Sivaraman. Also
    fix build dependencies for `sqrt()`.

    e54aa58 Digest
    bca5d8d sqrt
    d9eaa5b Package

2019-07-24 Jerry Lundström

    Release 2.3.1

    After a report and additional confirming results the use of `poll()` in
    the network receive code for TCP and TLS has been removed. This `poll()`
    initially gave better results while testing in a docker container on
    it's loopback interface but when on physical networks it reduced
    performance to 1/12th, so it had to go.

    Thanks to Brian Wellington (Akamai/Nominum) for the initial report and
    testing, and to Jan Hák (CZ.NIC) for testing and confirming the results.

    Bugfix:
    - Fix check for having more DNS messages in the receive buffer for TCP
      and TLS

    670db9c TCP/TLS receive
    b8925b2 recvbuf have more

2019-07-17 Jerry Lundström

    Release 2.3.0

    This release adds support for DNS over TCP and TLS which can be selected
    by using the mode option for `dnsperf` and `resperf`. The default server
    port used is now determined by the transport mode, udp/tcp port 53 and
    tls port 853.

    Note that the mode option is different between the program because it was
    already taken for `resperf`.

    `dnsperf` changes:
    - Add `-m` for setting transport mode, `udp` (default), `tcp` or `tls`
    - Add verbose messages about network readiness and congestion

    `resperf` changes:
    - Add `-M` for setting transport mode, `udp` (default), `tcp` or `tls`
    - Add `-v` for verbose mode to report about network readiness and
      congestion

    ffa49cf LGTM, SonarCloud
    4cd5441 TLS
    35624d1 TCP send, socket ready loop
    fbf76aa TCP support
    5988b06 Funding

2019-01-28 Jerry Lundström

    Release 2.2.1

    The commit pulled from a fork that used `inttypes.h`, instead of ISC
    internal types, missed to remove the old conversion specifier.
    This was reported and fixed by Vladimír Čunát.

    9534ce1 remove visible "u" characters after numbers

2019-01-25 Jerry Lundström

    Release 2.2.0

    First release by DNS-OARC with a rework of the code to use autotools,
    semantic versioning 2.0 and bugfixes pulled from other's forks.

    Bugfixes:
    - Fix infinite loop in argument parsing
    - Fix min/max latency summing for multithreaded runs
    - Fix calculation of per_thread socket counts
    - Fixes to queryparse
      - Mark correctly end of file
      - Support python3
      - Stop looping on end of file undefinitely
    - Fix compilation issues and work around missing `dns_fixedname_initname()`
    - Clang `scan-build` fixes

    Other changes:
    - add "configure --with-bind" option
    - Handle bind library changes to HMAC (see #22) and other differences
      between versions
    - Workaround issue on FreeBSD (see #23)
    - Use `snprintf()` and OpenBSD's `strlcat()`
    - Add/update build dependencies for Debia, Ubuntu, CentOS, FreeBSD
      and OpenBSD

    ae9bc91 Clang format
    b9bb085 CI, buildbot
    b84e41b Autotools, README, changelog
    a2e1732 License
    9dcb661 Remove $Id markers, Principal Author and Reviewed tags from the
            full source tree
    0677bf0 Use dns_fixedname_initname() where possible
    d8d4696 [master] add "configure --with-bind" option to dnsperf
    b71a280 Add deb based distros dependencies
    439c614 Replace custom isc_boolean_t with C standard bool type
    407ae7c Replace custom isc_u?intNN_t types with C99 u?intNN_t types
    c27afd4 Replace ISC_PRINT_QUADFORMAT with inttypes.h format constants
    6fdb2f7 Fix queryparse
    4909b78 README
    2782d50 README.md: Rectify link to software
    e31ddf4 fix calculation of per_thread socket counts
    3bd7fb4 Fix min/max latency summing for multithreaded runs
    2207e27 Fix infinite loop in argument parsing.
    3bfe97a Include the github URL; remove the bug reports section.
    0cee04a Add note about bug reports.
    62c4b32 add .gitignore
    c45f0be Initial import.
    149172b Initial commit
  • Loading branch information
coypoop committed Oct 16, 2019
1 parent fe77b65 commit 81cdbe6
Show file tree
Hide file tree
Showing 8 changed files with 14 additions and 96 deletions.
12 changes: 5 additions & 7 deletions benchmarks/dnsperf/Makefile
Original file line number Diff line number Diff line change
@@ -1,18 +1,16 @@
# $NetBSD: Makefile,v 1.10 2019/10/16 09:37:27 maya Exp $
# $NetBSD: Makefile,v 1.11 2019/10/16 10:05:28 maya Exp $

DISTNAME= dnsperf-src-2.1.0.0-1
PKGNAME= dnsperf-2.1.0.0
PKGREVISION= 2
DISTNAME= dnsperf-2.3.2
CATEGORIES= benchmarks net
MASTER_SITES= ftp://ftp.nominum.com/pub/nominum/${PKGBASE}/${PKGVERSION_NOREV}/
MASTER_SITES= https://www.dns-oarc.net/files/dnsperf/

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.nominum.com/support/measurement-tools/
HOMEPAGE= https://www.dns-oarc.net/tools/dnsperf
COMMENT= DNS server performance measurement tools
LICENSE= mit

GNU_CONFIGURE= yes
USE_TOOLS+= sh:run
USE_TOOLS+= sh:run pkg-config

# This package needs "isc" include files and "isc-config.sh" to build.
# The built-in check only considers "libbind".
Expand Down
5 changes: 4 additions & 1 deletion benchmarks/dnsperf/PLIST
Original file line number Diff line number Diff line change
@@ -1,6 +1,9 @@
@comment $NetBSD: PLIST,v 1.1 2013/11/30 20:31:18 tron Exp $
@comment $NetBSD: PLIST,v 1.2 2019/10/16 10:05:28 maya Exp $
bin/dnsperf
bin/resperf
bin/resperf-report
man/man1/dnsperf.1
man/man1/resperf.1
share/doc/dnsperf/CHANGES
share/doc/dnsperf/LICENSE
share/doc/dnsperf/README.md
15 changes: 5 additions & 10 deletions benchmarks/dnsperf/distinfo
Original file line number Diff line number Diff line change
@@ -1,11 +1,6 @@
$NetBSD: distinfo,v 1.4 2018/10/27 12:04:33 tron Exp $
$NetBSD: distinfo,v 1.5 2019/10/16 10:05:28 maya Exp $

SHA1 (dnsperf-src-2.1.0.0-1.tar.gz) = 1a5d32feb41dd174f82f57ba62389d3480619c91
RMD160 (dnsperf-src-2.1.0.0-1.tar.gz) = 0392903f300750ca53785f342a547eee5eb9db6d
SHA512 (dnsperf-src-2.1.0.0-1.tar.gz) = 5571bd0855aba4affcdf81724919e60ab6762d646f8d9a6abf177a2a588675c636842f2fb708bf648004b9c411e9c9b68789f7c6bbbd87afc24c8299a21aa6c9
Size (dnsperf-src-2.1.0.0-1.tar.gz) = 561502 bytes
SHA1 (patch-Makefile.in) = 9f5377a75d9674a3aeb12f933f0a552564534d91
SHA1 (patch-datafile.h) = d05f41b5d02048ffe5ca7261cd0164202fb9821a
SHA1 (patch-dns.h) = 1c78fc5dd05c4eb32563c2cfacdabadfa9937c1b
SHA1 (patch-os.h) = 53b573fddee3495a8b8e73088b1a4742a6b1b9ae
SHA1 (patch-util.h) = 94893a9d867aabd43650e66ffbbb0995ceb9becd
SHA1 (dnsperf-2.3.2.tar.gz) = e533ac288de7e52d7b09b4e2fc059b380b1a9164
RMD160 (dnsperf-2.3.2.tar.gz) = 3b7ebde9379fcdb268765ff934879c913c90ac5b
SHA512 (dnsperf-2.3.2.tar.gz) = b4fbfa40811174a0613ba333a57278262af2c424118c55ad3f0fe7bf4df07ae4ca4c5fb528ff659d98db61393399308b652bc9887c48ed24427c70343307f06d
Size (dnsperf-2.3.2.tar.gz) = 402223 bytes
15 changes: 0 additions & 15 deletions benchmarks/dnsperf/patches/patch-Makefile.in

This file was deleted.

17 changes: 0 additions & 17 deletions benchmarks/dnsperf/patches/patch-datafile.h

This file was deleted.

15 changes: 0 additions & 15 deletions benchmarks/dnsperf/patches/patch-dns.h

This file was deleted.

16 changes: 0 additions & 16 deletions benchmarks/dnsperf/patches/patch-os.h

This file was deleted.

15 changes: 0 additions & 15 deletions benchmarks/dnsperf/patches/patch-util.h

This file was deleted.

0 comments on commit 81cdbe6

Please sign in to comment.