Skip to content

Commit

Permalink
archivers/hs-zip-archive: Update to 0.4.2.2
Browse files Browse the repository at this point in the history
zip-archive 0.4.2.2

  * Use `command -v` before trying `which` in the test suite (#62).
    `command` is a bash builtin, but for busybox we'll need `which`.

zip-archive 0.4.2.1

  * Fix Windows build regression (#61).

zip-archive 0.4.2

  * Fix problem with files with colon (#89).
  * Remove build-tools.  This was used to indicate that the 'unzip'
    executable was needed for testing, but it was never intended to be used
    this way and now the field is deprecated.  The current test suite
    simply skips the test using the unzip executable (with a warning) if
    'unzip' is not in the path.
  * Remove existing symlinks when extracting zip files with symlinks (#60,
    Vikrem).  Previously, writeEntry would raise an error if it tried to
    create a symlink and a symlink already existed at that path.  This
    behavior was inconsistent with its behavior for regular files, which
    it overwrote without comment.  This commit causes symlinks to be replaced
    by writeEntry instead of an error being raised.
  * Remove binary < 0.6 CPP.  It's no longer needed because we don't support
    binary < 0.6.  Also use manySig instead of many, to get better error
    messages.
  * Add type annotation for printf.
  * Better checking for unsafe paths (#55).  This method allows things like
    `foo/bar/../../baz`.
  * Require base >= 4.5 (#56)
  * Add GitHub CI.
  • Loading branch information
depressed-pho committed Jan 25, 2023
1 parent 43c1559 commit 2b711d2
Show file tree
Hide file tree
Showing 4 changed files with 24 additions and 25 deletions.
5 changes: 2 additions & 3 deletions archivers/hs-zip-archive/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.5 2022/02/26 03:57:43 pho Exp $
# $NetBSD: Makefile,v 1.6 2023/01/25 09:53:52 pho Exp $

DISTNAME= zip-archive-0.4.1
PKGREVISION= 4
DISTNAME= zip-archive-0.4.2.2
CATEGORIES= archivers

MAINTAINER= zecrazytux@zecrazytux.net
Expand Down
30 changes: 15 additions & 15 deletions archivers/hs-zip-archive/PLIST
Original file line number Diff line number Diff line change
@@ -1,19 +1,19 @@
@comment $NetBSD: PLIST,v 1.2 2021/04/23 04:01:42 pho Exp $
lib/${HS_PLATFORM}/libHS${HS_PKGID}-${HS_VER}.so
lib/${HS_PLATFORM}/${HS_PKGID}/Codec/Archive/Zip.dyn_hi
@comment $NetBSD: PLIST,v 1.3 2023/01/25 09:53:52 pho Exp $
${PLIST.shlibs}lib/${HS_PLATFORM}/libHS${HS_PKGID}-${HS_VER}.so
${PLIST.shlibs}lib/${HS_PLATFORM}/${HS_PKGID}/Codec/Archive/Zip.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Codec/Archive/Zip.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Codec/Archive/Zip.p_hi
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/Codec/Archive/Zip.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}.a
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}_p.a
${PLIST.prof}lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}_p.a
lib/zip-archive-${PKGVERSION}/${HS_VERSION}/package-description
lib/zip-archive-${PKGVERSION}/${HS_VERSION}/package-id
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/LICENSE
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/Codec-Archive-Zip.html
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/doc-index.html
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/haddock-bundle.min.js
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/index.html
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/linuwial.css
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/meta.json
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/quick-jump.css
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/synopsis.png
share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/zip-archive.haddock
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/LICENSE
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/Codec-Archive-Zip.html
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/doc-index.html
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/haddock-bundle.min.js
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/index.html
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/linuwial.css
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/meta.json
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/quick-jump.css
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/synopsis.png
${PLIST.doc}share/doc/${HS_PLATFORM}/zip-archive-${PKGVERSION}/html/zip-archive.haddock
6 changes: 3 additions & 3 deletions archivers/hs-zip-archive/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.5 2022/02/26 03:57:43 pho Exp $
# $NetBSD: buildlink3.mk,v 1.6 2023/01/25 09:53:52 pho Exp $

BUILDLINK_TREE+= hs-zip-archive

.if !defined(HS_ZIP_ARCHIVE_BUILDLINK3_MK)
HS_ZIP_ARCHIVE_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-zip-archive+= hs-zip-archive>=0.4.1
BUILDLINK_ABI_DEPENDS.hs-zip-archive+= hs-zip-archive>=0.4.1nb4
BUILDLINK_API_DEPENDS.hs-zip-archive+= hs-zip-archive>=0.4.2
BUILDLINK_ABI_DEPENDS.hs-zip-archive+= hs-zip-archive>=0.4.2.2
BUILDLINK_PKGSRCDIR.hs-zip-archive?= ../../archivers/hs-zip-archive

.include "../../security/hs-digest/buildlink3.mk"
Expand Down
8 changes: 4 additions & 4 deletions archivers/hs-zip-archive/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.3 2021/10/26 09:57:07 nia Exp $
$NetBSD: distinfo,v 1.4 2023/01/25 09:53:52 pho Exp $

BLAKE2s (zip-archive-0.4.1.tar.gz) = 22a9560076df30891ce8b4149106331804cba0f8d10aa8c7f1a2b9effa6ffb92
SHA512 (zip-archive-0.4.1.tar.gz) = 216555bd73a46da5061291c2c071e9c71239bd5ae253ac06ee80ade65bb1871366cc8e4dffbad983c5b6a7f4b0cb2a1439dfa5971db3e183124fa90442a73f0c
Size (zip-archive-0.4.1.tar.gz) = 20967 bytes
BLAKE2s (zip-archive-0.4.2.2.tar.gz) = c21854b98f3bfd916b751242430318234547cb3fc69ef22312b55bc86787f643
SHA512 (zip-archive-0.4.2.2.tar.gz) = f0134a58583bd3f2bd1282391c7f9d5a7411db5ca7acdc2882e2b99811a8368df903c151665fd097b7e806198912aea833cc8b910c41bda57f2ff1346b17a673
Size (zip-archive-0.4.2.2.tar.gz) = 22296 bytes

0 comments on commit 2b711d2

Please sign in to comment.