Skip to content

Commit

Permalink
ristretto: update to 0.12.1
Browse files Browse the repository at this point in the history
Change log:

0.12.1 (2021-11-26)
======
- Dependency Changes:
  - GLib >= 2.44.0

- Performance Improvement:
  - Optimize sorting by content type
  - Load images asynchronously (#16, #29, #32, !34)
  - Increase image loading buffer size (!34)

- Appearance Changes:
  - Allow to display all files in the open dialog (!33)

- Code Refactoring:
  - Rework the file opening procedure (!33)

- Bug Fixes:
  - Fix a memory leak when closing the window directly
  - Refactoring: Clarify thumbnailer queue management
  - Thumbnailer: Do not empty an unprocessed file list
  - Update window title on image deletion or insertion
  - Perform content-based filtering wherever necessary
  - Set device scale for animated images
  - Properly recognize SVG compressed image files
  - Use the generic pixbuf loader for RAW image files
  - Fix pointer behavior in fullscreen mode
  - Icon bar: Properly highlight item under the cursor
  - Icon bar: Center on the active item for any size change
  - Fix regression: Exif orientation is not respected (#69)
  - Do not try to load images whose pixbuf is not available (!34)
  - Fix memory management of image loading objects (!34)
  - Use URIs instead of filenames in the `.desktop` file (#49)
  - Directory loading: Allow to load a directory via the cli
  - Flatpak: Access remote locations with GVfs
  - Directory loading: Fix improper use of GFileEnumerator APIs (#68)

- Translation Updates:
  Albanian, Arabic, Armenian (Armenia), Basque, Belarusian, Bulgarian,
  Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish,
  Dutch, Eastern Armenian, English (Australia), English (United
  Kingdom), Estonian, Finnish, French, Galician, German, Greek, Hebrew,
  Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese,
  Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Occitan (post
  1500), Polish, Portuguese, Portuguese (Brazil), Romanian, Russian,
  Serbian, Slovak, Slovenian, Spanish, Swedish, Thai, Turkish,
  Ukrainian, Uyghur

0.12.0 (2021-10-11)
======
- Dependency Changes:
  - libxfce4ui >= 4.16.0
  - libxfce4util >= 4.16.0

- New Features:
  - Allow to choose the default scale (!29)
  - Keep the scale in memory for each loaded image (#7, #17, !28)
  - Toggle fullscreen mode by double clicking on the image

- Performance Improvement:
  - Optimize directory loading (#20, #22, #32, #37, !31)
  - Optimize image viewer redraw: Disable overlay scrolling (#64)
  - Optimize image viewer redraw: Reuse source surface (#64, !26)
  - Avoid using Cairo Xlib backend to create surfaces (#60, #61, #62, !25)
  - Optimize image viewer redraw: Animation (#64)
  - Optimize image viewer redraw: Background color (#64)
  - Optimize image viewer redraw: Clock (#64)
  - Optimize image viewer redraw: Selection box (#64)
  - Don't redraw the main window when it loses focus (#64)
  - Remove the shadow of the toolbar buttons (#51, #64)

- Appearance Changes:
  - Hide thumbnail scrollbar when unused (!24)
  - Use the same background for the image and the thumbnails (#36, !23)
  - Drop preferences-desktop-default-applications icon

- Code Refactoring:
  - Flatpak build (!32)
  - Refactoring: Use only one file filter for the app
  - Refactoring: Icon bar adjustments
  - Cleanup: `icon_bar.c`
  - Cleanup: Pass orientation directly from file to viewer
  - Code refactoring: Image viewer adjustments, scale and drawing (!27)
  - Use integers for the image rendering rectangle
  - Code cleanup: Build sanitation, obsolete code removal, spacing, normalization (!22)
  - Transfer contents from dispose() to finalize()
  - Add debugging macros

- Bug Fixes:
  - Protect asynchronous jobs from an application exit
  - Fix position of the active item in the icon bar when vertical (#34)
  - Take into account the device scale (#47, !30)
  - Properly load images via drag and drop (#67)
  - Delay GdkPixbufLoader "closed" signal handler
  - Use the same scale factor to zoom via action and scrolling
  - Fix a lack of centering when zooming via the menu action
  - Fix some memory leak (several commits of this kind)
  - Fix file creation monitoring
  - Try to display the image on `GDK_PIXBUF_ERROR_CORRUPT_IMAGE` (#39)
  - Always set adjustment upper bounds greater than page sizes (#35)
  - Scaling/zoom corrections (#30, !8)
  - Fix animated GIF display
  - Automate and sanitize memory management of sources (#65)
  - Fix `rstto_icon_bar_rows_reordered()` (#48)
  - Chain up to parent in dispose() and finalize()

- Translation Updates:
  Albanian, Arabic, Armenian (Armenia), Basque, Belarusian, Bulgarian,
  Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish,
  Dutch, Eastern Armenian, English (Australia), English (United
  Kingdom), Estonian, Finnish, French, Galician, German, Greek, Hebrew,
  Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese,
  Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Occitan (post
  1500), Polish, Portuguese, Portuguese (Brazil), Romanian, Russian,
  Serbian, Slovak, Slovenian, Spanish, Swedish, Thai, Turkish,
  Ukrainian, Uyghur

0.11.0 (2021-06-11)
======
- Update copyright years and appdata infos
- Enable `HAVE_MAGIC_H`-delimited code
- Fix compilation warnings
- autoconf: Some updates
- Update `.gitignore`
- Add option to copy image to clipboard (!20)
- Allow dragging window when CSD is used (#52)
- Remove GSourceFunc casts
- Added new stock icons with reverse DNS format
- Updates README.md
- Include string.h
- Codebase cleanup (!7)
- Make build less verbose
- Update .gitignore
- Make sure that argument passed to strncmp is non-NULL (!1)
- privacy_dialog.c: Remove dead initialization (!2)
- image_list.c: Remove dead assignment (!2)
- Add basic GitLab pipeline
- Switch to README.md and foreign automake mode
- Bug #16717: Move from exo-csource to xdt-csource
- Resolve couple "cast between incompatible function types" warnings
- Fix memory leaks in Privacy Dialog
- Resolve deprecation warnings
- Resolve some deprecation warnings
- Clean up unused functions
- Rename vars and funcs: show -> hide
- Add inactivity timeout setting to Preferences
- Hide the cursor while inactive in fullscreen mode
- Fix 'Status bar appears upon leaving fullscreen'
- Update .gitignore
- Do not show translation info on --help output
- Fix "window-state-event" handler
- Update credits
- Add support for old gtk2-style bg color settings
- Add missing LDFLAGS (fixes build on *bsd)
- In fullscreen mode, show toolbar when the mouse pointer is moved to
the top
- Return to git versioning
- Translation Updates:
  Albanian, Arabic, Armenian (Armenia), Basque, Belarusian, Bulgarian,
  Catalan, Chinese (China), Chinese (Taiwan), Croatian, Czech, Danish,
  Dutch, Eastern Armenian, English (Australia), English (United
  Kingdom), Estonian, Finnish, French, Galician, German, Greek, Hebrew,
  Hungarian, Icelandic, Indonesian, Interlingue, Italian, Japanese,
  Kazakh, Korean, Lithuanian, Malay, Norwegian Bokmål, Occitan (post
  1500), Polish, Portuguese, Portuguese (Brazil), Romanian, Russian,
  Serbian, Slovak, Slovenian, Spanish, Swedish, Telugu, Thai, Turkish,
  Ukrainian, Uyghur
  • Loading branch information
dhgutteridge committed Dec 11, 2021
1 parent 6a46d31 commit 1f03f65
Show file tree
Hide file tree
Showing 3 changed files with 21 additions and 16 deletions.
11 changes: 6 additions & 5 deletions graphics/ristretto/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,10 @@
# $NetBSD: Makefile,v 1.57 2021/12/08 16:05:04 adam Exp $
#
# $NetBSD: Makefile,v 1.58 2021/12/11 13:40:03 gutteridge Exp $

VERSION= 0.10.0
VERSION= 0.12.1
DISTNAME= ristretto-${VERSION}
EXTRACT_SUFX= .tar.bz2
PKGREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://archive.xfce.org/src/apps/ristretto/${VERSION:R}/
MASTER_SITES= https://archive.xfce.org/src/apps/ristretto/${VERSION:R}/

MAINTAINER= youri@NetBSD.org
HOMEPAGE= https://goodies.xfce.org/projects/applications/ristretto
Expand All @@ -30,9 +28,12 @@ LDFLAGS.SunOS= -lX11
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.44.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
BUILDLINK_API_DEPENDS.libxfce4util+= libxfce4util>=4.16.0
.include "../../x11/libxfce4util/buildlink3.mk"
BUILDLINK_API_DEPENDS.libxfce4ui+= libxfce4ui>=4.16.0
.include "../../x11/libxfce4ui/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"
18 changes: 11 additions & 7 deletions graphics/ristretto/PLIST
Original file line number Diff line number Diff line change
@@ -1,10 +1,12 @@
@comment $NetBSD: PLIST,v 1.6 2019/07/18 02:53:28 gutteridge Exp $
@comment $NetBSD: PLIST,v 1.7 2021/12/11 13:40:03 gutteridge Exp $
bin/ristretto
share/applications/ristretto.desktop
share/icons/hicolor/128x128/apps/ristretto.png
share/icons/hicolor/16x16/apps/ristretto.png
share/icons/hicolor/48x48/apps/ristretto.png
share/icons/hicolor/scalable/apps/ristretto.svg
share/applications/org.xfce.ristretto.desktop
share/icons/hicolor/128x128/apps/org.xfce.ristretto.png
share/icons/hicolor/16x16/apps/org.xfce.ristretto.png
share/icons/hicolor/24x24/apps/org.xfce.ristretto.png
share/icons/hicolor/32x32/apps/org.xfce.ristretto.png
share/icons/hicolor/48x48/apps/org.xfce.ristretto.png
share/icons/hicolor/scalable/apps/org.xfce.ristretto.svg
share/locale/ar/LC_MESSAGES/ristretto.mo
share/locale/ast/LC_MESSAGES/ristretto.mo
share/locale/be/LC_MESSAGES/ristretto.mo
Expand All @@ -17,6 +19,7 @@ share/locale/el/LC_MESSAGES/ristretto.mo
share/locale/en_AU/LC_MESSAGES/ristretto.mo
share/locale/en_GB/LC_MESSAGES/ristretto.mo
share/locale/es/LC_MESSAGES/ristretto.mo
share/locale/et/LC_MESSAGES/ristretto.mo
share/locale/eu/LC_MESSAGES/ristretto.mo
share/locale/fi/LC_MESSAGES/ristretto.mo
share/locale/fr/LC_MESSAGES/ristretto.mo
Expand All @@ -25,6 +28,7 @@ share/locale/he/LC_MESSAGES/ristretto.mo
share/locale/hr/LC_MESSAGES/ristretto.mo
share/locale/hu/LC_MESSAGES/ristretto.mo
share/locale/hy_AM/LC_MESSAGES/ristretto.mo
share/locale/hye/LC_MESSAGES/ristretto.mo
share/locale/id/LC_MESSAGES/ristretto.mo
share/locale/ie/LC_MESSAGES/ristretto.mo
share/locale/is/LC_MESSAGES/ristretto.mo
Expand Down Expand Up @@ -58,4 +62,4 @@ share/locale/ur_PK/LC_MESSAGES/ristretto.mo
share/locale/vi/LC_MESSAGES/ristretto.mo
share/locale/zh_CN/LC_MESSAGES/ristretto.mo
share/locale/zh_TW/LC_MESSAGES/ristretto.mo
share/metainfo/ristretto.appdata.xml
share/metainfo/org.xfce.ristretto.appdata.xml
8 changes: 4 additions & 4 deletions graphics/ristretto/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.11 2021/10/26 10:46:51 nia Exp $
$NetBSD: distinfo,v 1.12 2021/12/11 13:40:03 gutteridge Exp $

BLAKE2s (ristretto-0.10.0.tar.bz2) = c96c207a8c053259732b3e9960b00175de885637146b689bbe794f4824900b3b
SHA512 (ristretto-0.10.0.tar.bz2) = 1727025bbc056a71475d91505cc141661b011c3944cf4ca4d96b48a9ad7e1b28b8f4b0c856fa789cd2c877c1faa27aa57441e35e06f38fd2b81ddcd3284dc2b6
Size (ristretto-0.10.0.tar.bz2) = 586447 bytes
BLAKE2s (ristretto-0.12.1.tar.bz2) = 79a6b22e795789931e810512085f71dfda7601df17500fd303f09bc685f3f752
SHA512 (ristretto-0.12.1.tar.bz2) = 58e61b7ead3f78770132d1ba3b480f0300279dd42bf78c248d7927c0a6703c75edce051bcaa23acd46d92865c4f5e03fd085bcc6cfdc3fe2bd2b4abd4eb3fa3c
Size (ristretto-0.12.1.tar.bz2) = 610696 bytes
SHA1 (patch-src_Makefile.in) = efe5b0923709f5b2087e9faec15f11fcd8106924

0 comments on commit 1f03f65

Please sign in to comment.