Skip to content

Commit

Permalink
Update uriparser to version 0.9.6
Browse files Browse the repository at this point in the history
changes from changelog:

2022-01-06 -- 0.9.6

>>>>>>>>>>>>> SECURITY >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
  * Fixed: [CVE-2021-46141]
      Fix a bug affecting both uriNormalizeSyntax* and uriMakeOwner*
      functions where the text range in .hostText would not be duped using
      malloc but remain unchanged (and hence "not owned") for URIs with
      an IPv4 or IPv6 address hostname; depending on how an application
      uses uriparser, this could lead the application into a use-after-free
      situation.
      As the second half, fix uriFreeUriMembers* functions that would not
      free .hostText memory for URIs with an IPv4 or IPv6 address host;
      also, calling uriFreeUriMembers* multiple times on a URI of this
      very nature would result in trying to free pointers to stack
      (rather than heap) memory (GitHub #121, GitHub #124)
      Commit 987b046e41f407d17c622e580fc82a5e834b4329
      Commit b1a34743bc1472e055d886e29e9b53f670eb3282
  * Fixed: [CVE-2021-46142]
      Fix functions uriNormalizeSyntax* for out-of-memory situations
      (i.e. malloc returning NULL) for URIs containing empty segments
      (any of user info, host text, query, or fragment) where previously
      pointers to stack (rather than heap) memory were freed (GitHub #122,
      GitHub #124)
      Commit c0483990e6b5b454f7c8752b36760cfcb0d093f5
>>>>>>>>>>>>> SECURITY >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
  * Fixed: CMake: Call "enable_language(CXX)" prior to tinkering with
      CMAKE_CXX_* variables (GitHub #110)
      Thanks to Alexander Richardson for the patch (originally at libexpat)
  * Fixed: CMake: Support absolute paths for both CMAKE_INSTALL_LIBDIR
      and CMAKE_INSTALL_INCLUDEDIR (GitHub #114)
      Thanks to Rafael Fontenelle for bringing this up (originally at libexpat)
  * Fixed: Windows: Address MSVC compiler warnings (GitHub #111, GitHub #113)
  * Fixed: Documentation: Space requirements for uriUriStringToUnixFilename
      did not take into account short form "file:/bin/bash" of RFC 8089 of 2017
      (with prefix "file:/" rather than "file:///") that uriparser supports
      since release 0.8.6 in 2018 (GitHub #118, GitHub #119)
  * Fixed: Compile error with MinGW GCC 9 related to a mismatched prototype
      for function inet_ntop (GitHub #117, GitHub #120)
      Thanks to Sandro Mani for the report!
  * Fixed: Compile warnings in test suite code (GitHub #120)
  * Improved: Respect variable ${CPP} in doc/preprocess.sh (GitHub #115)
  * Added: Test suite invocation for MinGW using Wine (GitHub #120)
  * Soname: 1:29:0 see https://verbump.de/ for what these numbers do
  • Loading branch information
nros committed Jan 7, 2022
1 parent 184e264 commit 347f5cd
Show file tree
Hide file tree
Showing 3 changed files with 12 additions and 12 deletions.
4 changes: 2 additions & 2 deletions textproc/uriparser/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.15 2021/03/21 15:18:54 taca Exp $
# $NetBSD: Makefile,v 1.16 2022/01/07 12:40:08 nros Exp $

DISTNAME= uriparser-0.9.5
DISTNAME= uriparser-0.9.6
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=uriparser/}
GITHUB_RELEASE= ${DISTNAME}
Expand Down
12 changes: 6 additions & 6 deletions textproc/uriparser/PLIST
Original file line number Diff line number Diff line change
@@ -1,16 +1,16 @@
@comment $NetBSD: PLIST,v 1.7 2021/03/21 15:18:54 taca Exp $
@comment $NetBSD: PLIST,v 1.8 2022/01/07 12:40:08 nros Exp $
bin/uriparse
include/uriparser/Uri.h
include/uriparser/UriBase.h
include/uriparser/UriDefsAnsi.h
include/uriparser/UriDefsConfig.h
include/uriparser/UriDefsUnicode.h
include/uriparser/UriIp4.h
lib/cmake/uriparser-${PKGVERSION}/uriparser-config-version.cmake
lib/cmake/uriparser-${PKGVERSION}/uriparser-config.cmake
lib/cmake/uriparser-${PKGVERSION}/uriparser-noconfig.cmake
lib/cmake/uriparser-${PKGVERSION}/uriparser.cmake
lib/cmake/${PKGNAME}/uriparser-config-version.cmake
lib/cmake/${PKGNAME}/uriparser-config.cmake
lib/cmake/${PKGNAME}/uriparser-noconfig.cmake
lib/cmake/${PKGNAME}/uriparser.cmake
lib/liburiparser.so
lib/liburiparser.so.1
lib/liburiparser.so.1.0.28
lib/liburiparser.so.1.0.29
lib/pkgconfig/liburiparser.pc
8 changes: 4 additions & 4 deletions textproc/uriparser/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.16 2021/10/26 11:23:38 nia Exp $
$NetBSD: distinfo,v 1.17 2022/01/07 12:40:08 nros Exp $

BLAKE2s (uriparser-0.9.5.tar.xz) = 16a073304d9bf350c88646cdce16bc103f5a0bc0686aca14d809385c02ac7e49
SHA512 (uriparser-0.9.5.tar.xz) = e6077a1892cf92542205d5f4f888502e0cd51586832dd5d06903b8cebfada3fd37310978fac0134a671dea07d471f384026da07c076bda194c7a0abc7ba9867a
Size (uriparser-0.9.5.tar.xz) = 169220 bytes
BLAKE2s (uriparser-0.9.6.tar.xz) = 51057de51f8f3380062c6065419565a1048ed29bcb6b9ff73cda9fa5e534a0ae
SHA512 (uriparser-0.9.6.tar.xz) = 4b071e3aee5ca9e065ea9aaa98ee4f14157c8b52f8d95c0d526c083e61d0c015841fda7a8fa6e535664c0bfef7322da2bcfed0dc313e30794fb66a65b832d4ad
Size (uriparser-0.9.6.tar.xz) = 171260 bytes
SHA1 (patch-include_uriparser_UriBase.h) = 71f3582a2988c6c35a1a2b1995d50f47f22939bd

0 comments on commit 347f5cd

Please sign in to comment.