Skip to content

Commit

Permalink
Update to unordered-containers-0.2.13.0
Browse files Browse the repository at this point in the history
0.2.13.0
* Add HashMap.compose. Thanks Alexandre Esteves.

0.2.12.0
* Add HashMap.isSubmapOf[By] and HashSet.isSubsetOf. Thanks Sven
  Keidel. (#282)
* Expose internal modules. (#283)
* Documentation improvements in Data.HashSet, including a
  beginner-friendly introduction. Thanks Matt Renaud. (#267)
* HashMap.alterF: Skip key deletion for absent keys. (#288)
* Remove custom unsafeShift{L,R} definitions. (#281)
* Various other documentation improvements.

0.2.11.0
* Add HashMap.findWithDefault (soft-deprecates
  HashMap.lookupDefault). Thanks, Matt Renaud.
* Add HashMap.fromListWithKey. Thanks, Josef Svenningsson.
* Add more folding functions and use them in Foldable
  instances. Thanks, David Feuer.
* Add HashMap.!?, a flipped version of lookup. Thanks, Matt Renaud.
* Add a Bifoldable instance for HashMap. Thanks, Joseph Sible.
* Add a HasCallStack constraint to (!). Thanks, Roman Cheplyaka.

Bug fixes
* Fix a space leak affecting updates on keys with hash
  collisions. Thanks, Neil Mitchell. (#254)
* Get rid of some silly thunks that could be left lying
  around. (#232). Thanks, David Feuer.

Other changes
* Speed up the Hashable instances for HashMap and HashSet. Thanks,
  Edward Amsden.
* Remove a dependency cycle hack from the benchmark suite. Thanks,
  Andrew Martin.
* Improve documentation. Thanks, Tristan McLeay, Li-yao Xia, Gareth
  Smith, Simon Jakobi, Sergey Vinokurov, and likely others.
  • Loading branch information
depressed-pho committed Apr 23, 2021
1 parent f0ed888 commit 29147c5
Show file tree
Hide file tree
Showing 5 changed files with 60 additions and 73 deletions.
4 changes: 2 additions & 2 deletions devel/hs-unordered-containers/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.12 2019/12/31 16:26:32 pho Exp $
# $NetBSD: Makefile,v 1.13 2021/04/23 06:28:04 pho Exp $

DISTNAME= unordered-containers-0.2.10.0
DISTNAME= unordered-containers-0.2.13.0
CATEGORIES= devel

MAINTAINER= pho@cielonegro.org
Expand Down
97 changes: 50 additions & 47 deletions devel/hs-unordered-containers/PLIST
Original file line number Diff line number Diff line change
@@ -1,48 +1,51 @@
@comment $NetBSD: PLIST,v 1.3 2020/05/11 17:52:08 rillig Exp $
${HS_INTF}/package-description
${HS_INTF}/package-id
@comment $NetBSD: PLIST,v 1.4 2021/04/23 06:28:04 pho Exp $
lib/unordered-containers-${PKGVERSION}/${HS_VERSION}/package-description
lib/unordered-containers-${PKGVERSION}/${HS_VERSION}/package-id
lib/${HS_PLATFORM}/libHS${HS_PKGID}-${HS_VER}.so
${HS_IMPL}/Data/HashMap/Array.dyn_hi
${HS_IMPL}/Data/HashMap/Array.hi
${HS_IMPL}/Data/HashMap/Array.p_hi
${HS_IMPL}/Data/HashMap/Base.dyn_hi
${HS_IMPL}/Data/HashMap/Base.hi
${HS_IMPL}/Data/HashMap/Base.p_hi
${HS_IMPL}/Data/HashMap/Lazy.dyn_hi
${HS_IMPL}/Data/HashMap/Lazy.hi
${HS_IMPL}/Data/HashMap/Lazy.p_hi
${HS_IMPL}/Data/HashMap/List.dyn_hi
${HS_IMPL}/Data/HashMap/List.hi
${HS_IMPL}/Data/HashMap/List.p_hi
${HS_IMPL}/Data/HashMap/Strict.dyn_hi
${HS_IMPL}/Data/HashMap/Strict.hi
${HS_IMPL}/Data/HashMap/Strict.p_hi
${HS_IMPL}/Data/HashMap/Strict/Base.dyn_hi
${HS_IMPL}/Data/HashMap/Strict/Base.hi
${HS_IMPL}/Data/HashMap/Strict/Base.p_hi
${HS_IMPL}/Data/HashMap/Unsafe.dyn_hi
${HS_IMPL}/Data/HashMap/Unsafe.hi
${HS_IMPL}/Data/HashMap/Unsafe.p_hi
${HS_IMPL}/Data/HashMap/UnsafeShift.dyn_hi
${HS_IMPL}/Data/HashMap/UnsafeShift.hi
${HS_IMPL}/Data/HashMap/UnsafeShift.p_hi
${HS_IMPL}/Data/HashSet.dyn_hi
${HS_IMPL}/Data/HashSet.hi
${HS_IMPL}/Data/HashSet.p_hi
${HS_IMPL}/Data/HashSet/Base.dyn_hi
${HS_IMPL}/Data/HashSet/Base.hi
${HS_IMPL}/Data/HashSet/Base.p_hi
${HS_IMPL}/libHS${HS_PKGID}.a
${HS_IMPL}/libHS${HS_PKGID}_p.a
${HS_DOCS}/LICENSE
${HS_DOCS}/html/Data-HashMap-Lazy.html
${HS_DOCS}/html/Data-HashMap-Strict.html
${HS_DOCS}/html/Data-HashSet.html
${HS_DOCS}/html/doc-index.html
${HS_DOCS}/html/haddock-bundle.min.js
${HS_DOCS}/html/index.html
${HS_DOCS}/html/linuwial.css
${HS_DOCS}/html/meta.json
${HS_DOCS}/html/quick-jump.css
${HS_DOCS}/html/synopsis.png
${HS_DOCS}/html/unordered-containers.haddock
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Array.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Array.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Array.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/List.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/List.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/List.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Strict.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Strict.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Strict.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Unsafe.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Unsafe.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Internal/Unsafe.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Lazy.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Lazy.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Lazy.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Strict.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Strict.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashMap/Strict.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashSet.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashSet.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashSet.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashSet/Internal.dyn_hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashSet/Internal.hi
lib/${HS_PLATFORM}/${HS_PKGID}/Data/HashSet/Internal.p_hi
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}.a
lib/${HS_PLATFORM}/${HS_PKGID}/libHS${HS_PKGID}_p.a
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/LICENSE
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Internal-Array.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Internal-List.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Internal-Strict.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Internal-Unsafe.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Internal.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Lazy.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashMap-Strict.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashSet-Internal.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/Data-HashSet.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/doc-index.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/haddock-bundle.min.js
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/index.html
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/linuwial.css
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/meta.json
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/quick-jump.css
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/synopsis.png
share/doc/${HS_PLATFORM}/unordered-containers-${PKGVERSION}/html/unordered-containers.haddock
6 changes: 3 additions & 3 deletions devel/hs-unordered-containers/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.12 2019/12/31 16:26:32 pho Exp $
# $NetBSD: buildlink3.mk,v 1.13 2021/04/23 06:28:04 pho Exp $

BUILDLINK_TREE+= hs-unordered-containers

.if !defined(HS_UNORDERED_CONTAINERS_BUILDLINK3_MK)
HS_UNORDERED_CONTAINERS_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-unordered-containers+= hs-unordered-containers>=0.2.10
BUILDLINK_ABI_DEPENDS.hs-unordered-containers+= hs-unordered-containers>=0.2.10.0
BUILDLINK_API_DEPENDS.hs-unordered-containers+= hs-unordered-containers>=0.2.13
BUILDLINK_ABI_DEPENDS.hs-unordered-containers+= hs-unordered-containers>=0.2.13.0
BUILDLINK_PKGSRCDIR.hs-unordered-containers?= ../../devel/hs-unordered-containers

.include "../../devel/hs-hashable/buildlink3.mk"
Expand Down
11 changes: 5 additions & 6 deletions devel/hs-unordered-containers/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.5 2019/12/31 16:26:32 pho Exp $
$NetBSD: distinfo,v 1.6 2021/04/23 06:28:04 pho Exp $

SHA1 (unordered-containers-0.2.10.0.tar.gz) = 17d0a16aabbb03c91953b24b39cd3432f8c9afd3
RMD160 (unordered-containers-0.2.10.0.tar.gz) = b0a825c7c5fde3d5cb4136790f59c677e03eef41
SHA512 (unordered-containers-0.2.10.0.tar.gz) = 450e5e839e0092b2476a0abfc3eb2f45fba634a9e782cddf25b3db3730d16dd2e65673f46678ab4ad23be71525ae5f72888b89b03402cb70e20fc33feb765766
Size (unordered-containers-0.2.10.0.tar.gz) = 44733 bytes
SHA1 (patch-unordered-containers.cabal) = bd7765f3b4d041c0e603d3774f42ca4df6f710c2
SHA1 (unordered-containers-0.2.13.0.tar.gz) = 902b315eaa2fcd4bc5dbd4ad0fbf001392ceb874
RMD160 (unordered-containers-0.2.13.0.tar.gz) = fea917ec6d341e5a757f3ef6e17168cf05dd198a
SHA512 (unordered-containers-0.2.13.0.tar.gz) = f32d6e91ba7ef54cc24562e26e8bda147e43b954966bae3f9850b0c57438e5d8af43f7a49106980d1197ff674eca7bb9a50c8895deb0e45588ec123664c6c47d
Size (unordered-containers-0.2.13.0.tar.gz) = 53379 bytes

This file was deleted.

0 comments on commit 29147c5

Please sign in to comment.