Skip to content

Commit

Permalink
textproc/ruby-classifier-reborn: update to 2.3.0
Browse files Browse the repository at this point in the history
pkgsrc change: remove redundant PKGNAME.

2.3.0 (2022-06-19)

Minor Enhancements

* Separate tokenizer from hasher, allowing custom tokenizers. (#162)
* Improved handling of Zero division and Zero vector normalization. (#173)
* Support Numo Gem for performing SVD (#198)

Development Fixes

* remove deprecated has_rdoc in gemspec
* auto-gen-config for Rubocop
* auto-correct offenses
* Freeze all Ruby string literals (#190)
* Migrate TravisCI to GitHub Actions & Update Tested Ruby Versions (#195)
* Test Native and GSL Implementations (#196)
* Actually Use GSL in CI Tests (#197)

Documentation

* Updated Bayes docs for filters (#191)
  • Loading branch information
taca committed Sep 1, 2022
1 parent 4ec7b94 commit 234d0e7
Show file tree
Hide file tree
Showing 3 changed files with 19 additions and 8 deletions.
11 changes: 8 additions & 3 deletions textproc/ruby-classifier-reborn/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2018/03/14 15:40:07 taca Exp $
# $NetBSD: Makefile,v 1.5 2022/09/01 14:46:27 taca Exp $

DISTNAME= classifier-reborn-2.2.0
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME}
DISTNAME= classifier-reborn-2.3.0
CATEGORIES= textproc

MAINTAINER= pkgsrc-users@NetBSD.org
Expand All @@ -13,5 +12,11 @@ DEPENDS= ${RUBY_PKGPREFIX}-fast-stemmer>=1.0<2:../../textproc/ruby-fast-stemmer

RUBYGEM_OPTIONS+= --format-executable

.include "../../lang/ruby/rubyversion.mk"

.if ${RUBY_VER} != 31
DEPENDS+= ${RUBY_PKGPREFIX}-matrix>=0.4:../../math/ruby-matrix
.endif

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"
8 changes: 7 additions & 1 deletion textproc/ruby-classifier-reborn/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2018/03/14 15:40:07 taca Exp $
@comment $NetBSD: PLIST,v 1.4 2022/09/01 14:46:27 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/LICENSE
${GEM_LIBDIR}/README.markdown
Expand Down Expand Up @@ -32,8 +32,14 @@ ${GEM_LIBDIR}/lib/classifier-reborn/backends/no_redis_error.rb
${GEM_LIBDIR}/lib/classifier-reborn/bayes.rb
${GEM_LIBDIR}/lib/classifier-reborn/category_namer.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/hasher.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/token_filter/stemmer.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/token_filter/stopword.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/token_filter/symbol.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/tokenizer/token.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/tokenizer/whitespace.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/vector.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/vector_serialize.rb
${GEM_LIBDIR}/lib/classifier-reborn/extensions/zero_vector.rb
${GEM_LIBDIR}/lib/classifier-reborn/lsi.rb
${GEM_LIBDIR}/lib/classifier-reborn/lsi/cached_content_node.rb
${GEM_LIBDIR}/lib/classifier-reborn/lsi/content_node.rb
Expand Down
8 changes: 4 additions & 4 deletions textproc/ruby-classifier-reborn/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.7 2021/10/26 11:23:21 nia Exp $
$NetBSD: distinfo,v 1.8 2022/09/01 14:46:27 taca Exp $

BLAKE2s (classifier-reborn-2.2.0.gem) = aa2c89bc4e7a8a2a1864a75333d1e19a3c957476724593a3ab9b3ce38506c2af
SHA512 (classifier-reborn-2.2.0.gem) = f24c64f7b6ee26a41cfc2d9c09dbeb59d0d0a9291a6528088d5802c66f36f950891b7102cfaa62faaf70f3a4a4abb993c0e3db9219e1e504fca6edb40059432d
Size (classifier-reborn-2.2.0.gem) = 49664 bytes
BLAKE2s (classifier-reborn-2.3.0.gem) = d5edb742abef0a694e869bcd290f94fc277732cbaa25d0f5c28132a6c834b6f8
SHA512 (classifier-reborn-2.3.0.gem) = 992ed73a0b0c571ac6944ad3c76b9e74a43b1696416b78eddcb78bc35ce1168d99e56e7008e7eed2de058f2958f604b3631fe1f2649a676728fe3d116bf0b296
Size (classifier-reborn-2.3.0.gem) = 51200 bytes

0 comments on commit 234d0e7

Please sign in to comment.