Skip to content

Commit

Permalink
py-pylint: update to 3.1.0.
Browse files Browse the repository at this point in the history
New Features
------------

- Skip ``consider-using-join`` check for non-empty separators if an ``suggest-join-with-non-empty-separator`` option is set to ``no``.

  Closes #8701 (`#8701 <https://github.com/pylint-dev/pylint/issues/8701>`_)

- Discover ``.pyi`` files when linting.

  These can be ignored with the ``ignore-patterns`` setting.

  Closes #9097 (`#9097 <https://github.com/pylint-dev/pylint/issues/9097>`_)

- Check ``TypeAlias`` and ``TypeVar`` (PEP 695) nodes for ``invalid-name``.

  Refs #9196 (`#9196 <https://github.com/pylint-dev/pylint/issues/9196>`_)

- Support for resolving external toml files named pylintrc.toml and .pylintrc.toml.

  Closes #9228 (`#9228 <https://github.com/pylint-dev/pylint/issues/9228>`_)

- Check for `.clear`, `.discard`, `.pop` and `remove` methods being called on a set while it is being iterated over.

  Closes #9334 (`#9334 <https://github.com/pylint-dev/pylint/issues/9334>`_)



New Checks
----------

- New message `use-yield-from` added to the refactoring checker. This message is emitted when yielding from a loop can be replaced by `yield from`.

  Closes #9229. (`#9229 <https://github.com/pylint-dev/pylint/issues/9229>`_)

- Added a ``deprecated-attribute`` message to check deprecated attributes in the stdlib.

  Closes #8855 (`#8855 <https://github.com/pylint-dev/pylint/issues/8855>`_)


False Positives Fixed
---------------------

- Fixed false positive for ``inherit-non-class`` for generic Protocols.

  Closes #9106 (`#9106 <https://github.com/pylint-dev/pylint/issues/9106>`_)

- Exempt ``TypedDict`` from ``typing_extensions`` from ``too-many-ancestor`` checks.

  Refs #9167 (`#9167 <https://github.com/pylint-dev/pylint/issues/9167>`_)



False Negatives Fixed
---------------------

- Extend broad-exception-raised and broad-exception-caught to except*.

  Closes #8827 (`#8827 <https://github.com/pylint-dev/pylint/issues/8827>`_)

- Fix a false-negative for unnecessary if blocks using a different than expected ordering of arguments.

  Closes #8947. (`#8947 <https://github.com/pylint-dev/pylint/issues/8947>`_)



Other Bug Fixes
---------------

- Improve the message provided for wrong-import-order check.  Instead of the import statement ("import x"), the message now specifies the import that is out of order and which imports should come after it.  As reported in the issue, this is particularly helpful if there are multiple imports on a single line that do not follow the PEP8 convention.

  The message will report imports as follows:
  For "import X", it will report "(standard/third party/first party/local) import X"
  For "import X.Y" and "from X import Y", it will report "(standard/third party/first party/local) import X.Y"
  The import category is specified to provide explanation as to why pylint has issued the message and guidence to the developer on how to fix the problem.

  Closes #8808 (`#8808 <https://github.com/pylint-dev/pylint/issues/8808>`_)



Other Changes
-------------

- Print how many files were checked in verbose mode.

  Closes #8935 (`#8935 <https://github.com/pylint-dev/pylint/issues/8935>`_)

- Fix a crash when an enum class which is also decorated with a ``dataclasses.dataclass`` decorator is defined.

  Closes #9100 (`#9100 <https://github.com/pylint-dev/pylint/issues/9100>`_)
  • Loading branch information
0-wiz-0 committed Mar 3, 2024
1 parent 761d206 commit e20c625
Show file tree
Hide file tree
Showing 3 changed files with 12 additions and 7 deletions.
6 changes: 4 additions & 2 deletions devel/py-pylint/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.92 2024/02/25 15:21:34 wiz Exp $
# $NetBSD: Makefile,v 1.93 2024/03/03 11:54:21 wiz Exp $

DISTNAME= pylint-3.0.4
DISTNAME= pylint-3.1.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pylint/}
Expand All @@ -18,6 +18,8 @@ DEPENDS+= ${PYPKGPREFIX}-isort>=4.2.5:../../devel/py-isort
DEPENDS+= ${PYPKGPREFIX}-mccabe>=0.6:../../devel/py-mccabe
DEPENDS+= ${PYPKGPREFIX}-platformdirs>=2.2.0:../../misc/py-platformdirs
DEPENDS+= ${PYPKGPREFIX}-tomlkit>=0.10.1:../../textproc/py-tomlkit
TEST_DEPENDS+= ${PYPKGPREFIX}-gitpython>=0:../../devel/py-gitpython
TEST_DEPENDS+= ${PYPKGPREFIX}-test-benchmark>=0:../../devel/py-test-benchmark

USE_LANGUAGES= # none

Expand Down
5 changes: 4 additions & 1 deletion devel/py-pylint/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.32 2023/10/28 19:57:05 wiz Exp $
@comment $NetBSD: PLIST,v 1.33 2024/03/03 11:54:21 wiz Exp $
bin/pylint-${PYVERSSUFFIX}
bin/pylint-config-${PYVERSSUFFIX}
bin/pyreverse-${PYVERSSUFFIX}
Expand Down Expand Up @@ -166,6 +166,9 @@ ${PYSITELIB}/pylint/checkers/variables.pyo
${PYSITELIB}/pylint/config/__init__.py
${PYSITELIB}/pylint/config/__init__.pyc
${PYSITELIB}/pylint/config/__init__.pyo
${PYSITELIB}/pylint/config/_breaking_changes.py
${PYSITELIB}/pylint/config/_breaking_changes.pyc
${PYSITELIB}/pylint/config/_breaking_changes.pyo
${PYSITELIB}/pylint/config/_pylint_config/__init__.py
${PYSITELIB}/pylint/config/_pylint_config/__init__.pyc
${PYSITELIB}/pylint/config/_pylint_config/__init__.pyo
Expand Down
8 changes: 4 additions & 4 deletions devel/py-pylint/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.79 2024/02/25 15:21:34 wiz Exp $
$NetBSD: distinfo,v 1.80 2024/03/03 11:54:21 wiz Exp $

BLAKE2s (pylint-3.0.4.tar.gz) = e7adbb6ed097fe2d7d822b5e299e76ce4025caaa015c61087a4aa83e630ad21a
SHA512 (pylint-3.0.4.tar.gz) = 5c769be9d26c09f6bd692b87fb71f80329556653f8ce692e5f52e8537d5002bfd83ffe4d1b9119b2b8085953757859b20e108ece602f92f135e276ce0417b198
Size (pylint-3.0.4.tar.gz) = 442328 bytes
BLAKE2s (pylint-3.1.0.tar.gz) = 9a0448a1552c796de6fd39cc5405d1139d46afc83adb448b205f6adf76741f25
SHA512 (pylint-3.1.0.tar.gz) = 23d72ad32c3a41be3978085d370c997ab5d2feacbd2923ddb4c1216b05a2a3ff1dae362ca8bcfef6159d284dcd16fd3226bfe71d7780e773d00e09d4bc16a8ec
Size (pylint-3.1.0.tar.gz) = 1494465 bytes

0 comments on commit e20c625

Please sign in to comment.