Skip to content

Commit

Permalink
Update to 1.9.5:
Browse files Browse the repository at this point in the history
Changes from Ant 1.9.4 TO Ant 1.9.5
===================================

Changes that could break older environments:
-------------------------------------------

 * The ReplaceTokens filter can now use token-separators longer than
   one character.  This means it can be used to replace mustache-style
   {{patterns}} and similar templates.  This is going to break code
   that invokes the setters on ReplaceTokens via the Java API as their
   parameters have been changed from char to String.  It may also
   break build files that specified multi character tokens and relied
   on Ant silently ignoring all but the first character.
   Bugzilla Report 56584

 * The changes that added <get>'s support for gzip encoding
   automatically uncompressed content that would not have been touched
   before - like when downloading .tar.gz files.  A new flag has been
   added to control the behavior and its default will make <get> work
   as it did in 1.9.3.  I.e. if you want it to work like 1.9.4
   you have to explicitly set tryGzipEncoding to true.
   Bugzilla Report 57048

Fixed bugs:
-----------

 * TarArchiveInputStream failed to read archives with empty gid/uid
   fields.
   Bugzilla Report 56641

 * TarArchiveInputStream could throw IOException when reading PAX
   headers from a "slow" InputStream.

 * XMLJunitResultFormatter could throw NullPointerException if Java
   cannot determine the local hostname.
   Bugzilla Report 56593

 * URLResource#getLastModified tried to access the connection to the
   URL without making sure it was established, potentially leading to
   a NullPointerException when using FTP.
   Bugzilla Report 56873

 * Long-Name and -link or PAX-header entries in TAR archives
   always had the current time as last modfication time, creating
   archives that are different at the byte level each time an
   archive was built.

 * runant.py should now work as well when the path of the Java executable
   contains spaces.
   github pull request #1

 * <junitreport> now supports nested <classpath> and <factory> elements.
   Bugzilla Report 47002

 * complete-ant-cmd.pl now also knows about the -file option.
   Bugzilla Report 57371

 * the br-replace template inside the XSLT stylesheets used by
   <junitreport> could cause stack overflows or out-of-memory errors
   when applied to big outputs.
   Bugzilla Report 57341

 * removed spurious warning about unclosed ZipFiles when reading the
   archive failed.
   Port of https://issues.apache.org/jira/browse/COMPRESS-297

 * FileUtils.rename which is used by several tasks can throw a
   NullPointerException if the "normal" renameTo operation fails and
   an exception occurs while rename falls back to copying and deleting
   the file.
   Bugzilla Report 57533

 * complete-ant-cmd.pl would incorrectly suggest words from the build
   file description.
   Bugzilla Report 51931

 * complete-ant-cmd.pl now also completes tasks without a description.
   Bugzilla Report 57542

 * LocalPropertyStack could run into ConcurrentModificationException
   when tasks spawned new child threads that accessed the properties.
   Bugzilla Report 55074

 * TarEntry's constructor with a File and a String arg didn't
   normalize the name.

 * Between 1.8.4 and 1.9.0 TarInputStream started to parse file
   names using the platform's default encoding rather than as ASCII.
   This has been a breaking change that has never been marked as such
   (in fact it went unnoticed).  In order to allow <untar> and
   <tarfileset> to work on platforms who's encoding doesn't match the
   encoding of file names inside the archive, both now support
   encoding attributes.
   The attribute has also been added to <tar> for symmetry.
   Bugzilla Report 57822

Other changes:
--------------

 * it is now possible to provide proxy configuration to signjar
   when using the timestamped authority.
   Bugzilla Report 56678

 * complete-ant-cmd.pl now also analyzes the ANT_ARGS environment
   variable.
   Bugzilla Report 57371

 * ported some of the write-optimization of Commons Compress 1.10 to
   the ZIP package

 * adapted unit tests to Java9 and added "javac1.9" as valid option
   for javac's compiler attribute.

 * performance improvements for <intersect>
   Bugzilla Report 57588

 * MailLogger can now add CC and BCC addresses.
   Bugzilla Report 57789.

 * <scp>'s buffer size has been increased from 1k to 100k to match
   <ftp> and <get>.
   github pull requests #8 and #9

 * The tar package can now deal with group and user ids bigger than
   0x80000000.
   https://issues.apache.org/jira/browse/COMPRESS-314
   https://issues.apache.org/jira/browse/COMPRESS-315

 * <scp> has new attributes fileMode and dirMode that control the
   permissions on the remote side when sending data via SSH.
   Bugzilla Report 43271.

 * New <allbutlast> and <allbutfirst> resource collections can be used
   to select all but a given subset of a resource collection.
   Bugzilla Report 57834.
  • Loading branch information
wiz committed Jul 1, 2015
1 parent dc6edaf commit e29e664
Show file tree
Hide file tree
Showing 3 changed files with 13 additions and 9 deletions.
5 changes: 2 additions & 3 deletions devel/apache-ant/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.37 2014/09/03 19:36:52 tonio Exp $
# $NetBSD: Makefile,v 1.38 2015/07/01 09:36:21 wiz Exp $

DISTNAME= apache-ant-1.9.4-bin
DISTNAME= apache-ant-1.9.5-bin
PKGNAME= ${DISTNAME:S/-bin//}
PKGREVISION= 1
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_APACHE:=ant/binaries/}
EXTRACT_SUFX= .tar.bz2
Expand Down
9 changes: 7 additions & 2 deletions devel/apache-ant/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.17 2014/05/07 18:23:31 wiz Exp $
@comment $NetBSD: PLIST,v 1.18 2015/07/01 09:36:21 wiz Exp $
bin/ant
bin/antRun
lib/java/ant/ant-antlr.jar
Expand Down Expand Up @@ -1188,6 +1188,8 @@ share/doc/java/ant/api/org/apache/tools/ant/types/resolver/package-tree.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/AbstractClasspathResource.ClassLoaderWithFlag.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/AbstractClasspathResource.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/AbstractResourceCollectionWrapper.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/AllButFirst.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/AllButLast.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/Appendable.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/ArchiveResource.html
share/doc/java/ant/api/org/apache/tools/ant/types/resources/Archives.html
Expand Down Expand Up @@ -1500,7 +1502,10 @@ share/doc/java/ant/api/overview-frame.html
share/doc/java/ant/api/overview-summary.html
share/doc/java/ant/api/overview-tree.html
share/doc/java/ant/api/package-list
share/doc/java/ant/api/resources/inherit.gif
share/doc/java/ant/api/resources/background.gif
share/doc/java/ant/api/resources/tab.gif
share/doc/java/ant/api/resources/titlebar.gif
share/doc/java/ant/api/resources/titlebar_end.gif
share/doc/java/ant/api/serialized-form.html
share/doc/java/ant/api/stylesheet.css
share/doc/java/ant/argumentprocessor.html
Expand Down
8 changes: 4 additions & 4 deletions devel/apache-ant/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.20 2014/09/03 19:36:52 tonio Exp $
$NetBSD: distinfo,v 1.21 2015/07/01 09:36:21 wiz Exp $

SHA1 (apache-ant-1.9.4-bin.tar.bz2) = 99bff3c702dd79076f4e705e3541f7e35bbb4306
RMD160 (apache-ant-1.9.4-bin.tar.bz2) = 7f4263d617bbf40a15eab401369d18a755f8d260
Size (apache-ant-1.9.4-bin.tar.bz2) = 4351965 bytes
SHA1 (apache-ant-1.9.5-bin.tar.bz2) = b776cc60a861429c36fd3277741017653279b0be
RMD160 (apache-ant-1.9.5-bin.tar.bz2) = b342c22315ccb04d066d76ba5d638cacf1abba3a
Size (apache-ant-1.9.5-bin.tar.bz2) = 4383313 bytes
SHA1 (patch-aa) = 2cbee5444e1da56072fc61506b28d22dde6dbcdc

0 comments on commit e29e664

Please sign in to comment.