Skip to content

Commit

Permalink
Update textproc/py-cssutils to 1.0.2
Browse files Browse the repository at this point in the history
pkgsrc changes:
 - Use REPLACE_PYTHON instead of REPLACE_INTERPRETER (no functional changes
   intended)
 - Use ALTERNATIVE and instruct PLIST and Makefile post-install target
   accordingly to permit coexistence of multi-pkgs py-cssutils

Changes:
1.0.2 170304
------------
 - FIXED issue #61: Nesting of `@media` rules
 - FIXED issue #51 and #56: Slow font-family regex
 - FIXED issue #68: failing tests on Python 3
 - FIXED issue #69: our DOM implementation now delegates unsupported methods
 - FIXED issue #72: importing now faster since regexes are no longer pre-cached on import time

1.0.1 151008
------------
 - Fixed Python 3.5 compatibility
  • Loading branch information
leot committed Apr 14, 2017
1 parent d4a4bfe commit f8017cc
Show file tree
Hide file tree
Showing 4 changed files with 80 additions and 18 deletions.
3 changes: 3 additions & 0 deletions textproc/py-cssutils/ALTERNATIVES
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
bin/csscapture @PREFIX@/bin/csscapture-@PYVERSSUFFIX@
bin/csscombine @PREFIX@/bin/csscombine-@PYVERSSUFFIX@
bin/cssparse @PREFIX@/bin/cssparse-@PYVERSSUFFIX@
19 changes: 10 additions & 9 deletions textproc/py-cssutils/Makefile
Original file line number Diff line number Diff line change
@@ -1,27 +1,28 @@
# $NetBSD: Makefile,v 1.11 2016/06/08 17:43:40 wiz Exp $
# $NetBSD: Makefile,v 1.12 2017/04/14 13:06:49 leot Exp $

DISTNAME= cssutils-1.0
DISTNAME= cssutils-1.0.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_PYPI:=c/cssutils/}
EXTRACT_SUFX= .zip

MAINTAINER= rhialto@falu.nl
HOMEPAGE= http://cthedot.de/cssutils/
COMMENT= Cascading Style Sheets parser and library for Python
LICENSE= gnu-lgpl-v3

USE_LANGUAGES= #none
USE_LANGUAGES= # none

REPLACE_INTERPRETER+= python
REPLACE.python.old= /usr/bin/env python
REPLACE.python.new= ${PYTHONBIN}
REPLACE_FILES.python= src/cssutils/*.py
REPLACE_FILES.python+= src/cssutils/scripts/*.py
REPLACE_PYTHON+= src/cssutils/*.py src/cssutils/scripts/*.py

# all files are group/others writable.
post-extract:
chmod -R go-w ${WRKSRC}

post-install:
${MV} ${DESTDIR}${PREFIX}/bin/csscapture ${DESTDIR}${PREFIX}/bin/csscapture-${PYVERSSUFFIX} || ${TRUE}
${MV} ${DESTDIR}${PREFIX}/bin/csscombine ${DESTDIR}${PREFIX}/bin/csscombine-${PYVERSSUFFIX} || ${TRUE}
${MV} ${DESTDIR}${PREFIX}/bin/cssparse ${DESTDIR}${PREFIX}/bin/cssparse-${PYVERSSUFFIX} || ${TRUE}

.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"
66 changes: 62 additions & 4 deletions textproc/py-cssutils/PLIST
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
@comment $NetBSD: PLIST,v 1.3 2013/07/28 17:26:08 kleink Exp $
bin/csscapture
bin/csscombine
bin/cssparse
@comment $NetBSD: PLIST,v 1.4 2017/04/14 13:06:49 leot Exp $
bin/csscapture-${PYVERSSUFFIX}
bin/csscombine-${PYVERSSUFFIX}
bin/cssparse-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand Down Expand Up @@ -163,6 +163,64 @@ ${PYSITELIB}/cssutils/tests/__init__.pyo
${PYSITELIB}/cssutils/tests/basetest.py
${PYSITELIB}/cssutils/tests/basetest.pyc
${PYSITELIB}/cssutils/tests/basetest.pyo
${PYSITELIB}/cssutils/tests/sheets/096.css
${PYSITELIB}/cssutils/tests/sheets/097.css
${PYSITELIB}/cssutils/tests/sheets/1.css
${PYSITELIB}/cssutils/tests/sheets/1ascii.css
${PYSITELIB}/cssutils/tests/sheets/1import.css
${PYSITELIB}/cssutils/tests/sheets/1inherit-ascii.css
${PYSITELIB}/cssutils/tests/sheets/1inherit-iso.css
${PYSITELIB}/cssutils/tests/sheets/1inherit-utf8.css
${PYSITELIB}/cssutils/tests/sheets/1utf.css
${PYSITELIB}/cssutils/tests/sheets/2inherit-iso.css
${PYSITELIB}/cssutils/tests/sheets/2resolve.css
${PYSITELIB}/cssutils/tests/sheets/acid2.css
${PYSITELIB}/cssutils/tests/sheets/all.css
${PYSITELIB}/cssutils/tests/sheets/atrule.css
${PYSITELIB}/cssutils/tests/sheets/bad.css
${PYSITELIB}/cssutils/tests/sheets/basic.css
${PYSITELIB}/cssutils/tests/sheets/bundle.css
${PYSITELIB}/cssutils/tests/sheets/cases.css
${PYSITELIB}/cssutils/tests/sheets/csscombine-1.css
${PYSITELIB}/cssutils/tests/sheets/csscombine-2.css
${PYSITELIB}/cssutils/tests/sheets/csscombine-proxy.css
${PYSITELIB}/cssutils/tests/sheets/cthedot_default.css
${PYSITELIB}/cssutils/tests/sheets/default_html4.css
${PYSITELIB}/cssutils/tests/sheets/hacks.css
${PYSITELIB}/cssutils/tests/sheets/html.css
${PYSITELIB}/cssutils/tests/sheets/html20.css
${PYSITELIB}/cssutils/tests/sheets/html40.css
${PYSITELIB}/cssutils/tests/sheets/images/example.gif
${PYSITELIB}/cssutils/tests/sheets/import.css
${PYSITELIB}/cssutils/tests/sheets/import/images2/example2.gif
${PYSITELIB}/cssutils/tests/sheets/import/import-impossible.css
${PYSITELIB}/cssutils/tests/sheets/import/import2.css
${PYSITELIB}/cssutils/tests/sheets/import3.css
${PYSITELIB}/cssutils/tests/sheets/ll.css
${PYSITELIB}/cssutils/tests/sheets/ll2.css
${PYSITELIB}/cssutils/tests/sheets/multiple-values.css
${PYSITELIB}/cssutils/tests/sheets/page_test.css
${PYSITELIB}/cssutils/tests/sheets/sample_5.css
${PYSITELIB}/cssutils/tests/sheets/sample_7.css
${PYSITELIB}/cssutils/tests/sheets/simple.css
${PYSITELIB}/cssutils/tests/sheets/single-color.css
${PYSITELIB}/cssutils/tests/sheets/slashcode.css
${PYSITELIB}/cssutils/tests/sheets/t-HACKS.css
${PYSITELIB}/cssutils/tests/sheets/test-unicode.css
${PYSITELIB}/cssutils/tests/sheets/test.css
${PYSITELIB}/cssutils/tests/sheets/tigris.css
${PYSITELIB}/cssutils/tests/sheets/tigris2.css
${PYSITELIB}/cssutils/tests/sheets/u_simple.css
${PYSITELIB}/cssutils/tests/sheets/v_simple.css
${PYSITELIB}/cssutils/tests/sheets/var/start.css
${PYSITELIB}/cssutils/tests/sheets/var/use.css
${PYSITELIB}/cssutils/tests/sheets/var/vars.css
${PYSITELIB}/cssutils/tests/sheets/var/vars2.css
${PYSITELIB}/cssutils/tests/sheets/vars.css
${PYSITELIB}/cssutils/tests/sheets/varsimport.css
${PYSITELIB}/cssutils/tests/sheets/xhtml2.css
${PYSITELIB}/cssutils/tests/sheets/xhtml22.css
${PYSITELIB}/cssutils/tests/sheets/yuck.css
${PYSITELIB}/cssutils/tests/test_codec.py
${PYSITELIB}/cssutils/tests/test_codec.pyc
${PYSITELIB}/cssutils/tests/test_codec.pyo
Expand Down
10 changes: 5 additions & 5 deletions textproc/py-cssutils/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2015/11/04 02:00:02 agc Exp $
$NetBSD: distinfo,v 1.6 2017/04/14 13:06:49 leot Exp $

SHA1 (cssutils-1.0.zip) = 341e57dbb02b699745b13a9a3296634209d26169
RMD160 (cssutils-1.0.zip) = 16efd2eca89977a98fb0edb01e17ed5233b43f2e
SHA512 (cssutils-1.0.zip) = fac2e46edece73fac66a741c7226b7a1ed9ef58d4a621e60a5b7ecd96dc74c5121969f007bd80a6dddea06a811dbc85b3691940cefc7a5b887fc458febb974e8
Size (cssutils-1.0.zip) = 434178 bytes
SHA1 (cssutils-1.0.2.tar.gz) = cd940e8b16a603f319763cf9144baa34380d4599
RMD160 (cssutils-1.0.2.tar.gz) = ca6af81a4bc73354056a78f0a5644371bd8fa199
SHA512 (cssutils-1.0.2.tar.gz) = 4988893875a03923d3127e334654799e5c2ebcdc0a7f5b3fb5c9ab27d1b331caa5bf197161312a298531e0757843aa3259ceba5fa19947353eea24a5da53ceda
Size (cssutils-1.0.2.tar.gz) = 367038 bytes

0 comments on commit f8017cc

Please sign in to comment.