Skip to content

Commit

Permalink
Updated py-oauth2client to 4.0.0.
Browse files Browse the repository at this point in the history
## v4.0.0

New features:
* New Django samples. (#636)
* Add support for RFC7636 PKCE. (#588)
* Release as a universal wheel. (#665)

Bug fixes:
* Fix django authorization redirect by correctly checking validity of credentials. (#651)
* Correct query loss when using parse_qsl to dict. (#622)
* Switch django models from pickle to jsonpickle. (#614)
* Support new MIDDLEWARE Django 1.10 aetting. (#623)
* Remove usage of os.environ.setdefault. (#621)
* Handle missing storage files correctly. (#576)
* Try to revoke token with POST when getting a 405. (#662)

Internal changes:
* Use transport module for GCE environment check. (#612)
* Remove __author__ lines and add contributors.md. (#627)
* Clean up imports. (#625)
* Use transport.request in tests. (#607)
* Drop unittest2 dependency (#610)
* Remove backslash line continuations. (#608)
* Use transport helpers in system tests. (#606)
* Clean up usage of HTTP mocks in tests. (#605)
* Remove all uses of MagicMock. (#598)
* Migrate test runner to pytest. (#569)
* Merge util.py and _helpers.py. (#579)
* Remove httplib2 imports from non-transport modules. (#577)

Breaking changes:
* Drop Python 3.3 support. (#603)
* Drop Python 2.6 support. (#590)
* Remove multistore_file. (#589)

## v3.0.0

* Populate `token_expiry` for GCE credentials. (#473)
* Move GCE metadata interface to a separate module. (#520)
* Populate `scopes` for GCE credentials. (#524)
* Fix Python 3.5 compatibility. (#531)
* Add `oauth2client.contrib.sqlalchemy`, a SQLAlchemy-based credential store. (#527)
* Improve error when an invalid client secret is provided. (#530)
* Add `oauth2client.contrib.multiprocess_storage`. This supersedes the functionality in `oauth2client.contrib.multistore_file`. (#504)
* Pull httplib2 usage into a separate transport module. (#559, #561)
* Refactor all django-related code into `oauth2client.contrib.django_util`. Add `DjangoORMStorage`, remove `FlowField`. (#546)
* Fix application default credentials resolution order. (#570)
* Add configurable timeout for GCE metadata server check. (#571)
* Add warnings when using deprecated `approval_prompt='force'`. (#572)
* Add deprecation warning to `oauth2client.contrib.multistore_file`. (#574)
* (Hygiene) PEP8 compliance and various style fixes (#537, #540, #552, #562)
* (Hygiene) Remove duplicated exception classes in `oauth2client.contrib.appengine`. (#533)

NOTE: The next major release of oauth2client (v4.0.0) will remove the `oauth2client.contrib.multistore_file` module.

## v2.2.0

* Added support to override `token_uri` and `revoke_uri` in `oauth2client.service_account.ServiceAccountCredentials`. (#510)
* `oauth2client.contrib.multistore_file` now handles `OSError` in addition to `IOError` because Windows may raise `OSError` where other platforms will raise `IOError`.
* `oauth2client.contrib.django_util` and `oauth2client.contrib.django_orm` have been updated to support Django 1.8 - 1.10. Versions of Django below 1.8 will not work with these modules.

## v2.1.0

* Add basic support for JWT access credentials. (#503)
* Fix `oauth2client.client.DeviceFlowInfo` to use UTC instead of the system timezone when calculating code expiration.

## v2.0.2

* Fix issue where `flask_util.UserOAuth2.required` would accept expired credentials (#452).
* Fix issue where `flask_util` would fill the session with `Flow` objects (#498).
* Fix issue with Python 3 binary strings in `Flow.step2_exchange` (#446).
* Improve test coverage to 100%.

## v2.0.1

* Making scopes optional on Google Compute Engine `AppAssertionCredentials`
  and adding a warning that GCE won't honor scopes (#419)
* Adding common `sign_blob()` to service account types and a
  `service_account_email` property. (#421)
* Improving error message in P12 factory
  `ServiceAccountCredentials.from_p12_keyfile` when pyOpenSSL is
  missing. (#424)
* Allowing default flags in `oauth2client.tools.run_flow()`
  rather than forcing users to create a dummy argparser (#426)
* Removing `oauth2client.util.dict_to_tuple_key()` from public
  interface (#429)
* Adding `oauth2client.contrib._appengine_ndb` helper module
  for `oauth2client.contrib.appengine` and moving most code that
  uses the `ndb` library into the helper (#434)
* Fix error in `django_util` sample code (#438)

## v2.0.0-post1

* Fix Google Compute Engine breakage (#411, breakage introduced in #387) that
  made it impossible to obtain access tokens
* Implement `ServiceAccountCredentials.from_p12_keyfile_buffer()`
  to allow passing a file-like object in addition to the factory
  constructor that uses a filename directly (#413)
* Implement `ServiceAccountCredentials.create_delegated()`
  to allow upgrading a credential to one that acts on behalf
  of a given subject (#420)
  • Loading branch information
wiz committed Oct 19, 2016
1 parent 6e327b5 commit ec03e3e
Show file tree
Hide file tree
Showing 3 changed files with 86 additions and 40 deletions.
6 changes: 2 additions & 4 deletions security/py-oauth2client/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.4 2016/03/03 12:59:55 wiz Exp $
# $NetBSD: Makefile,v 1.5 2016/10/19 13:02:48 wiz Exp $

DISTNAME= oauth2client-2.0.0
DISTNAME= oauth2client-4.0.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= security net python
MASTER_SITES= -https://github.com/google/oauth2client/archive/v${PKGVERSION_NOREV}${EXTRACT_SUFX}
Expand All @@ -16,8 +16,6 @@ DEPENDS+= ${PYPKGPREFIX}-httplib2-[0-9]*:../../www/py-httplib2
DEPENDS+= ${PYPKGPREFIX}-rsa-[0-9]*:../../security/py-rsa
DEPENDS+= ${PYPKGPREFIX}-six-[0-9]*:../../lang/py-six

REPLACE_PYTHON+= oauth2client/util.py

.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"
110 changes: 79 additions & 31 deletions security/py-oauth2client/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2016/03/03 12:59:55 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2016/10/19 13:02:48 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand All @@ -13,6 +13,9 @@ ${PYSITELIB}/oauth2client/_helpers.pyo
${PYSITELIB}/oauth2client/_openssl_crypt.py
${PYSITELIB}/oauth2client/_openssl_crypt.pyc
${PYSITELIB}/oauth2client/_openssl_crypt.pyo
${PYSITELIB}/oauth2client/_pkce.py
${PYSITELIB}/oauth2client/_pkce.pyc
${PYSITELIB}/oauth2client/_pkce.pyo
${PYSITELIB}/oauth2client/_pure_python_crypt.py
${PYSITELIB}/oauth2client/_pure_python_crypt.pyc
${PYSITELIB}/oauth2client/_pure_python_crypt.pyo
Expand All @@ -28,6 +31,12 @@ ${PYSITELIB}/oauth2client/clientsecrets.pyo
${PYSITELIB}/oauth2client/contrib/__init__.py
${PYSITELIB}/oauth2client/contrib/__init__.pyc
${PYSITELIB}/oauth2client/contrib/__init__.pyo
${PYSITELIB}/oauth2client/contrib/_appengine_ndb.py
${PYSITELIB}/oauth2client/contrib/_appengine_ndb.pyc
${PYSITELIB}/oauth2client/contrib/_appengine_ndb.pyo
${PYSITELIB}/oauth2client/contrib/_metadata.py
${PYSITELIB}/oauth2client/contrib/_metadata.pyc
${PYSITELIB}/oauth2client/contrib/_metadata.pyo
${PYSITELIB}/oauth2client/contrib/appengine.py
${PYSITELIB}/oauth2client/contrib/appengine.pyc
${PYSITELIB}/oauth2client/contrib/appengine.pyo
Expand All @@ -37,9 +46,6 @@ ${PYSITELIB}/oauth2client/contrib/devshell.pyo
${PYSITELIB}/oauth2client/contrib/dictionary_storage.py
${PYSITELIB}/oauth2client/contrib/dictionary_storage.pyc
${PYSITELIB}/oauth2client/contrib/dictionary_storage.pyo
${PYSITELIB}/oauth2client/contrib/django_orm.py
${PYSITELIB}/oauth2client/contrib/django_orm.pyc
${PYSITELIB}/oauth2client/contrib/django_orm.pyo
${PYSITELIB}/oauth2client/contrib/django_util/__init__.py
${PYSITELIB}/oauth2client/contrib/django_util/__init__.pyc
${PYSITELIB}/oauth2client/contrib/django_util/__init__.pyo
Expand All @@ -49,6 +55,9 @@ ${PYSITELIB}/oauth2client/contrib/django_util/apps.pyo
${PYSITELIB}/oauth2client/contrib/django_util/decorators.py
${PYSITELIB}/oauth2client/contrib/django_util/decorators.pyc
${PYSITELIB}/oauth2client/contrib/django_util/decorators.pyo
${PYSITELIB}/oauth2client/contrib/django_util/models.py
${PYSITELIB}/oauth2client/contrib/django_util/models.pyc
${PYSITELIB}/oauth2client/contrib/django_util/models.pyo
${PYSITELIB}/oauth2client/contrib/django_util/signals.py
${PYSITELIB}/oauth2client/contrib/django_util/signals.pyc
${PYSITELIB}/oauth2client/contrib/django_util/signals.pyo
Expand All @@ -70,12 +79,12 @@ ${PYSITELIB}/oauth2client/contrib/gce.pyo
${PYSITELIB}/oauth2client/contrib/keyring_storage.py
${PYSITELIB}/oauth2client/contrib/keyring_storage.pyc
${PYSITELIB}/oauth2client/contrib/keyring_storage.pyo
${PYSITELIB}/oauth2client/contrib/locked_file.py
${PYSITELIB}/oauth2client/contrib/locked_file.pyc
${PYSITELIB}/oauth2client/contrib/locked_file.pyo
${PYSITELIB}/oauth2client/contrib/multistore_file.py
${PYSITELIB}/oauth2client/contrib/multistore_file.pyc
${PYSITELIB}/oauth2client/contrib/multistore_file.pyo
${PYSITELIB}/oauth2client/contrib/multiprocess_file_storage.py
${PYSITELIB}/oauth2client/contrib/multiprocess_file_storage.pyc
${PYSITELIB}/oauth2client/contrib/multiprocess_file_storage.pyo
${PYSITELIB}/oauth2client/contrib/sqlalchemy.py
${PYSITELIB}/oauth2client/contrib/sqlalchemy.pyc
${PYSITELIB}/oauth2client/contrib/sqlalchemy.pyo
${PYSITELIB}/oauth2client/contrib/xsrfutil.py
${PYSITELIB}/oauth2client/contrib/xsrfutil.pyc
${PYSITELIB}/oauth2client/contrib/xsrfutil.pyo
Expand All @@ -91,33 +100,63 @@ ${PYSITELIB}/oauth2client/service_account.pyo
${PYSITELIB}/oauth2client/tools.py
${PYSITELIB}/oauth2client/tools.pyc
${PYSITELIB}/oauth2client/tools.pyo
${PYSITELIB}/oauth2client/util.py
${PYSITELIB}/oauth2client/util.pyc
${PYSITELIB}/oauth2client/util.pyo
${PYSITELIB}/oauth2client/transport.py
${PYSITELIB}/oauth2client/transport.pyc
${PYSITELIB}/oauth2client/transport.pyo
${PYSITELIB}/tests/__init__.py
${PYSITELIB}/tests/__init__.pyc
${PYSITELIB}/tests/__init__.pyo
${PYSITELIB}/tests/conftest.py
${PYSITELIB}/tests/conftest.pyc
${PYSITELIB}/tests/conftest.pyo
${PYSITELIB}/tests/contrib/__init__.py
${PYSITELIB}/tests/contrib/__init__.pyc
${PYSITELIB}/tests/contrib/__init__.pyo
${PYSITELIB}/tests/contrib/test_appengine.py
${PYSITELIB}/tests/contrib/test_appengine.pyc
${PYSITELIB}/tests/contrib/test_appengine.pyo
${PYSITELIB}/tests/contrib/appengine/__init__.py
${PYSITELIB}/tests/contrib/appengine/__init__.pyc
${PYSITELIB}/tests/contrib/appengine/__init__.pyo
${PYSITELIB}/tests/contrib/appengine/conftest.py
${PYSITELIB}/tests/contrib/appengine/conftest.pyc
${PYSITELIB}/tests/contrib/appengine/conftest.pyo
${PYSITELIB}/tests/contrib/appengine/test__appengine_ndb.py
${PYSITELIB}/tests/contrib/appengine/test__appengine_ndb.pyc
${PYSITELIB}/tests/contrib/appengine/test__appengine_ndb.pyo
${PYSITELIB}/tests/contrib/appengine/test_appengine.py
${PYSITELIB}/tests/contrib/appengine/test_appengine.pyc
${PYSITELIB}/tests/contrib/appengine/test_appengine.pyo
${PYSITELIB}/tests/contrib/django_util/__init__.py
${PYSITELIB}/tests/contrib/django_util/__init__.pyc
${PYSITELIB}/tests/contrib/django_util/__init__.pyo
${PYSITELIB}/tests/contrib/django_util/apps.py
${PYSITELIB}/tests/contrib/django_util/apps.pyc
${PYSITELIB}/tests/contrib/django_util/apps.pyo
${PYSITELIB}/tests/contrib/django_util/models.py
${PYSITELIB}/tests/contrib/django_util/models.pyc
${PYSITELIB}/tests/contrib/django_util/models.pyo
${PYSITELIB}/tests/contrib/django_util/settings.py
${PYSITELIB}/tests/contrib/django_util/settings.pyc
${PYSITELIB}/tests/contrib/django_util/settings.pyo
${PYSITELIB}/tests/contrib/django_util/test_decorators.py
${PYSITELIB}/tests/contrib/django_util/test_decorators.pyc
${PYSITELIB}/tests/contrib/django_util/test_decorators.pyo
${PYSITELIB}/tests/contrib/django_util/test_django_models.py
${PYSITELIB}/tests/contrib/django_util/test_django_models.pyc
${PYSITELIB}/tests/contrib/django_util/test_django_models.pyo
${PYSITELIB}/tests/contrib/django_util/test_django_storage.py
${PYSITELIB}/tests/contrib/django_util/test_django_storage.pyc
${PYSITELIB}/tests/contrib/django_util/test_django_storage.pyo
${PYSITELIB}/tests/contrib/django_util/test_django_util.py
${PYSITELIB}/tests/contrib/django_util/test_django_util.pyc
${PYSITELIB}/tests/contrib/django_util/test_django_util.pyo
${PYSITELIB}/tests/contrib/django_util/test_views.py
${PYSITELIB}/tests/contrib/django_util/test_views.pyc
${PYSITELIB}/tests/contrib/django_util/test_views.pyo
${PYSITELIB}/tests/contrib/test_devshell.py
${PYSITELIB}/tests/contrib/test_devshell.pyc
${PYSITELIB}/tests/contrib/test_devshell.pyo
${PYSITELIB}/tests/contrib/test_dictionary_storage.py
${PYSITELIB}/tests/contrib/test_dictionary_storage.pyc
${PYSITELIB}/tests/contrib/test_dictionary_storage.pyo
${PYSITELIB}/tests/contrib/test_django_orm.py
${PYSITELIB}/tests/contrib/test_django_orm.pyc
${PYSITELIB}/tests/contrib/test_django_orm.pyo
${PYSITELIB}/tests/contrib/test_django_settings.py
${PYSITELIB}/tests/contrib/test_django_settings.pyc
${PYSITELIB}/tests/contrib/test_django_settings.pyo
${PYSITELIB}/tests/contrib/test_django_util.py
${PYSITELIB}/tests/contrib/test_django_util.pyc
${PYSITELIB}/tests/contrib/test_django_util.pyo
${PYSITELIB}/tests/contrib/test_flask_util.py
${PYSITELIB}/tests/contrib/test_flask_util.pyc
${PYSITELIB}/tests/contrib/test_flask_util.pyo
Expand All @@ -127,9 +166,15 @@ ${PYSITELIB}/tests/contrib/test_gce.pyo
${PYSITELIB}/tests/contrib/test_keyring_storage.py
${PYSITELIB}/tests/contrib/test_keyring_storage.pyc
${PYSITELIB}/tests/contrib/test_keyring_storage.pyo
${PYSITELIB}/tests/contrib/test_multistore_file.py
${PYSITELIB}/tests/contrib/test_multistore_file.pyc
${PYSITELIB}/tests/contrib/test_multistore_file.pyo
${PYSITELIB}/tests/contrib/test_metadata.py
${PYSITELIB}/tests/contrib/test_metadata.pyc
${PYSITELIB}/tests/contrib/test_metadata.pyo
${PYSITELIB}/tests/contrib/test_multiprocess_file_storage.py
${PYSITELIB}/tests/contrib/test_multiprocess_file_storage.pyc
${PYSITELIB}/tests/contrib/test_multiprocess_file_storage.pyo
${PYSITELIB}/tests/contrib/test_sqlalchemy.py
${PYSITELIB}/tests/contrib/test_sqlalchemy.pyc
${PYSITELIB}/tests/contrib/test_sqlalchemy.pyo
${PYSITELIB}/tests/contrib/test_xsrfutil.py
${PYSITELIB}/tests/contrib/test_xsrfutil.pyc
${PYSITELIB}/tests/contrib/test_xsrfutil.pyo
Expand All @@ -139,6 +184,9 @@ ${PYSITELIB}/tests/http_mock.pyo
${PYSITELIB}/tests/test__helpers.py
${PYSITELIB}/tests/test__helpers.pyc
${PYSITELIB}/tests/test__helpers.pyo
${PYSITELIB}/tests/test__pkce.py
${PYSITELIB}/tests/test__pkce.pyc
${PYSITELIB}/tests/test__pkce.pyo
${PYSITELIB}/tests/test__pure_python_crypt.py
${PYSITELIB}/tests/test__pure_python_crypt.pyc
${PYSITELIB}/tests/test__pure_python_crypt.pyo
Expand Down Expand Up @@ -166,6 +214,6 @@ ${PYSITELIB}/tests/test_service_account.pyo
${PYSITELIB}/tests/test_tools.py
${PYSITELIB}/tests/test_tools.pyc
${PYSITELIB}/tests/test_tools.pyo
${PYSITELIB}/tests/test_util.py
${PYSITELIB}/tests/test_util.pyc
${PYSITELIB}/tests/test_util.pyo
${PYSITELIB}/tests/test_transport.py
${PYSITELIB}/tests/test_transport.pyc
${PYSITELIB}/tests/test_transport.pyo
10 changes: 5 additions & 5 deletions security/py-oauth2client/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2016/03/03 12:59:55 wiz Exp $
$NetBSD: distinfo,v 1.6 2016/10/19 13:02:48 wiz Exp $

SHA1 (oauth2client-2.0.0.tar.gz) = 4f5e710b85d18df312fed8ecec56e82f73fc5591
RMD160 (oauth2client-2.0.0.tar.gz) = d952d17777a52754458107c7a5818f9e816ae666
SHA512 (oauth2client-2.0.0.tar.gz) = 4839f9ea6384fa19ee55ee953ef4e38211afd7e409a77658e535534632dd182aabb857cebc1969bcba5d80c63fa79f965a2c0b1bb2832975c1ed8dd3cd6d3042
Size (oauth2client-2.0.0.tar.gz) = 148575 bytes
SHA1 (oauth2client-4.0.0.tar.gz) = bdce685cd0586e03f75aa1963751373e3850eb79
RMD160 (oauth2client-4.0.0.tar.gz) = 654f15187861515992db1c3e66cbb7008400e2da
SHA512 (oauth2client-4.0.0.tar.gz) = b59805702c7acb306801a04a92b7f700c0f58d5937b4b27a497018d313922512b5ec3f1711bacf13bc7e01c4f006eda5344a9055f981ba34e116c34c56c5dfec
Size (oauth2client-4.0.0.tar.gz) = 183288 bytes

0 comments on commit ec03e3e

Please sign in to comment.