Skip to content

Commit

Permalink
Update to 0.9.5.3
Browse files Browse the repository at this point in the history
Changelog:
================================================================================
GLM 0.9.5.4: 2014-06-21
--------------------------------------------------------------------------------
- Fixed non-utf8 character #196
- Added FindGLM install for CMake #189
- Fixed GTX_color_space - saturation #195
- Fixed glm::isinf and glm::isnan for with Android NDK 9d #191
- Fixed builtin GLM_ARCH_SSE4 #204
- Optimized Quaternion vector rotation #205
- Fixed missing doxygen @endcond tag #211
- Fixed instruction set detection with Clang #158
- Fixed orientate3 function #207
- Fixed lerp when cosTheta is close to 1 in quaternion slerp #210
- Added GTX_io for io with <iostream> #144
- Fixed fastDistance ambiguity #215
- Fixed tweakedInfinitePerspective #208 and added user-defined epsilon to
  tweakedInfinitePerspective
- Fixed std::copy and std::vector with GLM types #214
- Fixed strict aliasing issues #212, #152
- Fixed std::nextafter not supported with C++11 on Android #213
- Fixed corner cases in exp and log functions for quaternions #199

================================================================================
GLM 0.9.5.3: 2014-04-02
--------------------------------------------------------------------------------
- Added instruction set auto detection with Visual C++ using _M_IX86_FP - /arch
  compiler argument
- Fixed GTX_raw_data code dependency
- Fixed GCC instruction set detection
- Added GLM_GTX_matrix_transform_2d extension (#178, #176)
- Fixed CUDA issues (#169, #168, #183, #182)
- Added support for all extensions but GTX_string_cast to CUDA
- Fixed strict aliasing warnings in GCC 4.8.1 / Android NDK 9c (#152)
- Fixed missing bitfieldInterleave definisions
- Fixed usubBorrow (#171)
- Fixed eulerAngle*** not consistent for right-handed coordinate system (#173)
- Added full tests for eulerAngle*** functions (#173)
- Added workaround for a CUDA compiler bug (#186, #185)

================================================================================
GLM 0.9.5.2: 2014-02-08
--------------------------------------------------------------------------------
- Fixed initializer list ambiguity (#159, #160)
- Fixed warnings with the Android NDK 9c
- Fixed non power of two matrix products
- Fixed mix function link error
- Fixed SSE code included in GLM tests on "pure" platforms
- Fixed undefined reference to fastInverseSqrt (#161)
- Fixed GLM_FORCE_RADIANS with <glm/ext.hpp> build error (#165)
- Fix dot product clamp range for vector angle functions. (#163)
- Tentative fix for strict aliasing warning in GCC 4.8.1 / Android NDK 9c (#152)
- Fixed GLM_GTC_constants description brief (#162)

================================================================================
GLM 0.9.5.1: 2014-01-11
--------------------------------------------------------------------------------
- Fixed angle and orientedAngle that sometimes return NaN values (#145)
- Deprecated degrees for function parameters and display a message
- Added possible static_cast conversion of GLM types (#72)
- Fixed error 'inverse' is not a member of 'glm' from glm::unProject (#146)
- Fixed mismatch between some declarations and definitions
- Fixed inverse link error when using namespace glm; (#147)
- Optimized matrix inverse and division code (#149)
- Added intersectRayPlane function (#153)
- Fixed outerProduct return type (#155)

================================================================================
GLM 0.9.5.0: 2013-12-25
--------------------------------------------------------------------------------
- Added forward declarations (glm/fwd.hpp) for faster compilations
- Added per feature headers
- Minimized GLM internal dependencies
- Improved Intel Compiler detection
- Added bitfieldInterleave and _mm_bit_interleave_si128 functions
- Added GTX_scalar_relational
- Added GTX_dual_quaternion
- Added rotation function to GTX_quaternion (#22)
- Added precision variation of each type
- Added quaternion comparison functions
- Fixed GTX_multiple for negative value
- Removed GTX_ocl_type extension
- Fixed post increment and decrement operators
- Fixed perspective with zNear == 0 (#71)
- Removed l-value swizzle operators
- Cleaned up compiler detection code for unsupported compilers
- Replaced C cast by C++ casts
- Fixed .length() that should return a int and not a size_t
- Added GLM_FORCE_SIZE_T_LENGTH and glm::length_t
- Removed unnecessary conversions
- Optimized packing and unpacking functions
- Removed the normalization of the up argument of lookAt function (#114)
- Added low precision specializations of inversesqrt
- Fixed ldexp and frexp implementations
- Increased assert coverage
- Increased static_assert coverage
- Replaced GLM traits by STL traits when possible
- Allowed including individual core feature
- Increased unit tests completness
- Added creating of a quaternion from two vectors
- Added C++11 initializer lists
- Fixed umulExtended and imulExtended implementations for vector types (#76)
- Fixed CUDA coverage for GTC extensions
- Added GTX_io extension
- Improved GLM messages enabled when defining GLM_MESSAGES
- Hidden matrix _inverse function implementation detail into private section

================================================================================
GLM 0.9.4.6: 2013-09-20
--------------------------------------------------------------------------------
- Fixed detection to select the last known compiler if newer version #106
- Fixed is_int and is_uint code duplication with GCC and C++11 #107
- Fixed test suite build while using Clang in C++11 mode
- Added c++1y mode support in CMake test suite
- Removed ms extension mode to CMake when no using Visual C++
- Added pedantic mode to CMake test suite for Clang and GCC
- Added use of GCC frontend on Unix for ICC and Visual C++ fronted on Windows
  for ICC
- Added compilation errors for unsupported compiler versions
- Fixed glm::orientation with GLM_FORCE_RADIANS defined #112
- Fixed const ref issue on assignment operator taking a scalar parameter #116
- Fixed glm::eulerAngleY implementation #117

================================================================================
GLM 0.9.4.5: 2013-08-12
--------------------------------------------------------------------------------
- Fixed CUDA support
- Fixed inclusion of intrinsics in "pure" mode #92
- Fixed language detection on GCC when the C++0x mode isn't enabled #95
- Fixed issue #97: register is deprecated in C++11
- Fixed issue #96: CUDA issues
- Added Windows CE detection #92
- Added missing value_ptr for quaternions #99

================================================================================
GLM 0.9.4.4: 2013-05-29
--------------------------------------------------------------------------------
- Fixed slerp when costheta is close to 1 #65
- Fixed mat4x2 value_type constructor #70
- Fixed glm.natvis for Visual C++ 12 #82
- Added assert in inversesqrt to detect division by zero #61
- Fixed missing swizzle operators #86
- Fixed CUDA warnings #86
- Fixed GLM natvis for VC11 #82
- Fixed GLM_GTX_multiple with negative values #79
- Fixed glm::perspective when zNear is zero #71

================================================================================
GLM 0.9.4.3: 2013-03-20
--------------------------------------------------------------------------------
- Detected qualifier for Clang
- Fixed C++11 mode for GCC, couldn't be enabled without MS extensions
- Fixed squad, intermediate and exp quaternion functions
- Fixed GTX_polar_coordinates euclidean function, takes a vec2 instead of a vec3
- Clarify the license applying on the manual
- Added a docx copy of the manual
- Fixed GLM_GTX_matrix_interpolation
- Fixed isnan and isinf on Android with Clang
- Autodetected C++ version using __cplusplus value
- Fixed mix for bool and bvec* third parameter

================================================================================
GLM 0.9.4.2: 2013-02-14
--------------------------------------------------------------------------------
- Fixed compAdd from GTX_component_wise
- Fixed SIMD support for Intel compiler on Windows
- Fixed isnan and isinf for CUDA compiler
- Fixed GLM_FORCE_RADIANS on glm::perspective
- Fixed GCC warnings
- Fixed packDouble2x32 on XCode
- Fixed mix for vec4 SSE implementation
- Fixed 0x2013 dash character in comments that cause issue in Windows
  Japanese mode
- Fixed documentation warnings
- Fixed CUDA warnings

================================================================================
GLM 0.9.4.1: 2012-12-22
--------------------------------------------------------------------------------
- Improved half support: -0.0 case and implicit conversions
- Fixed Intel Composer Compiler support on Linux
- Fixed interaction between quaternion and euler angles
- Fixed GTC_constants build
- Fixed GTX_multiple
- Fixed quat slerp using mix function when cosTheta close to 1
- Improved fvec4SIMD and fmat4x4SIMD implementations
- Fixed assert messages
- Added slerp and lerp quaternion functions and tests

================================================================================
GLM 0.9.4.0: 2012-11-18
--------------------------------------------------------------------------------
- Added Intel Composer Compiler support
- Promoted GTC_espilon extension
- Promoted GTC_ulp extension
- Removed GLM website from the source repository
- Added GLM_FORCE_RADIANS so that all functions takes radians for arguments
- Fixed detection of Clang and LLVM GCC on MacOS X
- Added debugger visualizers for Visual C++ 2012

================================================================================
GLM 0.9.3.4: 2012-06-30
--------------------------------------------------------------------------------
- Added SSE4 and AVX2 detection.
- Removed VIRTREV_xstream and the incompatibility generated with GCC
- Fixed C++11 compiler option for GCC
- Removed MS language extension option for GCC (not fonctionnal)
- Fixed bitfieldExtract for vector types
- Fixed warnings
- Fixed SSE includes

================================================================================
GLM 0.9.3.3: 2012-05-10
--------------------------------------------------------------------------------
- Fixed isinf and isnan
- Improved compatibility with Intel compiler
- Added CMake test build options: SIMD, C++11, fast math and MS land ext
- Fixed SIMD mat4 test on GCC
- Fixed perspectiveFov implementation
- Fixed matrixCompMult for none-square matrices
- Fixed namespace issue on stream operators
- Fixed various warnings
- Added VC11 support
  • Loading branch information
ryoon committed Oct 13, 2014
1 parent 4994047 commit bd96948
Show file tree
Hide file tree
Showing 4 changed files with 137 additions and 106 deletions.
10 changes: 6 additions & 4 deletions graphics/glm/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2012/10/06 14:10:55 asau Exp $
# $NetBSD: Makefile,v 1.3 2014/10/13 21:47:59 ryoon Exp $
#

DISTNAME= glm-0.9.3.2
DISTNAME= glm-0.9.5.4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ogl-math/}
EXTRACT_SUFX= .zip
Expand All @@ -11,6 +11,8 @@ HOMEPAGE= http://glm.g-truc.net/
COMMENT= C++ mathematics library for graphics programming
LICENSE= mit

WRKSRC= ${WRKDIR}/glm

NO_BUILD= yes
NO_CONFIGURE= yes

Expand All @@ -21,9 +23,9 @@ INSTALLATION_DIRS= ${GLM_DIR}

do-install:
${RUN}cd ${WRKSRC}/glm && \
${CHMOD} 644 *hpp core/* gtc/* gtx/* virtrev/*
${CHMOD} 644 *hpp detail/* gtc/* gtx/*
${RUN}cd ${WRKSRC}/glm && \
pax -rw *hpp core gtc gtx virtrev \
pax -rw *hpp detail gtc gtx \
${DESTDIR}${PREFIX}/${GLM_DIR}

# for test target
Expand Down
221 changes: 125 additions & 96 deletions graphics/glm/PLIST
Original file line number Diff line number Diff line change
@@ -1,84 +1,95 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2012/05/06 08:23:22 ryoon Exp $
include/glm/core/_detail.hpp
include/glm/core/_fixes.hpp
include/glm/core/_swizzle.hpp
include/glm/core/_swizzle_func.hpp
include/glm/core/_vectorize.hpp
include/glm/core/dummy.cpp
include/glm/core/func_common.hpp
include/glm/core/func_common.inl
include/glm/core/func_exponential.hpp
include/glm/core/func_exponential.inl
include/glm/core/func_geometric.hpp
include/glm/core/func_geometric.inl
include/glm/core/func_integer.hpp
include/glm/core/func_integer.inl
include/glm/core/func_matrix.hpp
include/glm/core/func_matrix.inl
include/glm/core/func_noise.hpp
include/glm/core/func_noise.inl
include/glm/core/func_packing.hpp
include/glm/core/func_packing.inl
include/glm/core/func_trigonometric.hpp
include/glm/core/func_trigonometric.inl
include/glm/core/func_vector_relational.hpp
include/glm/core/func_vector_relational.inl
include/glm/core/hint.hpp
include/glm/core/intrinsic_common.hpp
include/glm/core/intrinsic_common.inl
include/glm/core/intrinsic_exponential.hpp
include/glm/core/intrinsic_exponential.inl
include/glm/core/intrinsic_geometric.hpp
include/glm/core/intrinsic_geometric.inl
include/glm/core/intrinsic_matrix.hpp
include/glm/core/intrinsic_matrix.inl
include/glm/core/intrinsic_trigonometric.hpp
include/glm/core/intrinsic_trigonometric.inl
include/glm/core/intrinsic_vector_relational.hpp
include/glm/core/intrinsic_vector_relational.inl
include/glm/core/setup.hpp
include/glm/core/type.hpp
include/glm/core/type_float.hpp
include/glm/core/type_gentype.hpp
include/glm/core/type_gentype.inl
include/glm/core/type_half.hpp
include/glm/core/type_half.inl
include/glm/core/type_int.hpp
include/glm/core/type_mat.hpp
include/glm/core/type_mat.inl
include/glm/core/type_mat2x2.hpp
include/glm/core/type_mat2x2.inl
include/glm/core/type_mat2x3.hpp
include/glm/core/type_mat2x3.inl
include/glm/core/type_mat2x4.hpp
include/glm/core/type_mat2x4.inl
include/glm/core/type_mat3x2.hpp
include/glm/core/type_mat3x2.inl
include/glm/core/type_mat3x3.hpp
include/glm/core/type_mat3x3.inl
include/glm/core/type_mat3x4.hpp
include/glm/core/type_mat3x4.inl
include/glm/core/type_mat4x2.hpp
include/glm/core/type_mat4x2.inl
include/glm/core/type_mat4x3.hpp
include/glm/core/type_mat4x3.inl
include/glm/core/type_mat4x4.hpp
include/glm/core/type_mat4x4.inl
include/glm/core/type_size.hpp
include/glm/core/type_vec.hpp
include/glm/core/type_vec.inl
include/glm/core/type_vec1.hpp
include/glm/core/type_vec1.inl
include/glm/core/type_vec2.hpp
include/glm/core/type_vec2.inl
include/glm/core/type_vec3.hpp
include/glm/core/type_vec3.inl
include/glm/core/type_vec4.hpp
include/glm/core/type_vec4.inl
@comment $NetBSD: PLIST,v 1.2 2014/10/13 21:47:59 ryoon Exp $
include/glm/common.hpp
include/glm/detail/_features.hpp
include/glm/detail/_fixes.hpp
include/glm/detail/_literals.hpp
include/glm/detail/_noise.hpp
include/glm/detail/_swizzle.hpp
include/glm/detail/_swizzle_func.hpp
include/glm/detail/_vectorize.hpp
include/glm/detail/dummy.cpp
include/glm/detail/func_common.hpp
include/glm/detail/func_common.inl
include/glm/detail/func_exponential.hpp
include/glm/detail/func_exponential.inl
include/glm/detail/func_geometric.hpp
include/glm/detail/func_geometric.inl
include/glm/detail/func_integer.hpp
include/glm/detail/func_integer.inl
include/glm/detail/func_matrix.hpp
include/glm/detail/func_matrix.inl
include/glm/detail/func_noise.hpp
include/glm/detail/func_noise.inl
include/glm/detail/func_packing.hpp
include/glm/detail/func_packing.inl
include/glm/detail/func_trigonometric.hpp
include/glm/detail/func_trigonometric.inl
include/glm/detail/func_vector_relational.hpp
include/glm/detail/func_vector_relational.inl
include/glm/detail/glm.cpp
include/glm/detail/hint.hpp
include/glm/detail/intrinsic_common.hpp
include/glm/detail/intrinsic_common.inl
include/glm/detail/intrinsic_exponential.hpp
include/glm/detail/intrinsic_exponential.inl
include/glm/detail/intrinsic_geometric.hpp
include/glm/detail/intrinsic_geometric.inl
include/glm/detail/intrinsic_integer.hpp
include/glm/detail/intrinsic_integer.inl
include/glm/detail/intrinsic_matrix.hpp
include/glm/detail/intrinsic_matrix.inl
include/glm/detail/intrinsic_trigonometric.hpp
include/glm/detail/intrinsic_trigonometric.inl
include/glm/detail/intrinsic_vector_relational.hpp
include/glm/detail/intrinsic_vector_relational.inl
include/glm/detail/precision.hpp
include/glm/detail/precision.inl
include/glm/detail/setup.hpp
include/glm/detail/type_float.hpp
include/glm/detail/type_gentype.hpp
include/glm/detail/type_gentype.inl
include/glm/detail/type_half.hpp
include/glm/detail/type_half.inl
include/glm/detail/type_int.hpp
include/glm/detail/type_mat.hpp
include/glm/detail/type_mat.inl
include/glm/detail/type_mat2x2.hpp
include/glm/detail/type_mat2x2.inl
include/glm/detail/type_mat2x3.hpp
include/glm/detail/type_mat2x3.inl
include/glm/detail/type_mat2x4.hpp
include/glm/detail/type_mat2x4.inl
include/glm/detail/type_mat3x2.hpp
include/glm/detail/type_mat3x2.inl
include/glm/detail/type_mat3x3.hpp
include/glm/detail/type_mat3x3.inl
include/glm/detail/type_mat3x4.hpp
include/glm/detail/type_mat3x4.inl
include/glm/detail/type_mat4x2.hpp
include/glm/detail/type_mat4x2.inl
include/glm/detail/type_mat4x3.hpp
include/glm/detail/type_mat4x3.inl
include/glm/detail/type_mat4x4.hpp
include/glm/detail/type_mat4x4.inl
include/glm/detail/type_vec.hpp
include/glm/detail/type_vec.inl
include/glm/detail/type_vec1.hpp
include/glm/detail/type_vec1.inl
include/glm/detail/type_vec2.hpp
include/glm/detail/type_vec2.inl
include/glm/detail/type_vec3.hpp
include/glm/detail/type_vec3.inl
include/glm/detail/type_vec4.hpp
include/glm/detail/type_vec4.inl
include/glm/exponential.hpp
include/glm/ext.hpp
include/glm/fwd.hpp
include/glm/geometric.hpp
include/glm/glm.hpp
include/glm/gtc/half_float.hpp
include/glm/gtc/half_float.inl
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
include/glm/gtc/epsilon.inl
include/glm/gtc/matrix_access.hpp
include/glm/gtc/matrix_access.inl
include/glm/gtc/matrix_integer.hpp
Expand All @@ -88,24 +99,26 @@ include/glm/gtc/matrix_transform.hpp
include/glm/gtc/matrix_transform.inl
include/glm/gtc/noise.hpp
include/glm/gtc/noise.inl
include/glm/gtc/packing.hpp
include/glm/gtc/packing.inl
include/glm/gtc/quaternion.hpp
include/glm/gtc/quaternion.inl
include/glm/gtc/random.hpp
include/glm/gtc/random.inl
include/glm/gtc/swizzle.hpp
include/glm/gtc/swizzle.inl
include/glm/gtc/reciprocal.hpp
include/glm/gtc/reciprocal.inl
include/glm/gtc/type_precision.hpp
include/glm/gtc/type_precision.inl
include/glm/gtc/type_ptr.hpp
include/glm/gtc/type_ptr.inl
include/glm/gtc/ulp.hpp
include/glm/gtc/ulp.inl
include/glm/gtx/associated_min_max.hpp
include/glm/gtx/associated_min_max.inl
include/glm/gtx/bit.hpp
include/glm/gtx/bit.inl
include/glm/gtx/closest_point.hpp
include/glm/gtx/closest_point.inl
include/glm/gtx/color_cast.hpp
include/glm/gtx/color_cast.inl
include/glm/gtx/color_space.hpp
include/glm/gtx/color_space.inl
include/glm/gtx/color_space_YCoCg.hpp
Expand All @@ -115,9 +128,9 @@ include/glm/gtx/compatibility.inl
include/glm/gtx/component_wise.hpp
include/glm/gtx/component_wise.inl
include/glm/gtx/constants.hpp
include/glm/gtx/constants.inl
include/glm/gtx/dual_quaternion.hpp
include/glm/gtx/dual_quaternion.inl
include/glm/gtx/epsilon.hpp
include/glm/gtx/epsilon.inl
include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
include/glm/gtx/extend.hpp
Expand All @@ -142,6 +155,8 @@ include/glm/gtx/integer.hpp
include/glm/gtx/integer.inl
include/glm/gtx/intersect.hpp
include/glm/gtx/intersect.inl
include/glm/gtx/io.hpp
include/glm/gtx/io.inl
include/glm/gtx/log_base.hpp
include/glm/gtx/log_base.inl
include/glm/gtx/matrix_cross_product.hpp
Expand All @@ -154,12 +169,13 @@ include/glm/gtx/matrix_operation.hpp
include/glm/gtx/matrix_operation.inl
include/glm/gtx/matrix_query.hpp
include/glm/gtx/matrix_query.inl
include/glm/gtx/matrix_transform_2d.hpp
include/glm/gtx/matrix_transform_2d.inl
include/glm/gtx/mixed_product.hpp
include/glm/gtx/mixed_product.inl
include/glm/gtx/multiple.hpp
include/glm/gtx/multiple.inl
include/glm/gtx/noise.hpp
include/glm/gtx/noise.inl
include/glm/gtx/norm.hpp
include/glm/gtx/norm.inl
include/glm/gtx/normal.hpp
Expand All @@ -168,8 +184,6 @@ include/glm/gtx/normalize_dot.hpp
include/glm/gtx/normalize_dot.inl
include/glm/gtx/number_precision.hpp
include/glm/gtx/number_precision.inl
include/glm/gtx/ocl_type.hpp
include/glm/gtx/ocl_type.inl
include/glm/gtx/optimum_pow.hpp
include/glm/gtx/optimum_pow.inl
include/glm/gtx/orthonormalize.hpp
Expand All @@ -183,15 +197,19 @@ include/glm/gtx/projection.inl
include/glm/gtx/quaternion.hpp
include/glm/gtx/quaternion.inl
include/glm/gtx/random.hpp
include/glm/gtx/random.inl
include/glm/gtx/raw_data.hpp
include/glm/gtx/raw_data.inl
include/glm/gtx/reciprocal.hpp
include/glm/gtx/reciprocal.inl
include/glm/gtx/rotate_normalized_axis.hpp
include/glm/gtx/rotate_normalized_axis.inl
include/glm/gtx/rotate_vector.hpp
include/glm/gtx/rotate_vector.inl
include/glm/gtx/scalar_relational.hpp
include/glm/gtx/scalar_relational.inl
include/glm/gtx/simd_mat4.hpp
include/glm/gtx/simd_mat4.inl
include/glm/gtx/simd_quat.hpp
include/glm/gtx/simd_quat.inl
include/glm/gtx/simd_vec4.hpp
include/glm/gtx/simd_vec4.inl
include/glm/gtx/spline.hpp
Expand All @@ -205,19 +223,30 @@ include/glm/gtx/transform.inl
include/glm/gtx/transform2.hpp
include/glm/gtx/transform2.inl
include/glm/gtx/ulp.hpp
include/glm/gtx/ulp.inl
include/glm/gtx/unsigned_int.hpp
include/glm/gtx/unsigned_int.inl
include/glm/gtx/vec1.hpp
include/glm/gtx/vec1.inl
include/glm/gtx/vector_access.hpp
include/glm/gtx/vector_access.inl
include/glm/gtx/vector_angle.hpp
include/glm/gtx/vector_angle.inl
include/glm/gtx/vector_query.hpp
include/glm/gtx/vector_query.inl
include/glm/gtx/verbose_operator.hpp
include/glm/gtx/verbose_operator.inl
include/glm/gtx/wrap.hpp
include/glm/gtx/wrap.inl
include/glm/virtrev/xstream.hpp
include/glm/integer.hpp
include/glm/mat2x2.hpp
include/glm/mat2x3.hpp
include/glm/mat2x4.hpp
include/glm/mat3x2.hpp
include/glm/mat3x3.hpp
include/glm/mat3x4.hpp
include/glm/mat4x2.hpp
include/glm/mat4x3.hpp
include/glm/mat4x4.hpp
include/glm/matrix.hpp
include/glm/packing.hpp
include/glm/trigonometric.hpp
include/glm/vec2.hpp
include/glm/vec3.hpp
include/glm/vec4.hpp
include/glm/vector_relational.hpp
4 changes: 2 additions & 2 deletions graphics/glm/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2012/05/06 08:23:22 ryoon Exp $
# $NetBSD: buildlink3.mk,v 1.2 2014/10/13 21:47:59 ryoon Exp $

BUILDLINK_TREE+= glm

Expand All @@ -7,7 +7,7 @@ GLM_BUILDLINK3_MK:=

BUILDLINK_DEPMETHOD.glm?= build

BUILDLINK_API_DEPENDS.glm+= glm>=0.9.3.2
BUILDLINK_API_DEPENDS.glm+= glm>=0.9.5.3
BUILDLINK_PKGSRCDIR.glm?= ../../graphics/glm
.endif # GLM_BUILDLINK3_MK

Expand Down
8 changes: 4 additions & 4 deletions graphics/glm/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2012/05/06 08:23:22 ryoon Exp $
$NetBSD: distinfo,v 1.2 2014/10/13 21:47:59 ryoon Exp $

SHA1 (glm-0.9.3.2.zip) = 0378dd2f8a434b63e62c87d2ea4942d873d4f75f
RMD160 (glm-0.9.3.2.zip) = 42f0a789b62dc4ef20782c539752cfe8ad7d9377
Size (glm-0.9.3.2.zip) = 6451695 bytes
SHA1 (glm-0.9.5.4.zip) = d9666b5b013d374c7d1a498c9495f7142f6fe9d3
RMD160 (glm-0.9.5.4.zip) = f5c22182f15901969aa2bf9fbfbafd653fbd5682
Size (glm-0.9.5.4.zip) = 4081182 bytes

0 comments on commit bd96948

Please sign in to comment.