Skip to content

Commit

Permalink
Updated to latest release, 1.5. Included lang/python/application.mk to
Browse files Browse the repository at this point in the history
REPLACE_PYTHON in two installed files. Lots of PLIST additions/moves. From
CHANGES.txt:

Changelog
=========

1.5 (2014-01-01)
----------------

* **BACKWARD INCOMPATIBLE** pip no longer supports the ``--use-mirrors``,
  ``-M``, and ``--mirrors`` flags. The mirroring support has been removed. In
  order to use a mirror specify it as the primary index with ``-i`` or
  ``--index-url``, or as an additional index with ``--extra-index-url``. (Pull #1098, CVE-2013-5123)

* **BACKWARD INCOMPATIBLE** pip no longer will scrape insecure external urls by
  default nor will it install externally hosted files by default. Users may opt
  into installing externally hosted or insecure files or urls using
  ``--allow-external PROJECT`` and ``--allow-unverified PROJECT``. (Pull #1055)

* **BACKWARD INCOMPATIBLE** pip no longer respects dependency links by default.
  Users may opt into respecting them again using ``--process-dependency-links``.

* **DEPRECATION** ``pip install --no-install`` and ``pip install
  --no-download`` are now formally deprecated.  See Issue #906 for discussion on
  possible alternatives, or lack thereof, in future releases.

* **DEPRECATION** ``pip zip`` and ``pip unzip`` are now formally deprecated.

* pip will now install Mac OSX platform wheels from PyPI. (Pull #1278)

* pip now generates the appropriate platform-specific console scripts when
  installing wheels. (Pull #1251)

* Pip now confirms a wheel is supported when installing directly from a path or
  url. (Pull #1315)

* Fixed #1097, ``--ignore-installed`` now behaves again as designed, after it was
  unintentionally broke in v0.8.3 when fixing Issue #14 (Pull #1352).

* Fixed a bug where global scripts were being removed when uninstalling --user
  installed packages (Pull #1353).

* Fixed #1163, --user wasn't being respected when installing scripts from wheels (Pull #1176).

* Fixed #1150, we now assume '_' means '-' in versions from wheel filenames (Pull #1158).

* Fixed #219, error when using --log with a failed install (Pull #1205).

* Fixed #1131, logging was buffered and choppy in Python 3.

* Fixed #70,  --timeout was being ignored (Pull #1202).

* Fixed #772, error when setting PIP_EXISTS_ACTION (Pull #1201).

* Added colors to the logging output in order to draw attention to important
  warnings and errors. (Pull #1109)

* Added warnings when using an insecure index, find-link, or dependency link. (Pull #1121)

* Added support for installing packages from a subdirectory using the ``subdirectory``
  editable option. ( Pull #1082 )

* Fixed #1192. "TypeError: bad operand type for unary" in some cases when
  installing wheels using --find-links (Pull #1218).

* Fixed #1133 and #317. Archive contents are now written based on system
  defaults and umask (i.e. permissions are not preserved), except that regular
  files with any execute permissions have the equivalent of "chmod +x" applied
  after being written (Pull #1146).

* PreviousBuildDirError now returns a non-zero exit code and prevents the
  previous build dir from being cleaned in all cases (Pull #1162).

* Renamed --allow-insecure to --allow-unverified, however the old name will
  continue to work for a period of time.

* Fixed #1006, error when installing local projects with symlinks in Python 3.

* The previously hidden ``--log-file`` otion, is now shown as a general option.

1.4.1 (2013-08-07)
------------------

* **New Signing Key** Release 1.4.1 is using a different key than normal with
  fingerprint: 7C6B 7C5D 5E2B 6356 A926 F04F 6E3C BCE9 3372 DCFA
* Fixed issues with installing from pybundle files
* Fixed error when sysconfig module throws an exception
* Don't ignore already installed pre-releases
* Fixes related to upgrading setuptools
* Fixes so that --download works with wheel archives
* Fixes related to recognizing and cleaning global build dirs
  • Loading branch information
rodent committed Jan 16, 2014
1 parent 1958df8 commit 99b1efe
Show file tree
Hide file tree
Showing 3 changed files with 418 additions and 174 deletions.
8 changes: 6 additions & 2 deletions devel/py-pip/Makefile
Original file line number Diff line number Diff line change
@@ -1,10 +1,11 @@
# $NetBSD: Makefile,v 1.6 2013/07/25 15:11:59 wen Exp $
# $NetBSD: Makefile,v 1.7 2014/01/16 02:40:15 rodent Exp $
#

DISTNAME= pip-1.4
DISTNAME= pip-1.5
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel
MASTER_SITES= http://pypi.python.org/packages/source/p/pip/
FETCH_USING= curl

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.pip-installer.org/
Expand All @@ -13,5 +14,8 @@ LICENSE= mit

PLIST_SUBST+= PYVERSSUFFIX="${PYVERSSUFFIX}"

REPLACE_PYTHON+= pip/__init__.py pip/_vendor/requests/certs.py

.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"
Loading

0 comments on commit 99b1efe

Please sign in to comment.