Skip to content

Commit

Permalink
Update to 1.1.2
Browse files Browse the repository at this point in the history
Remove BROKEN mark(build without Internet access)

Upstream changes:
## 1.1.2 (2016-09-30) **CRAN**

* [BUGFIX] round(), snprintf() is not C++98

-------------------------------------------------------------------------------

## 1.1.1 (2016-05-25) **CRAN**

* [BUGFIX] #214: allow a regex pattern like `.*`  to match an empty string.

* [BUGFIX] #210: `stri_replace_all_fixed(c("1", "NULL"), "NULL", NA)`
now results in `c("1", NA)`.

* [NEW FEATURE] #199: `stri_sub<-` now allows for ignoring `NA` locations
(a new `omit_na` argument added).

* [NEW FEATURE] #207: `stri_sub<-` now allows for substring insertions
(via `length=0`).

* [NEW FUNCTION] #124: `stri_subset<-` functions added.

* [NEW FEATURE] #216: `stri_detect`, `stri_subset`, `stri_subset<-` gained
a `negate` argument.

* [NEW FUNCTION] #175: `stri_join_list` concatenates all strings
in a list of character vectors. Useful with, e.g., `stri_extract_all_regex`,
`stri_extract_all_words` etc.
  • Loading branch information
wen committed Dec 18, 2016
1 parent 28be51f commit 50da130
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 19 deletions.
7 changes: 2 additions & 5 deletions textproc/R-stringi/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
# $NetBSD: Makefile,v 1.4 2016/12/04 05:17:42 ryoon Exp $
# $NetBSD: Makefile,v 1.5 2016/12/18 02:18:39 wen Exp $

PKGREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_R_CRAN:=contrib/}

Expand All @@ -10,12 +9,10 @@ COMMENT= Character String Processing Facilities
LICENSE= modified-bsd

R_PKGNAME= stringi
R_PKGVER= 1.0-1
R_PKGVER= 1.1.2

USE_LANGUAGES= c c++

BROKEN= "downloads during build"

.include "../../textproc/icu/buildlink3.mk"
.include "../../math/R/Makefile.extension"
.include "../../mk/bsd.pkg.mk"
12 changes: 6 additions & 6 deletions textproc/R-stringi/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.1 2016/01/01 12:59:19 wen Exp $
$NetBSD: distinfo,v 1.2 2016/12/18 02:18:39 wen Exp $

SHA1 (R/stringi_1.0-1.tar.gz) = b9fdcd23ae8950ea527574b74139ad74678b739f
RMD160 (R/stringi_1.0-1.tar.gz) = df1e9d90a7ba33cad66bfc37fcd54f02b43e4db4
SHA512 (R/stringi_1.0-1.tar.gz) = 5ec12d90234f28ac882785ddf2040130d2861870004f76a04bc68261129d77e4b4ef3c3cc9824023ead5be62726ce6a7cce0d10815f3173a28b8d8ca4681b38d
Size (R/stringi_1.0-1.tar.gz) = 3643002 bytes
SHA1 (patch-configure) = b466f9106db9c326a89e431ded9bad2172e1689a
SHA1 (R/stringi_1.1.2.tar.gz) = 983c527ef51ca441def25438b7a4829de563deaa
RMD160 (R/stringi_1.1.2.tar.gz) = 56745cd4bec327c42e6bbbde085b7a10acc1c676
SHA512 (R/stringi_1.1.2.tar.gz) = 8145fa8c08146ca9a1d7d64cc4f0b5f4803231c860c5363f155826996c1f739964cd3b92d655335413508d56771c6debc14261b801c99d2f30c8d8b325bec253
Size (R/stringi_1.1.2.tar.gz) = 3644855 bytes
SHA1 (patch-configure) = 25897b9a905b9761f1d23a1a0b0177d61a3a1ab9
16 changes: 8 additions & 8 deletions textproc/R-stringi/patches/patch-configure
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: patch-configure,v 1.1 2016/01/01 12:59:19 wen Exp $
$NetBSD: patch-configure,v 1.2 2016/12/18 02:18:39 wen Exp $
Fix configure
--- configure.orig 2016-01-01 12:33:03.000000000 +0000
--- configure.orig 2016-12-17 12:43:37.000000000 +0000
+++ configure
@@ -2205,7 +2205,7 @@ if test "${enable_gcc_debug+set}" = set;
enableval=$enable_gcc_debug;
Expand Down Expand Up @@ -53,21 +53,21 @@ Fix configure
with_extra_cflags="${with_extra_cflags} -Wall -Wextra -ansi -pedantic -std=c99"
with_extra_cxxflags="${with_extra_cxxflags} -Wall -Wextra -ansi -pedantic -std=c++98 -Wlong-long"
fi
@@ -2389,7 +2389,7 @@ CPPFLAGS=`"${R_PATH}" CMD config CPPFLAG
@@ -2391,7 +2391,7 @@ CPPFLAGS=`"${R_PATH}" CMD config CPPFLAG
LIBS=
LDFLAGS=

-if test "x$enable_cxx11" == "xyes"; then
+if test "x$enable_cxx11" = "xyes"; then
CXX="`\"${R_PATH}\" CMD config CXX1X` `\"${R_PATH}\" CMD config CXX1XSTD`"
CXXFLAGS=`"${R_PATH}" CMD config CXX1XFLAGS`
STRINGI_CXXSTD="CXX_STD=CXX11"
@@ -4054,7 +4054,7 @@ CPP_OK=0
CXX_tmp1=`"${R_PATH}" CMD config CXX1X`
CXX_tmp2=`"${R_PATH}" CMD config CXX1XSTD`
CXX="${CXX_tmp1} ${CXX_tmp2}"
@@ -4062,7 +4062,7 @@ CPP_OK=0
check_cpp

if test $CPP_OK = 0; then
- if test "x$enable_cxx11" == "xyes"; then
+ if test "x$enable_cxx11" = "xyes"; then
echo "*** trying with disabled C++11 compiler"
CXX=`"${R_PATH}" CMD config CXX`
CXXFLAGS=`"${R_PATH}" CMD config CXXFLAGS`
CXXFLAGS_base=`"${R_PATH}" CMD config CXXFLAGS`

0 comments on commit 50da130

Please sign in to comment.