Skip to content

Commit

Permalink
Update to 6.0.2:
Browse files Browse the repository at this point in the history
-----
6.0.2
-----

* Issue #262: Fixed regression in pip install due to egg-info directories
  being omitted. Re-opens Issue #118.

-----
6.0.1
-----

* Issue #259: Fixed regression with namespace package handling on ``single
  version, externally managed`` installs.

---
6.0
---

* Issue #100: When building a distribution, Setuptools will no longer match
  default files using platform-dependent case sensitivity, but rather will
  only match the files if their case matches exactly. As a result, on Windows
  and other case-insensitive file systems, files with names such as
  'readme.txt' or 'README.TXT' will be omitted from the distribution and a
  warning will be issued indicating that 'README.txt' was not found. Other
  filenames affected are:

    - README.rst
    - README
    - setup.cfg
    - setup.py (or the script name)
    - test/test*.py

  Any users producing distributions with filenames that match those above
  case-insensitively, but not case-sensitively, should rename those files in
  their repository for better portability.
* Pull Request #72: When using ``single_version_externally_managed``, the
  exclusion list now includes Python 3.2 ``__pycache__`` entries.
* Pull Request #76 and Pull Request #78: lines in top_level.txt are now
  ordered deterministically.
* Issue #118: The egg-info directory is now no longer included in the list
  of outputs.
* Issue #258: Setuptools now patches distutils msvc9compiler to
  recognize the specially-packaged compiler package for easy extension module
  support on Python 2.6, 2.7, and 3.2.

---
5.8
---

* Issue #237: ``pkg_resources`` now uses explicit detection of Python 2 vs.
  Python 3, supporting environments where builtins have been patched to make
  Python 3 look more like Python 2.
  • Loading branch information
wiz committed Oct 1, 2014
1 parent 2fa61e6 commit 4e27588
Show file tree
Hide file tree
Showing 3 changed files with 16 additions and 7 deletions.
4 changes: 2 additions & 2 deletions devel/py-setuptools/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.51 2014/08/17 16:32:36 wiz Exp $
# $NetBSD: Makefile,v 1.52 2014/10/01 12:25:44 wiz Exp $

EGG_VERSION= 5.7
EGG_VERSION= 6.0.2
DISTNAME= setuptools-${EGG_VERSION}
EGG_NAME= setuptools-${EGG_VERSION}
PKGNAME= ${PYPKGPREFIX}-setuptools-${EGG_VERSION}
Expand Down
11 changes: 10 additions & 1 deletion devel/py-setuptools/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.18 2014/07/22 10:00:06 wiz Exp $
@comment $NetBSD: PLIST,v 1.19 2014/10/01 12:25:44 wiz Exp $
bin/easy_install-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
Expand Down Expand Up @@ -103,6 +103,9 @@ ${PYSITELIB}/setuptools/extension.pyo
${PYSITELIB}/setuptools/lib2to3_ex.py
${PYSITELIB}/setuptools/lib2to3_ex.pyc
${PYSITELIB}/setuptools/lib2to3_ex.pyo
${PYSITELIB}/setuptools/msvc9_support.py
${PYSITELIB}/setuptools/msvc9_support.pyc
${PYSITELIB}/setuptools/msvc9_support.pyo
${PYSITELIB}/setuptools/package_index.py
${PYSITELIB}/setuptools/package_index.pyc
${PYSITELIB}/setuptools/package_index.pyo
Expand Down Expand Up @@ -171,6 +174,9 @@ ${PYSITELIB}/setuptools/tests/test_integration.pyo
${PYSITELIB}/setuptools/tests/test_markerlib.py
${PYSITELIB}/setuptools/tests/test_markerlib.pyc
${PYSITELIB}/setuptools/tests/test_markerlib.pyo
${PYSITELIB}/setuptools/tests/test_msvc9compiler.py
${PYSITELIB}/setuptools/tests/test_msvc9compiler.pyc
${PYSITELIB}/setuptools/tests/test_msvc9compiler.pyo
${PYSITELIB}/setuptools/tests/test_packageindex.py
${PYSITELIB}/setuptools/tests/test_packageindex.pyc
${PYSITELIB}/setuptools/tests/test_packageindex.pyo
Expand All @@ -195,6 +201,9 @@ ${PYSITELIB}/setuptools/tests/test_upload_docs.pyo
${PYSITELIB}/setuptools/unicode_utils.py
${PYSITELIB}/setuptools/unicode_utils.pyc
${PYSITELIB}/setuptools/unicode_utils.pyo
${PYSITELIB}/setuptools/utils.py
${PYSITELIB}/setuptools/utils.pyc
${PYSITELIB}/setuptools/utils.pyo
${PYSITELIB}/setuptools/version.py
${PYSITELIB}/setuptools/version.pyc
${PYSITELIB}/setuptools/version.pyo
8 changes: 4 additions & 4 deletions devel/py-setuptools/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.31 2014/08/17 16:32:36 wiz Exp $
$NetBSD: distinfo,v 1.32 2014/10/01 12:25:44 wiz Exp $

SHA1 (setuptools-5.7.tar.gz) = 807552212cda409b074e0e55630c3801a39eb198
RMD160 (setuptools-5.7.tar.gz) = ee9eff6c77e6f27e22e2049a6685bb0e624f94b0
Size (setuptools-5.7.tar.gz) = 1018789 bytes
SHA1 (setuptools-6.0.2.tar.gz) = a29a81b7913151697cb15b069844af75d441408f
RMD160 (setuptools-6.0.2.tar.gz) = 5040f99a8ee3cd5b4040dc1e0a4d7cd9d5e7f7b1
Size (setuptools-6.0.2.tar.gz) = 789143 bytes
SHA1 (patch-setup.py) = be1078e5e2b6e9ec8c859c2c6e2a4a44fe3c2840

0 comments on commit 4e27588

Please sign in to comment.