Skip to content

Commit

Permalink
Update to 20131010. From the changelog:
Browse files Browse the repository at this point in the history
Incompatible Changes:
* can no longer use both `\' and `:' (didn't work anyway)

New Features:
* Handling of run-time errors (default: die) is now overridable by
  subclasses via signature_error_handler(). [github #54]
* Can now have aliased named parameters. [github #57]
* remove dependency on Devel::BeginLift [github #39]
* can now use `when' to specify default conditions [github #48]
* can use `//=' as a shortcut for `when undef' [github #45]
* can now provide `where' constraints in addition to (or instead
  of) a type [github #7]
* can now use `...' to disable further argument checking [github #49]
* can now specify more than one alternative in type unions [github #55]
* can now nest parameterized types

Bug Fixes:
* Removed experimental smartmatch warnings
* Don't require Data::Alias for named params unless you have to [github #71]
* Fixed obscure bug where an eval in Method::Signatures wouldn't
  be skipped when carp'ing (i.e. in carp_location_for()) [github #72]
* Data::Alias is only loaded when needed avoiding a threads + eval
  bug in most cases and improving compile time performance.
  [rt.cpan.org 82922, github #62]
* Compile-time errors now reporting proper line numbers. [github #61]
* Trailing commas on parameter lists are now ok. [rt.cpan.org 81364]
* Default condition of `when {}' now interpreted as `when { $_ ~~
  {} }' (avoids parse error). [github #60]

Optimizations:
* better signature parsing using PPI [github #11]

Distribution Fixes:
* Fixed failing test in 5.10.0 (uncovered by CPAN Testers)
* Fixed repo link in metadata (thanks dsteinbrunner) [github #87]
* Add M::S::Parameter to MANIFEST [github #76]
* Change representation of Infinity to work on Win32 [github #75]
* Fixed stray detritus in MANIFEST.
* Somehow my last-minute fix to the new error handler test didn't
  make it in; this will fix "Can't locate Moose.pm" errors.
* Fixed test failing on 5.10.0 as per github #59.
* Fixed subtests failing on Test::More's prior to 0.96.

Docs:
* Updated close parend problem to include quotes and a workaround
  [rt.cpan.org 85925]
* Fixed some typos (thanks dsteinbrunner) [github #88]
* Found and fixed missing parend
* Minor clarifications here and there.
* Clarified what doesn't work in Perl 5.8.
* Added Function::Parameters to See Also section.
* Updated copyright.
* documented all new features
* new ASCI-art breakdown of signature syntax
* minor tweaks and corrections

Misc:
* Rearranged so signature is now an object [github #30]
* Add hook for Travis CI [github #78]
* Failure to parse parameters will now produce a more useful error.
  • Loading branch information
schmonz committed Jan 2, 2014
1 parent acaf095 commit 315b9c2
Show file tree
Hide file tree
Showing 2 changed files with 7 additions and 7 deletions.
6 changes: 3 additions & 3 deletions devel/p5-Method-Signatures/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.5 2013/05/31 12:40:29 wiz Exp $
# $NetBSD: Makefile,v 1.6 2014/01/02 16:27:12 schmonz Exp $

DISTNAME= Method-Signatures-20120523
DISTNAME= Method-Signatures-20131010
PKGNAME= p5-${DISTNAME}
PKGREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=../../authors/id/B/BA/BAREFOOT/}
#MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Method/}
Expand All @@ -18,6 +17,7 @@ DEPENDS+= p5-Data-Alias>=1.08:../../devel/p5-Data-Alias
DEPENDS+= p5-Devel-BeginLift>=0.001001:../../devel/p5-Devel-BeginLift
DEPENDS+= p5-Devel-Declare>=0.006002:../../devel/p5-Devel-Declare
DEPENDS+= p5-Devel-Pragma>=0.40:../../devel/p5-Devel-Pragma
DEPENDS+= p5-experimental>=0.005:../../devel/p5-experimental
DEPENDS+= p5-PPI>=1.203:../../devel/p5-PPI
DEPENDS+= p5-Mouse>=0.64:../../devel/p5-Mouse
DEPENDS+= p5-Sub-Name>=0.03:../../devel/p5-Sub-Name
Expand Down
8 changes: 4 additions & 4 deletions devel/p5-Method-Signatures/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2012/07/06 11:01:06 sno Exp $
$NetBSD: distinfo,v 1.3 2014/01/02 16:27:12 schmonz Exp $

SHA1 (Method-Signatures-20120523.tar.gz) = dfbc867d8d73a9a5b19d431701a0a18356ba5bab
RMD160 (Method-Signatures-20120523.tar.gz) = c92276f395a99853b94a27de13ccbfb33b0b9169
Size (Method-Signatures-20120523.tar.gz) = 47908 bytes
SHA1 (Method-Signatures-20131010.tar.gz) = 512abadc451e1c054003c48a6a6a4fa407ae62c2
RMD160 (Method-Signatures-20131010.tar.gz) = 198f52bee53e776be1b949b67d5e2426cab7de37
Size (Method-Signatures-20131010.tar.gz) = 64689 bytes

0 comments on commit 315b9c2

Please sign in to comment.