Skip to content

Commit

Permalink
Update to 2.1, from Wen Heping(myself) in PR 43395
Browse files Browse the repository at this point in the history
Add LICENSE
Remove unneeded MESSAGE file

Upstream changes:
Version 2.1
----------------------------------------------------------------------
* Fixed bug 196 "clustalx: user feedback about use of secondary structure
  printed to console" - secondary structure is now used if specified
  in Alignment -> Alignment Parameters -> Secondary Structure Parameters
  UserParameters->getGui() should be used when ClustalW code needs to
  know if a function has been called from ClustalX

* Fixed bug 204 "Nexus alignment format contain invalid line" - the amino
  acid alphabet line has been removed

* Missing/corrupted file names in ClustalX status messages have been
  fixed

* Fixed bug 175 "msf/pileup files cannot be read if sequences names are
  all numbers" - this happened if a line such as
528244          .......... .......... .......... .......... ..........
  was present in the first block of the file

* Fixed bug 192 "Alignment in Phylip Format broken for big Alignments"

* Fixed bug 198 "Warning about divergent sequences gets printed to
  console in ClustalX"

* Fixed bug 151 "clustalx doesn't switch to profile alignment mode when
  profile12 is given on cmdline"

----------------------------------------------------------------------
Version 2.0.12
----------------------------------------------------------------------

* Fixed bug 189 "Fixed filename used for iteration":
Now Creating temporary file and added error check

* Fixed bug 180 "Pairwise NJ tree: final bracket missing"

* Fixed bug 178 "Seg-fault on 64bit when -quicktree -upgma for sequences with high identity":
  Using relative error now to avoid unsafe comparison which led to
  incorrect branching

* Fixed Bug 176 "iteration doesn't iterate if -usetree is used as well"

* Fixed bug 162 "percent identity file option in clustalW not working":
Added -pim as command line option. See help

* Fixed bug 155 "upgma trees cannot be read"

* Fixed bug 147 "report duplicate sequences":
 "ClustalW/X now report offending sequences which are empty, duplicates etc

* Fixed bug 134 "Exit when encountering unrecognized cmdline params":
ClustalW now exits when encountering invalid values for command line
arguments instead of just reverting to default values

* Fixed bug 185 "clustal alignments differ between interactive and commandline mode"
window-gap and ktuple initialisation now fixed and made the same
between commandline and interactive mode

* Fixed bug 184 "error messages are send to stdout"

* Fixed bug when weights are 0, and nseq > INT_SCALE_FACTOR in UPGMA
  code (see RootedGuideTree.cpp)

* General code cleanup
- Introduced return values where control reached end of non-void function
- Removed unused variables
- Removed comparison between signed and unsigned integer expressions
- Removed deprecated conversion from string constant to char*



----------------------------------------------------------------------
Version 2.0.11
----------------------------------------------------------------------

* fixed file extension bug 166 in interactive mode

* Fixed bug 169, memory violation for DNA/RNA k-tuple

* Cut down distance calculation, symmetric matrix


----------------------------------------------------------------------
Version 2.0.10
----------------------------------------------------------------------

* Fixed g++-4.3 compilation errors

* Added new -quiet command line flag

* Added new -stats=<file> command line flag

* Fixed bug 142: command separator can now be mixed "/" and "-" on all platforms

* Fixed bug 141: profile merging and saving failed

* Fixed bug 139: saving of column quality scores

* Updated help files (new flags, new colour parameter format)


----------------------------------------------------------------------
Version 2.0.9
----------------------------------------------------------------------

* GUI now responding and giving feedback during alignment

* automatic automake os detection

* new OS_ define (set by clustalw/configure clustalx/clustalx.pro)

* got rid of qt3 dependencies

* removed QScrollArea bug workaround (fixed in Qt 4.3)

* Fixed bug 135: Last sequence and last residue not displayed on MacOSX

* Fixed bug 123: secondary structure profile alignment in clustalX on Mac

* Fixed g++-4.3 build error (include climits.h)


----------------------------------------------------------------------
Version 2.0.8
----------------------------------------------------------------------

* Implemented maxseqlen cmdline switch

* Updated help-file

* Fixed Bug 123: loading profile using gap penalties (ClustalX, Mac)

* Fixed bug 133: providing profiles on command line fails (ClustalX)

* Fixed bug 125: Angle bracket inside sequence

* Fixed bug 129: Early exit on empty sequence

* Fixed a couple of possible memory leaks


----------------------------------------------------------------------
Version 2.0.7
----------------------------------------------------------------------

* Fixed bug 121: CRLF  in sequence names (Pearson) are not trimmed

* Fixed bug 122: convert option broken

* Fixed reopened bug 114: profile alignment input didn't work with new
  getSeqRange routines

* Fixed bug 119: build with g++ 4.3

----------------------------------------------------------------------
Version 2.0.6
----------------------------------------------------------------------

* Fixed bug 77: fasta input performance issue

* Fixed bug 114: segfault while doing profile alignment with secondary
  structure mask

* Removed unncessary id console output in EMBLFileParser.cpp

* Fixed Bugs 108 and 109 and allowed mixed-case command line options


----------------------------------------------------------------------
Version 2.0.5
----------------------------------------------------------------------

* Fixed bug 105: Disallowed combination of "Reset Gaps"
  and Iteration in GUI

* Fixed bug 104 "reset all gaps doesn't work"

* Changed command line separator for Mac to hyphen instead slash

* Fixed full command line parsing for ClustalX after help flag


----------------------------------------------------------------------
Version 2.0.4
----------------------------------------------------------------------

* Updated URLs in help files

* Fixed bug 96: error message when loading alignment with identical
  sequence names

* Made console output look more like 1.83

* Fixed bug 100: "Scores in clustalw2.0 don't match clustalw1.83"
  getMatrix was called with wrong scaling factor

* Fixed bug 99: "stars in input not ignored"
  Asterisks were changed to gaps in alignment

* New command line option: -fullhelp which dumps the built-in help
  file content.

* Quickfix for bug 94 "quicktree seqfault"


----------------------------------------------------------------------
<= Version 2.0.3
----------------------------------------------------------------------

* Added LICENSE file to distribution
This file contains the information about commercial licensing of
clustal as well as FAQ for licensing issues

* Added README file to distribution
This is the file that lists the files and directories on the Clustal
FTP site.  It also includes acknowledgements of people who have
contributed binaries

* Removed .pro Qt file from the distribution
pro-file should be generated anew using qmake and modified according
to build requirements, i.e. no need for version control.

* Fixed bug where ClustalX2 was not processing command line args

* Fixed Segfault on opening helpfile.  Happened on Linux only with -O2
and when calling binary directly, not using the wrapper

* Added debian packaging files

* Added support for help command line flag GUI/xmenus version
When requesting help file, graphical version of command line help is
displayed (1.83 tried to open clustalw help)

* Added complete automake (configure etc) system according to the
following websites:
- http://www.openismus.com/documents/linux/automake/automake.shtml
- http://www.bioinf.uni-freiburg.de/~mmann/HowTo/automake.html

* clustalw files source files have been moved to subdir

* Fixed bug #53 change MAXNAMESTODISPLAY back to 10 from 30.
This fixes problem of large amount of space between sequence name and
actual alignment in clustal output files

* This solves bug #72 with long lines (5000+) in fasta files
changed code to use strings rather than arrays.  Needed to add delim
parameter to getline in order to read files formatted for different
OSs on different platforms.

* Fixed Bug 79:
"The count of amino acids in the ClustalX Postscript output not correct"
Off-by-one issue

* ClustalX and ClustalW version numbers are now the same and defined in
ClustalW code (automake)

* Fixed problem with compilation of ClustalX2 with gcc3
avoiding gcc3 error message: cannot declare member function
QDir::currentPath'

* Target now clustalw2 instead of clustalw

* Fixed Bug 46
added in aminoacid code O for pyrrolysine

* Fixed bug 89
changed clustalw2.0 to conform to 1.83 behaviour for width of sequence
ID and alignment

* Fixed bug 90
changed clustalw2.0 to conform to 1.83 behaviour leading spaces are
stripped from FASTA identifiers.

* Fixed bug 91
Clustalw2.0 now handles pseudo-FASTA/MoST format files. Strips out
numbers and spaces.
  • Loading branch information
wen committed Dec 13, 2012
1 parent 373b6c6 commit 21a7bec
Show file tree
Hide file tree
Showing 7 changed files with 13 additions and 94 deletions.
18 changes: 0 additions & 18 deletions biology/clustalw/MESSAGE

This file was deleted.

30 changes: 7 additions & 23 deletions biology/clustalw/Makefile
Original file line number Diff line number Diff line change
@@ -1,36 +1,20 @@
# $NetBSD: Makefile,v 1.12 2012/09/11 20:32:11 asau Exp $
# $NetBSD: Makefile,v 1.13 2012/12/13 13:27:13 wen Exp $

DISTNAME= clustalw1.83.UNIX
PKGNAME= clustalw-1.83
DISTNAME= clustalw-2.1
CATEGORIES= biology
MASTER_SITES= ftp://ftp-igbmc.u-strasbg.fr/pub/ClustalW/ \
ftp://ftp.ebi.ac.uk/pub/software/unix/clustalw/
MASTER_SITES= ftp://ftp.ebi.ac.uk/pub/software/clustalw2/2.1/ \
http://www.clustal.org/download/current/

MAINTAINER= babafou@babafou.eu.org
HOMEPAGE= http://bips.u-strasbg.fr/fr/Documentation/ClustalW/
COMMENT= General purpose multiple alignment program for DNA or proteins
LICENSE= gnu-gpl-v3 AND gnu-lgpl-v3

PKG_INSTALLATION_TYPES= overwrite pkgviews

MAKE_FILE= makefile
BUILD_TARGET= clustalw
WRKSRC= ${WRKDIR}/clustalw1.83

MAKE_FLAGS+= CC=${CC:Q}
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++

INSTALLATION_DIRS= bin

post-patch:
@${SED} -e 's:@PREFIX@:${PREFIX}:' < ${WRKSRC}/clustalw.c \
> ${WRKSRC}/clustalw.c.tmp \
&& ${MV} ${WRKSRC}/clustalw.c.tmp ${WRKSRC}/clustalw.c

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/clustalw ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/clustalw
for f in clustalv.doc clustalw.doc clustalw.ms clustalw_help; do \
${INSTALL_DATA} ${WRKSRC}/$$f \
${DESTDIR}${PREFIX}/share/doc/clustalw; \
done

.include "../../mk/bsd.pkg.mk"
8 changes: 2 additions & 6 deletions biology/clustalw/PLIST
Original file line number Diff line number Diff line change
@@ -1,6 +1,2 @@
@comment $NetBSD: PLIST,v 1.2 2009/06/14 17:34:33 joerg Exp $
bin/clustalw
share/doc/clustalw/clustalv.doc
share/doc/clustalw/clustalw.doc
share/doc/clustalw/clustalw.ms
share/doc/clustalw/clustalw_help
@comment $NetBSD: PLIST,v 1.3 2012/12/13 13:27:13 wen Exp $
bin/clustalw2
11 changes: 4 additions & 7 deletions biology/clustalw/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,5 @@
$NetBSD: distinfo,v 1.5 2012/10/20 22:02:07 joerg Exp $
$NetBSD: distinfo,v 1.6 2012/12/13 13:27:13 wen Exp $

SHA1 (clustalw1.83.UNIX.tar.gz) = 801ce911749171471b7964a1cff93c53c876c282
RMD160 (clustalw1.83.UNIX.tar.gz) = 20c0ec7739be6747ae08220e5abf2bae412f039e
Size (clustalw1.83.UNIX.tar.gz) = 166863 bytes
SHA1 (patch-aa) = 96f95acb4a312c96440275ca65f7f908c9b9032f
SHA1 (patch-ab) = 75fb21b88132bdf18e7f6bc13d1d35051a1babea
SHA1 (patch-interface.c) = 4c5f76efee503d55aafec87edcb5cbb40f71579d
SHA1 (clustalw-2.1.tar.gz) = f29784f68585544baa77cbeca6392e533d4cf433
RMD160 (clustalw-2.1.tar.gz) = e193769955a6270797fcb039ca398a4b59d9248d
Size (clustalw-2.1.tar.gz) = 350761 bytes
13 changes: 0 additions & 13 deletions biology/clustalw/patches/patch-aa

This file was deleted.

14 changes: 0 additions & 14 deletions biology/clustalw/patches/patch-ab

This file was deleted.

13 changes: 0 additions & 13 deletions biology/clustalw/patches/patch-interface.c

This file was deleted.

0 comments on commit 21a7bec

Please sign in to comment.