Skip to content

Commit

Permalink
userland: Add missing EGL_CAST defines
Browse files Browse the repository at this point in the history
Needed by libepoxy

Signed-off-by: Andrea Galbusera <gizero@gmail.com>
  • Loading branch information
gizero authored and agherzan committed Jul 14, 2017
1 parent 4cff21e commit 1e1b50c
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
From 382e3b16cbcc09d825540d5bd3e45a2fca4484fe Mon Sep 17 00:00:00 2001
From: Andrea Galbusera <gizero@gmail.com>
Date: Fri, 14 Jul 2017 09:52:54 +0200
Subject: [PATCH] EGL/glplatform.h: define EGL_CAST

C++ / C typecast macros for special EGL handle values: used by libepoxy code
The definition comes from the updated version of this header in mesa.

Upstream-Status: Pending
---
interface/khronos/include/EGL/eglplatform.h | 7 +++++++
1 file changed, 7 insertions(+)

diff --git a/interface/khronos/include/EGL/eglplatform.h b/interface/khronos/include/EGL/eglplatform.h
index 1f7c930..c39d425 100644
--- a/interface/khronos/include/EGL/eglplatform.h
+++ b/interface/khronos/include/EGL/eglplatform.h
@@ -202,4 +202,11 @@ EGLAPI void EGLAPIENTRY BEGL_GetDefaultDriverInterfaces(BEGL_DriverInterfaces *i
#include "interface/khronos/common/khrn_client_mangle.h"
#endif

+/* C++ / C typecast macros for special EGL handle values */
+#if defined(__cplusplus)
+#define EGL_CAST(type, value) (static_cast<type>(value))
+#else
+#define EGL_CAST(type, value) ((type) (value))
+#endif
+
#endif /* __eglplatform_h */
--
2.7.4

1 change: 1 addition & 0 deletions recipes-graphics/userland/userland_git.bb
Original file line number Diff line number Diff line change
Expand Up @@ -34,6 +34,7 @@ SRC_URI = "\
file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
file://0013-Implement-triple-buffering-for-wayland.patch \
file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \
file://0015-EGL-glplatform.h-define-EGL_CAST.patch \
"
S = "${WORKDIR}/git"

Expand Down

0 comments on commit 1e1b50c

Please sign in to comment.