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PART 2: Basic WPF
App with SQL
Database
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Creating a new WPF App

Create a new WPF App(.NET Framework) Project

Create a new project
Recent project templates

T WPF App (MET Framework)

5+ HETWBE Application

Desktop

13 2 NETWPE A pplication

Desktop

gets o NETWHE Appiication

Select the .NET Framework 4.7.2 version

Configure your new project

WPF App (NET Framework) ¢ xam

Project name
WpfApp2
Location
Ch\Users\User\source\repos
Solution
Create new solution
Solution name (G)
WpfApp2

Place solution and project in the same directory

Framework

Desktop

.MET Framework 4.7.2

Click Create




Adding a class library

In your Solution Explorer go to your Solution tab and click Add -> New Project

Create a class library (.NET Framework)

Add a new project

Recent project templates.

[R5 Class Library (NET Fram:
[
8 Apr wary (.cl)

vindows  Library

Choose .NET Framework 4.7.2 and click create

Configure your new project

Class Library (NET Framework) ¢  Windows
Project name
ClassLibrany1

Location

Ch\Users\User\sourcehrepos\WpfApp2

Framework

MET Framework 4.7.2

To add your class library to your WPF Project as a reference

Go to your WPF Project in the solution explorer and click References -> Add Reference



Solution Explorer
Gf o-s0O@

Search Solution Explorer (Ctri+;)

& Solution ‘WpfAppZ' (2 of 2 projects)
4 ClassLibrary1

b Properties

& References

P C# Classl.cs

4 WpfApp2

[ & Pro pe rties

[ o
Add Reference...

Add Service Reference...
Add Analyzer...

Manage MuGet Packages...
Scope to This

M solution Explorer !

In the Reference Manager go to Projects and select your class library, then click OK

r

Reference Manager - WpfApp2 ? *
\ssemblies Search (Ctrl+E)

Prajects MNarne Path Name:

N ClassLibraryl Ch\Users\User\source\...  ClassLibrary1
Solution - -

b Shared Projects

b COM




Your class library is now added to your project and your solution explorer should look similar to this

Search Solution Explorer (Ctrl+;)
5 Solution "WpfApp2' (2 of 2 projects)
4 ClassLibrany1

b Properties

I & References

Pcu Classl.cs
4 WpfApp2

b & Properties

4 & References
Analyzers
ClassLibrany1
Microsoft.CSharp
PresentationCore
PresentationFramework
System

em.Core

em.Data.DataSetExtensions
rstemn. Met.Hitp

wsterm. X{aml

c
-
C
b
c
-
o
S
C
)

=
o
o0
o
o0
o0
o
o0
o0
o
o0
o
o0
o0

WindowsBase

{j App.config

We'll come back to your class library later in the project.



Installing the necessary NuGet Packages

Now let’s setup the necessary SQL database packages so we can use it in our WPF App

Go to your WPF Project in the solution explorer and open Manage NuGet Packages...

Go to browse, then search and install the following packages:

1. Microsoft.EntityFrameworkCore.Design (Version 3.1.32)
2. Microsoft.EntityFrameworkCore.Tools (Version 3.1.32)

3. Microsoft.EntityFrameworkCore.SqlServer (Version 3.1.32)

NuGet: WpfApp2® + X

Include prerclease

Microsoft.EntityFrameworkCore.Design @ by Microsoft, 365M downloads
Shared design-time components for Entity Framework Core toale
FrameworkC
me componer

Microsoft.EntityFrameworkCore.Relational.|
Shared design-time Entity Fram
This package version is deprecated.

NuGet: WpfApp2* & X MainWindowxaml

Browse Installed Updates

M ft. EntityFram, X | U Include prerelease

Microsoft.EntityFrameworkCore.Tools @ by Microsoft, 249M downloads
Entity Framework Core Tools for the NuGet Package Manager Console in Visual Studio.

Microsoft EntityFrameworkCore.Design
Shared desig omponents for Entity

Microsoft.EntityFrameworkCore.Tools.DotNet &

Entity Framework
This package version is deprecated.

ET Command Line Tools.

7 NuGet:WpfApp2® + M:

Browse Installed Updates

M ft EntityFramewc ve x - U Include prerelease

Microsoft.EntityFrameworkCore.SqlServer @ by Microsoft, 381M downloads
Microsoft SQL Server database provider for Entity Framewark Core.

Microsoft.EntityFrameworkCore
change tracking, updates, and
and other datab, gh a pr

Microsoft.EntityFrameworkCore.SqlServer.NetTopologyS v 12.9M downloads
for the M QL database

Figure 3: Microsoft.EntityFrameworkCore.SqlServer(Version 3.1.32)

7011 b

NuGet Package Manager: WpfApp2

Package source: nugek.org -

Microsoft.EntityFrameworkCore.Design @

Description

Entity Framew,

NuGet Package Manager: WpfApp2

Package source: nuget.org =

Install

or the NuGet Package Manage Visual Studio

mmands:

~
NuGet Package Manager: WpfApp2

Package source: nuget.org =




After each packages installs, Click OK in the Preview Changes Window

Preview Changes >

Visual Studio is about to make changes to this solution. Click OK
to proceed with the changes listed below.

WpfApp2

Installing:
I ft.Bcl.HashCode.1.1.1

.EntityFram
Er1t|1:r ‘Fram

tem. |_|_|rr'IFII nnv.-_-ntl" Aodel.A

m. f"Jurr'lv.-_-rlcr Wi

n’rlg u rati on.
n’rl;uratln .

pticns.
[ ching.
System.Collections.Immutable.1.7.1

Do not show this again C Cancel




Accept the License for each installation

r

License Acceptance x

The following package(s) require that you accept their license terms before
installing.

Microsoft.Extensions.Configuration Author(s): Microsoft
Apache-2.0

Microsoft.Extensions.Logging.Abstractions Author(s): Microsoft
Apache-2.0

Microsoft.EntityFrameworkCore.Analyzers Author(s): Microsoft
Apache-2.0

Microsoft.EntityFrameworkCore.Tools Author(s): Microsoft
Apache-2.0

Microsoft.EntityFrameworkCore.Abstractions Author(s): Microsoft

Apache-2.0

Microsoft.Extensions.Caching.Abstractions Author(s): Microsoft

Apache-2.0

Microsoft.Extensions.Configuration.Abstractions Author(s):
Microsoft

v

By clicking "l Accept," you agree to the license terms for the package(s) listed
above. If you do not agree to the license terms, click "l Decline."

| Accept | Decline

After the packages are installed, in your NuGet Package Manager go to Installed to view your
installed packages.

If visual studio is not displaying all the installed packages, then Save your project then close and
open Visual Studio.

Now Open Manage NuGet Packages... -> and refresh your Installed packages

Now your project is setup in .NET Framework with a connected class library and all the required
packages ready to perform SQL functions for data persistence



Creating the SQL Database

Let’s move on to create the SQL Database where you’ll be persisting your data to

Go to your project in the solution explorer and Add -> New Item

= Solution 'V fApp2' (2 of 2 projects)
I ClassLibrary1
4 [y Build
" Rebuild
Clean
View
Analyze and Code Cleanup

Publish...

Mew [tem... Ctrl+Shift+A

Existing ltem... Shift+Alt+A

I older &  Set as Startup Project

REST API Client... Debug

Machine Learning Model... Initialize Interactive with Project

Reference... o Cut

Remove

Rename

Unload Projec
Window (WPF]... Load Direct Dependencies
Page (WPF)... Load Entire Dependency Tree

User Control (WPF)... Copy Full Path

Resource Dictionany (V * Open Folder in File Explorer

Class... Open in Terminal
Yesign in Blend...
New EditorConfig e

New EditorConfig (IntelliCode) e

Ln: 1 Ch: 1 SPC

Alt+Enter




Under C# click on Data -> Service Based Database

Default = Search (Ctrl+E) R~

ADO.NET Entity Data Model C# Type: C#
An empty St er database for service-
DataSet C2 based data acc

EF 5.x DbContext Generator
EF 6.x DbContext Generator

Storm Items - -
Service-based Database

b Tni Service-based Database
| XML File e

XML Schema

K5LT File

Name: Databasel.mdf

Cancel

Change the name or leave it as default, then click Add

The database should then appear in your solution explorer as of type mdf like this

Solution Explorer

g o-sOEIH
Search Solution Explorer (Ctrl+;)
03 Solution 'WpfApp2' (2 of 2 projects)
[ ClassLibrany1
4 WpfApp2
A Properties
I &4 References

a| App.config
I Appxaml
[ Databasel.mdf

7] Databasel_log.Idf
|:'] MainWindow.xaml
4| packages.config
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Creating a database table

Now in the solution explorer double click on the blue mdf file. Your database should appear in the
server explorer on the left under Data Connections

Now right click on Tables -> Add New Table

Project  Build  Debug

Debug ~ A

» o M | nde

Data Connections
[C} Databasel.mdf

D Tahles
Add Mew Table

Mew Cuery
Refresh
Properties Alt+Enter

ssemblies

| DESKTOP-53UZ9MED

11



The Table Design window should appear with an area below to write T-SQL scripts

” File Edit View Git Project Build Debug Test Analyze Tools  Extensions

£) i - e E B Debug = AnyCPU ~ P Start ~ [>

-+

dbo.Table [Design] + > Classl.cs MainWindow.xaml MainWindow.xaml.cs
4 Update  Script File  dbo.Tablesql -
Mame Data Type Allow Nulls Default
0 | |d int |
|

Jato)dxg sz

S 108

1io0)dx3 algp 2R

3INog B1E(]

=]

0 Design 7 ti = TsgL |

B [dbe] . [Table]

[1d]

For an example database we are going to change the table name to Student with columns:

StudentID and StudentName
GDsion /1 _imwsar|
M= Student

StudentId
StudentName




Now click enter
It will process the T-SQL script

After the script is processed, navigate to the top just above the table and click Update
Preview Database Updates
Highlights
Mone
User actions
Create

[dba].[Student] (Table)

Supporting actions
Mone

Include transactional scripts

Generate Script | | Update Database | | Cancel

b

Make sure to Include transactional scripts and then click Update Database

Below the T-SQL in Data Tools Operations you should see your Update completed successfully

Data Tools Operations

©F Update tor [LocallB P MSYULLocalU B U SERS W USERGUURLENREFUSWREAF FAWFEAFF A UAIABASE |LMUE 112
+" Creating update previ
+ Displaying update p W

+" Creating database script...

+" Executing update script on database 'C:\USERS\USER\SOURCE\REPOS\WPFAPP2\WPFAPP2\DATABASEL.MDF'...

Update completed successful

; Operations
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Now open your Server Explorer and Refresh your Database and Tables. Your database should now
have the new Student Table added with the Studentld and StudentName columns

ile  Edit View Git Project Build Debug Test Analyze

I-IE| - B |E| =] Debug -~ Any CPU

er Explorer * 4 X Window.xaml
|eEa | -

[CT)|Data Connections Mulls Default
4 [} Databasel.mdf

4 [EF Tables i

4 [FR Student |

2 Studentld I

StudentMame

BT Stored Procedures
EX Functions
Bl Synonyms
Bl Types
EX Assemblies
4 = Servers
b [ DESKTOP-3US9MNGD

;
;
b
b
;
;

Now that our database is created, we now need a connection to the database.
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Locating the database connection string

You can find your database connection string by double clicking on your [database name].mdf file in
the Solution Explorer under Database properties

Solution Explorer
Search Solution Explorer (Ctrl+;)
[ Solution 'WpfApp2' (2 of 2 projects)
p ClassLibrary1
4 WpfApp2
[ "" Properties
# References
{j App.config
I Appxaml
] Databasel.mdf
] MainWindow.xaml

{j packages.config

Properties
Databasel.mdf Connection

O=:
o= | D4

B (ldentity)

(Mame)

B Connection
Connectio
Provider
State

Primary File
Right to left Reading order
Show Unicode control characters

Connection S Insert Unicode control character

You will need this connection string later in your application
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Creating the Form
Let’s move to the xaml design MainWidnow where we will create the Student form

MainWindow.xaml + > Main

~ EDWindow

Height: Widthr

| Grid
Window

To continue the basic Student example

e Add alabel for Student Name. Set the content="Student Name”
e Add a Textbox alongside it and give it a name of x:Name="StudentName”. Set the Text=""
e Add a button to save the data and double click on it to auto-generate an Onclick method

It should look something like this

Student Mame

16



Window - Window

XmLns : mc

mc : Ignorable
Title Height Width

Alignment
largin: Texthirapping A Width
Button x:MName Conte ntalAlignment Margin: che

Grid
Window

e Now let’s add a GridView and a button to retrieve all the Students saved in the database like
this.

e Set the ListView x:Name="StudentList”
e Set the button Content="Show Students” and double click it to auto-generate an Onclick method

FdainWindiow

Student Mame
Show Students

StudentMame

Window

LALignm g irapp LALig Width

Cantent \Lignme Margin er ignment Click

Name:
ListView.View
Gridiiew
GridViewColumn Header- DisplayMemberBinding="{E tudentName
GridView
ListView.View
ListWiew

The student form is now setup.

From here you’ll INSERT data into your database from the StudentName textbox when the Saved
Data button is clicked. You can then click on the Show Students button to populate the GridView
with a SELECT query showing all the records in the Students tables

We'll now be moving to the MainWindow.cs class

17



Writing to the database

Add the following code to within the SaveData Onclick method the functionality will be discussed

Main'W m MainWindow.xamlcs®* 1 X

Wpfhpp2 : WpfApp2 MainWindow
= System;
System_Data.Sqlclient;
System.Windows;

WpFapp2

InitializeComponent(]);

SaveData_ Click( sender, RoutedEvent

connectionString

insertQuery

command . Parameters. AddWithValue("
command . ExecuteNonQuery();

¥ .Show(StudentMame . Text +
ox _Show{"Error: " + ex_Message];

ShowStudentsEtn_Click(

Code breakdown:

e Inthe SaveData_Click method we’ve created an empty string for now to store the database’s
connection string called connectionString

e We've then added a try-catch block to test the code, run it if there are no errors and catch any
errors through a message box

In the try block

e We add a using clause to create a new connect to the database so that the connection can be
disposed of properly
e We then open the connection and alert the user if the connection is successful

18



Then we declare an INSERT query that’ll insert the student name input using a StudentName
Parameter which we define later

The SqlCommand binds the query to the specific database through the database connection
We then add a parameter for the student’s name input that takes the input as
StudentName.Text

After setting up the command we execute the command to actually run it

We then alert the user to show the input was added successfully

In the catch block

The application will run the try block line-by-line and throw the appropriate error when its
reached

19



Adding the connection string

Remember we have to add the connection string. To do this double click on your database.mdf file

Solution Explorer

Search Selution Explorer (Ctrl+;)

3 Solution "WpfAppd' (2 of 2 projects)

d ClassLibraryl
A Properties
- &1 References

P WpfApp2
A Properties
I & References

{] App.config
b [Y Appxaml
] Databasel.mdf
4 [ MainWindow.xan
B MainWindow.s
a,] packages.config

Properties
Database1.mdf Connection

a=:
==

E (ldentity)
(Mame)

B Connection
Connection String
Provider

State

CAUSERS\USERVSOURCE\REPOSY

sel.mdf;Integrated Security="True
MET Framework Data Provider fo
Closed

oft SOL Server

20



Copy the full connection string under database properties and paste it in the 2 quotation marks by
your connectionString. It should look something like this

MainWindow.xamles & X
WpfApp2 NpfApp2 MainWindow - g SaveData_Click(objq
3 Systen;
System.Data.SqlClient;
System.Windows;

wWpfapp2

SaveData_Click(

connectionString

command . Parameters. AddWithValue("@Studentiame®, StudentName.Text);
mand. nQuery();

tudentame Text +

" + ex_Message);

ShowStudentsBen_Click(

Writing to the database: Test

Now start the application and try entering some text into the textbox then click the Save Data
button

1 MainWindow = O *

Student Name
Show Students|

StudentMame

21



Student Name | Jeff

Show Students|

MainWindow.xamlcs + 3

G2 wpfApn2. MainWindow

StudentMame

Student Name  |Jeff

Show Students|

Connected Successfully

LofApp2 MainWindow

StudentMame

Jeff added successfully

Show(Studentiame Text

ex)

ox.Show("Error: " + ex_Message);

This is good but let’s query the database too see if Jeff was actually added.

To do this open your Server Explorer -> Right click on your database -> New Query

22



Server Explorer
Y8 3 | 1
[T/ Data Connections
4 [T} Databasel.mdf
4 [7 Tables
4 BH Student
A2 Studentld
H StudentMame
BEX Views
EX Stored Procedures
B¥ Functions
B3 Synonyms
B Types
EX Assemblies
SEMVeErs

ESKTOP-5U39N6D

MainWind

S5QLQuery2.sgl® + X

"" Properties

Npfappd.M

Refresh
Delet

Change ¥
Modify Connection...
Close Connection
Mew Query

Detach Database

Browse In S0L Server Object Explorer

Renam

Alt+Enter

MainWi

-0 v E wi m¥ CA\USERS\USER\SOURCE\REPOS\ =

Student|

Studentld  StudentMame

Congratulations! You now know how to insert data from your WPF app to your SQL database.

Now that we’ve added data to the database lets look at how to pull data from it and display the
results in a GridView. You'll now be working with the Show Students button Onclick method

In this case it’s the ShowStudentsBtn_Click method

Now would be a good time to Save All your work
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Adding the Student class to the class library

You'll need to use your class library now. Let’s rename the default class (Should be Class1.cs) to
Student.cs

* #  Solution Explorer

NG s M o /
Search Solution Explorer (Ctrl+;)
5 Solution "WpfApp2' (2 of 2 projects)
P ClassLibraryl
[ "" Properties
[ ®E References
CH Student.cs
P WpfApp2
b & Properies
[ #5 References
a] App.config
B [ Appxaml
] Databasel.mdf
4 [ MainWindow.xaml
B MainWindowxaml.cs

{j packages.config

In the student class add the two columns from the Student table in the database that we’ve earlier
created Studentld and StudentName

Student.cs 1 » MainWindow.cam MainWindo

ClassLibrary1

ClassLibraryl

StudentID {
StudentMame {

24



Cleaning up the code & adding a Collection of Students

Now let’s head back to MainWIndow.xaml.cs
First, let’s clean up our code by removing all the unnecessary usings

Since we are going to work with the database connection in 2 methods, we can optimize our code to
declare the connection string outside the SaveData_Click method so we can use it anywhere in this
class.

You can use any List or collection as long as it’s a data structure that you can manage properly but, in
this case, let’s use an ObservableCollection of type Student that’ll serve as our GridViews Item
Source

WpfApp2 pfApp2. MainWindow = (7 MainWindow()
=1 ClassLibraryl;

s _ObjectModel;
dent;

WpFApp2

[

‘ Initi.
st

|

inection{connectionString))

, con);

Adduithvalue(*es ", Studenthame.Text);

" + ex.Message);
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Retrieving data from the database and displaying it in a list

Add the following code to your ShowStudentsBtn_Click method and let’s unpack it in the code
breakdown

ShowStudentsBtn_Click( sender, Routed

uery, conl;

(5glDataReader reader = command.ExecuteReader(]))

while (reader.Read(])
i

nt student
StudentName reader[*5tudentName”] . ToString(],

| H

Students. Add(student);

i

catch (Exception ex])
i
MessageBox  Show("Error: " + ex_Message];

i

Let’s pop up the GridView we earlier created

ListWiew Margin
ListWiew. View
Gridview

GridviesColumn Header DisplayMemberBinding Binding StudentMame
Gridview
Listview.View
Listview

Notice how the DisplayMemberBinding is set to a Binding of StudentName

Code Breakdown:

e We establish a database connection and open it.

e We create a SQL query (selectQuery) to retrieve all data from the Student table.
e We create a SqlCommand object and execute the query.

e We use a SglDataReader to read the result set row by row.

e For each row, we create a Student object and populate its properties with data from the
database.

e The Student object is then added to the Students collection (an ObservableCollection<Student>).

e When you run the application and click the "Show Students" button, the data retrieved from the
database is stored in the Students collection.
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e The ListView is configured to display this data in the GridView columns, with each row
representing a Student object.

e The DisplayMemberBinding property of the GridViewColumn specifies which property of the
student object to display in that column.

Retrieving data from the database and displaying it in a list: Test
Run the application and see if the data displays all the students you’ve added

It should display something like when you click the Show students button

17 MainWindow — = O
Student Name
Show Students
StudentMName
Jeff
Mac
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